Issues with MacOS Sierra and both v.1.5.4 and 1.6.2



  • Has anybody had any issues with CSP since upgrading to Sierra? The most annoying issue is the Curve and Ruler tools have become a burden to use. Typically, while drawing a Continuous Curve, the line will stop drawing and complete the curve even though I haven't finished. Then there are other smaller issues, such as moving the canvas around when holding the space bar and using my Wacom Pen is hit and miss, requiring me to lift the pen and wait about 2 seconds if I need to move it again after moving it once.

    I'm using a Wacom Cintiq 27QHD on a late 2013 Macbook Pro. I've tested it with the new drivers, as well as reverting to the more dependable older drivers, but no luck.

    Any advice would be appreciated.



  • The only trouble I've had with Sierra and CSP (on iMac 2014 and Cintiq 27QHDT) was pen barrel rotation stopped working with pen settings, and I still can't pan with touch or trackpad. Can't understand why wacom or CSP won't make that happen.

    I tried upgrading to newest driver today and it was unusable. Whenever I used undo on the remote CSP would start cycling through different tools. I had to roll back to a previous driver.

    The only driver I've had that worked great with this cintiq and CSP and Sierra isn't available for download in the cintiq section on support site, but is in the Intuos Pro section. It 6.3.18-4. Try that one.



  • @PGross I'll try out that driver. Wacom has the worst software support, and I always feel like a second class citizen when it comes to CSP and support since it's primary customer base is in Japan, so who knows if this will ever get fixed.

    I'm about to get a new Macbook Pro, and I'm wondering if it's a hardware issue and getting a new computer will fix the issue. Are you able to use Continuous Curve with any success?

    I made a video of the issue (the first 3 seconds of the video is me hitting undo, fyi), it's most apparent at the :20sec mark.



  • @aaron just tried continuos curve tool and it works fine.



  • @PGross Thanks for checking.

    After further testing, it seems that things get wonky in the color picker, along with the ruler, curve tools, and dragging the screen. I have to tap the screen twice before dragging on the screen.

    I'm wondering if it's just older Macbook Pros running Sierra, or if this plagues the new (or newer) Macbook Pros with Sierra since there are those, like yourself, that aren't experiencing issues.



  • I couldn't wait any longer for Apple, Wacom, or Clip Studio to fix the problem (no idea who is responsible). I downgraded back down to El Capitan. Everything works again at least.



  • I'm new to this forum so forgive me if this issue has been resolved, but I've been experiencing the same issues when using the Polyline Marquee. At least I noticed the problem when using that tool, but after reading this I used the Curve and Ruler tools and they do have the same problem. Basically I start using the tool and the line will stop and complete the curve (or close the shape when using the Polyline marquee). This is really frustrating since I use those tools a lot.

    So basically, the answer is to downgrade to El Capitan? Now that is messy, but thanks @aaron for providing me with a solution. I had a couple of days trying to resolve this issue.

    If anyone knows or recommends any other way, please tell me.

    Thanks



  • @bielero What model of Mac do you have?

    If it's a Macbook Pro, is it a late 2013, early 2015, etc? I have a feeling that only certain hardware configs seems to be having this problem, and not all Macs running Sierra. At least this is my hope.

    I just ordered a new Macbook Pro 2016, but if the Sierra/Wacom issue is present on that, then I'm returning it and opting it for a machine that will run El Capitan. I suspect that the newer Macbooks wont be downgradable to El Capitan because of the Touchbar.



  • @aaron I have an iMac late 2012. I don't know what is causing the problem but I do have two more computers (one iMac even older and one Macbook Air) at home, so I'll try to see if they present the problem as well.

    I would assume it is not a Clip Studio Paint problem since if you use a mouse the problem disappears, but what do I know. I think it must be a Wacom driver problem with Sierra, because I tried using the polygonal tool in Photoshop and it was even worse than in CSP.

    Also, it seems that downgrading to El Capitan seems much more difficult than I thought. I wouldn't trust my technical abilities to pull this off. Now I'm really frustrated!



  • @aaron Well, I tried with the other iMac 2011 using El Capitan OS X and everything is fine! It just infuriates me that Wacom hasn't come up with drivers to solve this situation. In any case here is a link on the Wacom forum http://forum.wacom.eu/posting.php?mode=reply&f=5&t=51 so we can keep asking for a solution. Thanks again