anybody get crashes with BPT and GPU?



  • Yes, absolutely. Can't use branched path on my Titan X - crashes every time with GPU render.



  • Same here with my GeForce GTX 1060. It rendered a few tiles okay, but then crashed in the middle. I reckon it had something to do with transparency because it crashed when rendering the first tile with hair, but that could be coincidence. I'm also not sure if this will happen with newer drivers, but at the moment I have to use an older one (373.06) or else it will not render at all.



  • @grubendol JUst ran the Superfly test scene from @raven and got a crash when it got to the transmapped hair on Pauline.



  • You might want to checkout the link from @Y-Phil.

    I was getting the timeout errors until I made a similar registry change (set the timeout to 10 seconds).
    I'm able to render with Branch Path Tracing with my twin 960 GTX. However, I have to keep the bucket size at 64 or the timeout errors return.



  • @willdial If you're reducing the bucket size to 64, then you're massively utilising your GPU's capacity, and you might as well just turn BPR off and go that route. Or is there some advantage to BPR that I am missing?



  • @matb when you turn off BPT it also turns off sample all light direct and indirect. The result is a less accurate render. Some lights in your scene will not be calculated or reflected in glossy surfaces.



  • @ghostship Oh really! Well this is essential information! So the recommended method of rendering in the program with many graphics cards actually produces worse quality in two different ways (micro displacement is not supported in GPU rendering either). This is very irritating.



  • @ghostship

    BPT is great if you are rendering with CPU as usually CPU is slower in rendering in Cycles/SF or any CUDA specific renderer

    With BPT you don't need to have render image up to 80 samples (interior scene is good example),with BPT you can go away with 30-40 samples maybe less,didn't tried to render with BPT as I don't render with CPU in Poser and SuperFly...

    I posted while back, same scene ball and HDRi map, with GPU I needed to render up to 30 samples and CPU with BPT I needed only 5-10 samples only

    This is good link

    http://blender.stackexchange.com/questions/3256/what-is-branched-path-tracing-and-how-is-it-useful

    There is always cons if you use CPU or GPU in many renderers

    Personally I don't use at all BPT if I render with GPU, lowering bucket size is no point, renders will be slower with lower bucket size, with Maxwell generation I use 256 or 512 samples, for CPU 16-32 samples is good starting point...

    Hope this helps

    Thanks, Jura



  • I learned that without BPT oily/sweaty skin created with EZSkin3 is not properly rendered; it still looks rather matte, even if I crank up roll-off and reflection to 1. So there is a difference in the rendering result between BPT and non-BPT, although it depends on what you like best.
    Before it crashed at trans-mapped hair, my test GPU BPT render produced the same skin like the CPU run, so in my opinion there is - generally - no big difference between GPU and CPU if you use the same settings (with a few exceptions like the EZDome issue).
    I wonder if the GPU still cannot render volume shaders properly?



  • @grubendol Volume shaders seem to work fine in GPU with BPT turned off.



  • @ghostship Just to be clear: pure PT can not have setting "sample all lights...". It is impossible by design. So if you don't see light source in reflection in PT usually it is just not enough samples. For me enough can vary from 70 to 140.


  • Poser Ambassadors

    @ghostship Yep, renders just black on my site here.



  • @Ladonna if you plug your volume shader (scatter or absorption) into the surface input you will get black. You have to plug it into the volume port on the Cycles root.



  • @Ladonna here rendered with three different lighting setups. two area lights, envirosphere only, enviroshere plus infinite light.
    0_1484238508016_scatter example.jpg


  • Poser Ambassadors

    @ghostship Thanks, have to try like this. :)