Superfly transparency issues - NSFW!!!



  • Superfly seems to handle transparency differently. The M4 gens are connected by a hip which is blended using a transparency map. In firefly, this renders just fine from transparent to fully opaque, however with cycles, it has these black broken areas. It doesn't matter whether you use a poser surface root node and a traditional material, or a material specifically constructed for superfly using the cycles transparency configuration. Nor does it seem to matter which product's trans map you use. Has anyone got an idea how to get around this please? The only solution is to bury the hip in the pelvis slightly, which is of course, not very professional for commercial products.

    0_1484739685260_gens good.jpg

    Traditional firefly version

    0_1484739703129_gens bad.jpg

    Superfly version



  • Is the filtering of the transparency map (which in fact should be an opaque map) set to "none"?



  • In the hierarchy editor, turn off the visibility of the left and right thigh for the genital. That will remove the bad bit by the sides of the penis.

    I quickly (hence a small error still!) used the grouping tool to make a new material in the affected area in the pubic hair of the genital and used the morphing tool affecting the new material only to push the offending polys out of the way. You could then export the morph to apply anytime.

    0_1484744080845_genital_fix.jpg



  • @Y-Phil There is no filtering option when using superfly image map nodes. but thanks for the suggestion.



  • @raven Thanks for the visibility tip. The morphing one is less useful for my needs. I don't want people to have to start morphing geometry simply to fix something that was not broken in Firefly. Also, that solution requires personalisation for every body type - bulk, muscular, etc.


  • Poser Ambassadors

    @matb
    0_1484771613773_Filtering.jpg

    The Filtering is set when you load the Image or the transmap.
    Here it is on a Physical surface Color. => Default V4 and the texture filtering set to Crisp. => Black Arrow.

    For Transmaps, GC should be at 1.000 and the filtering set to "None" or "Crisp". All others "can" bring trouble sometimes.



  • Thank you for your suggestion Vilters but I'm not using the colour texture. Here is my node configuration. I'd certainly welcome your thoughts if you see anything I'm doing wrong?

    0_1484777236227_gen maps.jpg



  • Check the image you're using for the trans map. Does it have artifacts like one might get from a jpg? So many were created with jgps and have artifacts and firefly is more forgiving of those.



  • @redphantom Ahh well that's a distinct avenue to pursue. I'll check it out...


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.