Poser 11 Loading Preset Magnets To Wrong Figure



  • Copy/pasting from my R'osity thread:

    Let me see if I can keep this simple, 'cause it's kinda hard to explain.

    I open a figure in Poser, add morphs and play with the dials until I get the shape I want. I then load (for example) a pair of pants and want to use some preset magnets to help the pants conform to the shape of the figure's morphs. Once the magnet loads, it does not parent to the pants, it ends up parenting to the figure.

    So far, the only way I have found to get around this is to start a scene, load the pants, then load the magnet onto the pants. THEN I have to import the scene with the figure just so I can use the magnets properly.

    I have upgraded from Poser 7 to 11, so I don't know if this was an issue in past versions, but it seems like there is some option or setting that is preventing the magnets from parenting to the selected object rather than the figure. I have tried changing the figure names too (I don't get why Poser now calls the initial figure "Figure" instead of "Figure 1"), but that doesn't seem to work either. This has become very frustrating because it takes me twice as long to fit clothing to figures if I need to employ magnets, which the whole point of having them is to speed things up when you put them in your library as a preset option.

    On both R'osity and RDNA, the two replies I got both said they were having similar issues and were not a problem prior to 11. It seems that Poser forgets what to parent the magnets to and defaults to the main figure instead of the props/clothing I want it to. What's more, it doesn't do this with ALL magnets, so I'm at a loss trying to figure out why some work and some don't.

    I have actually loaded the magnet in a new scene with the prop I want it on and THEN added it to the library and get the same result. If I copy the magnet's parameters to a fully new magnet and then add to the library, it seems to work fine, but some of the magnet sets I have can have many, many magnets.

    I have the most recent SR update installed and that did not seem to alleviate the problem, though I suppose if SM doesn't know there's an issue, they can't fix it.

    I could probably also provide pics for this. I wish I could upload the offending magnets so people could try to recreate the issue, but none of them are mine, though most were free anyway.

    Any help on this would be awesome.



  • This is what I did

    1 load figure
    2 load pants and conform to figure
    3 crate magnet from object menu
    4 parent magnet to pants
    5 move magnet around and watch pants bulge and deform with magnet movements.



  • @cujoe_da_man said in Poser 11 Loading Preset Magnets To Wrong Figure:

    Any help on this would be awesome.

    IIRC, there was a post around here, somewhere, concerning how magnets are saved that might be helpful for you. Basically, it detailed how to save magnets correctly so they'd function/parent correctly when loaded. IIRC, you save the magnet with the magnet base selected instead of the "magnet" part or the magnet zone selected when you save. Though, it could be another part you're supposed to save... Hard to remember since I don't use magnets like that very often.

    Load the magnets, parent them appropriately, then try saving them with different parts selected for each test save. (Don't overwrite the original file!) One of them "should" parent appropriately, as you had them when they were correctly re-parented, when you load them up. I think... :) Try it and see!

    ie: Old magnet save format might not be fully compatible, so re-save the parented magnets with special bit selected during save.



  • @morkonan

    So far, none of that has worked, no matter how I save the magnet, it still wants to parent to the figure rather than the conforming prop.



  • @cujoe_da_man said in Poser 11 Loading Preset Magnets To Wrong Figure:

    @morkonan

    So far, none of that has worked, no matter how I save the magnet, it still wants to parent to the figure rather than the conforming prop.

    Ah, a conforming prop? A parented prop? Try unparenting the prop (Object-Parent-Universe) and then selecting the Prop and only then loading the Magnets. Afterwards, you can reparent/conform/whatever the prop to the figure.



  • OK, let me see if I can explain this........

    If you don't have the pants selected

    and the magnet is parented to say "body" or "hip"

    it's going to parent to the first body/hip it finds. And it's going to find those parts in the figure you have selected.

    It's not a bug, nor is it an error, really. It's parenting to the correct body part on the object you have selected in the scene. There's no way Poser can KNOW it's supposed to be the PANTS body it should be parenting to.



  • @Glitterati3D

    In other words - When loaded, it will search for that group in the figure/prop you currently have selected. If you have nothing selected, then it will search the Universe and mate with the first thing it finds... (Maybe not worded very nicely, at the end there... :D )



  • Ok, so when I do have the pants selected and it still parents the magnet to the main figure, what does that mean?

    I say prop to differentiate the pant object from the figure itself. What's more, when I open the hierarchy, it shows the magnet, base and the mag zone parented to the pants, but they do not show up on the pants. They only show up if you click on the figure. It's acting like some weird cross-talk where it visually parents in the hierarchy, but is actually parented to the figure, if that makes sense.



  • @morkonan It actually based on the hierarchy within Poser. Open the Heirarchy Window and look. When you conform an item to a figure, the figure is always at the top of the heirarchy, with the clothing below it.

    Oh, and I forgot to mention items named Figure are on the creator, not Poser. The creator named the item Figure.

    When you are in the Fitting Room and you click "Create Figure" it asks for a name. Most folks use something descriptive there and not "Figure" but if that's what you choose, that's what you get.

    You can change the item name on the Parameters/Properties Tab by clicking on the name field and typing in a descriptive name. It will, however, not remain unless you resave the file.



  • @cujoe_da_man Please post a screenshot of the hierarchy window.

    And what is supposed to be the PARENT of the magnets? Which body part?



  • I will start making up some screen shots, it will take me just a bit to do, BUT I kinda went on what others were saying about the hierarchy and tried a test. I loaded a pair of pants and then imported the test figure into the scene then conformed the pants to the figure. This put the pants at the top of the hierarchy instead of the figure. When I went to use the preset magnet, it parented to the pants instead of the figure this time. It seems Poser is putting parenting priority on whatever is in the scene first rather than what is selected, something previous versions have never done.



  • @cujoe_da_man Then the hierarchy is wrong. Confoming the pants should move the pants under the figure in the heirarchy. The figure becomes the parent, the pants the child. It doesn't matter in what order you load anything.

    If that is not happening, then that's the error in Poser.



  • 0_1485547475042_Mag test 1.jpg
    So, this first image shows the figure loaded into the scene and then the pants conformed to the figure. I'm using V3 for quick refs. I made the morph quite extreme just to show what happens, so she has no intestines right now.

    0_1485547499481_Mag test 2.jpg

    This image shows the preset morph magnet loaded from the library, as you can see, I do have the pants selected, but Poser parents the magnet to the figure instead. In the hierarchy, it shows the magnet, mag zone and base are on the pants, but the effect of the magnet is on the figure.

    0_1485547994619_Mag test hierarchy 1.jpg
    The hierarchy showing the magnet parented to the pants, but affecting the figure instead.

    0_1485547526160_Mag test 3.jpg
    This final image shows a reversal of the figures in the scene. I loaded the pants first and then the figure, then I parented the pants to the figure and loaded the magnet from the library, this time it parents to the pants correctly.

    0_1485548173691_Mag test hierarchy 2.jpg
    The current hierarchy showing the pants first and the figure second. Poser seems to be giving priority over parenting the magnet from the library to the first figure in the scene and not the one that is selected (as all previous Poser versions did it this way).

    I did some further testing and so far any magnets saved as a preset in the library that are parented to the hip of the figure will do the same thing. It seems other magnets parented to other parts do not behave this way.


  • Poser Ambassadors

    My system is currently rendering, so I cant try what you describe.

    What does it do if you apply the magnet to the pants before you conform it to the figure?

    Years ago with the deformer sets, I am fairly sure it did the same thing. That is why there were apply poses to affect conformed clothes.



  • @shvrdavid

    To answer your question, this is what happens:

    https://www.dropbox.com/s/cc8hyvpzt6fxp6z/Vicky all morphs.mp4?dl=0

    Poser simply will not ignore the first figure in the scene, even though the pants are not conformed to the figure and the magnet has been applied to the pants.

    I have never had this problem before, which is what makes this so frustrating.



  • @cujoe_da_man said in Poser 11 Loading Preset Magnets To Wrong Figure:

    I have never had this problem before, which is what makes this so frustrating.

    Are the magnet toggles showing in the Vicky figure's appropriate groups? Have you tried turning them to zero? Or, are they not accessible or hidden?



  • @morkonan

    Kinda sorta, it only works half way. The magnet dials do show up on the figure and if I turn them off, the figure is no longer affected, however, the pants still do not get the affects of the magnet.



  • @cujoe_da_man said in Poser 11 Loading Preset Magnets To Wrong Figure:

    @morkonan

    Kinda sorta, it only works half way. The magnet dials do show up on the figure and if I turn them off, the figure is no longer affected, however, the pants still do not get the affects of the magnet.

    At that point, can you re-assign the magnets to the pants groups?



  • @morkonan

    I can, but that still doesn't solve the issue of why the magnet is parenting to the wrong figure in the first place. Also with reparenting, I could just spend the time making a new magnet with the same numbers and save it and it's fine, but again, that's only a partial solution to main issue.

    I know magnets aren't exactly the main thing now with the genesis figures out now, but since I am upgrading from P7, I never got into them and since DAZ has completely cut off Poser from supporting any of it's new figures, it makes no sense for me to start using them, so this is something I would like to figure out how to fix if possible.



  • After some more testing, I have come across another interesting tidbit. I decided for at least one of my magnets I would just duplicate the parameters, make a whole new magnet and save it in the library. This worked and I was able to add a magnet to the pants rather than the main figure, but when I introduced a new object, a shirt, the magnet would only parent to the pants and not the shirt.

    So, it seems to be an internal error on Poser's part and not how the magnet is being saved or applied to the scene when saved as a preset prop. I'm completely at a loss here.