CPU/GPU render different outcomes



  • Hi all. In the past I've noticed some variations between CPU and GPU renders, but lately the differences are massive. See the example below; the left side is CPU with BPT on, the right side is GPU with BPT off...

    0_1486800739655_hallway.jpg

    lighting intensity is ballpark but the specularity is way off. Figures rendered with GPU are also very flat looking. These scenes are identical in all ways except for the mode; CPU(BPT) or GPU(no BPT).

    Now, I haven't noticed this in the posted renders from other people, so I'm wondering if it might be a GPU driver thing, or a GPU settings thing. I've had like 3 driver updates for the GPU since the latest SR (and yes, I'm up to date). Any thoughts?

    I'm using a GTX970 with driver version 21.21.13.7849 (AKA 378.49).



  • And the settings are?



  • Why would that make a difference if the settings are the same for both? The only difference is CPU or GPU.



  • 'couse say Diffuse 1 Glossy 1 must be close to PT, and Diffuse 1 Glossy 5 must be different. Especially with low bounces, say 1-3.



  • 0_1486811167231_hallway settings.JPG

    For GPU, change samples to 100 and mode to GTX970. Bucket size was 256 (although 1024 works just the same). As I said, BPT off for GPU render.



  • As someone who can't get GPU working :( My only comment would be that if you turn off BPT then the Diffuse samples will drop to 1 as will the others. Have you tried doing a cpu render with BPT off?

    Amanda



  • @piersyf Yeah, We've discussed this before. I think one of the threads about render speed (maybe the one I started). We had a standard scene made by @Raven and some folks noticed that not all the lights would be reflected in windows and other surfaces. I think it comes down to BPT being off in GPU that turns off "sample all lights" etc. We also concluded that if BPT is on in GPU that you will get a nasty crash when the GPU starts to render transmapped hair. So gotta run GPU with that off.



  • @ghostship said in CPU/GPU render different outcomes:
    that if BPT is on in GPU that you will get a nasty crash when the GPU starts to render transmapped hair. So gotta run GPU with that off.
    If it's you display GPU. Not if it's CUDA only GPU, at least on Win7. As Win10 reserves memory on all GPU it can be different there too.



  • Will experiment later, but for me BPT and PT gives very similar results, in PT SSS and diffuse clears first, glossy second and vice versa in BPT. Reflections fully formed near 50 samples in PT and clear up to 100 and more.

    Re starting scene: how light fixtures are made?



  • Same settings as before;

    0_1486857429029_hallway bpt.jpg

    on the left, CPU render, BPT on. On the right, GPU render, BPT on.

    0_1486857531366_hallway BPTX.jpg

    on the left, CPU render, BPT off. On the right, GPU render, GPU off.

    Rendering without BPT is killing specularity and reducing light intensity. To go back to my original post, I haven't noticed this degree of difference before. It has occurred after the last SR, but also I've had several driver updates for the GTX970.

    The lights used are 3 spot lights. Area lights give entirely the wrong coverage for this scene.



  • @phdubrov Good to know! Thanks! I'll look into that as I was thinking of building a new computer with two video cards for Poser renders.



  • @piersyf SM claimed changes in glossy in last SR's readme.
    But is seems something scene/materials/lights dependent, will post some images later.



  • test scene https://www.dropbox.com/s/5660jcast1iwsp3/specular test.pz3?dl=0

    result BPT on left, PT on right
    0_1486883841779_2017-02-12 10_13_55-specular test - Smith Micro Poser Pro  (64-bit).png



  • I got the same results as you regarding the test scene. I also don't get nearly the same difference in my normal character creation scene, so yes, it appears to be scene specific. That doesn't answer why, though. If the light settings and material settings are identical, the only difference being whether BPT is on or not, I should not be getting such differing results. I'd like to know why I am.



  • @piersyf have you tried deleting all but one light and seeing if there is a difference then? I was under the impression it had to do with sample all lights etc. so maybe it has an issue when there are multiple light sources.



  • Not a single light, no, but as few as 3. If Poser can't handle specularity with 3 lights, it's fundamentally broken.



  • Not the numbers of lights issue - I add 7 spotlights in test scene, same results. Are lights behind the glass?



  • No. Free and clear of the ceiling. It also makes no difference whether spot, point or area light.



  • Materials?
    Poser, Physical or Cycles roots? If poser, is AltSpec involved?



  • It's a house, dude... 40 or more textures, so mixed root. Mostly Poser. I don't use alt spec. It does the same thing to people, so normal maps and EZskin is effected the same way.

    Sorry, I know you're trying to help. Just getting frustrated.