Help | Suddenly immense lag



  • Hello guys.
    I have a problem with Clip Studio Paint EX now.
    I bought it some time ago and it worked like a charm, everything was awesome.
    Today i opened CSP and it lagged as hell.
    The problem is that the cursor gets stuck immediately when i go over the Canvas without even pressing anything for a few seconds.
    Also when i go to the top buttons to access preference settings etc it takes a few seconds until it opens it.
    I am using a pc with a 2gb Geforce gtx 780 ti graphic card, 16Gb ram.
    70% of the ram is assigned to Csp which is about 9gb but the program itself only uses like about 500mb ram (Checked in the Task Manager) while only 20% of my total ram is in use.
    Every other program works fine, i have tested Photoshop CC, works without problem, i have tested playing games to make sure my graphic card didn't die, everything works fine as always.
    I can't use Csp with this amount of lag.
    I have tried uninstalling it and reinstalling it, still the same problem.
    I have deleted all the Celsys files in the documents folder and restarted the program, still the same.
    I have started the program while holding shift to reset everything, still the same problem.
    Everytime i try to make a stroke (with the mouse) the cursor suddenly stucks and appears few seconds later at a different location with a straight line to it.
    When i make a stroke with the pen, the cursor stucks aswell but the line shows up after a couple of seconds.
    Anyone knows how to fix this problem?
    Csp has worked so good until now, like literally used it 2 days ago and changed nothing since then.



  • What version are you using? Have you updated to latest version? I'm not sure if updating will correct the problem but some lag issues and memory hogging was cleared up with some of the more recent updates.



  • After uninstalling it i downloaded the latest 1.6.2 version and installed it after also deleting all Celsys files which includes all custom brushes, presets etc.
    It helped a little bit.
    The cursor now doesn't get immediately stuck when i go over the canvas.
    But it still gets stuck whenever i start painting as described above :/
    I usually painted on an A4 sized Canvas with 300/600dpi and it worked fine.
    I tried to go down to 72dpi, try out different brushes etc but the problem is still the same.
    Also created a canvas with 1200dpi and used max size brushes, ram usage went up to 900mb, same problem.
    I don't know what has caused the problem since i haven't changed anything since i used it last.
    I also tested the performence with other programs just to make sure it's not my pc.
    Programs tested: Photoshop CC, Autodest Sketchbook Pro & Painttool Sai.
    All of them work without any issues.

    Here some more details about my system maybe this helps.
    Win 8.1 64bit
    Intel Core I7-4770k 3.50Ghz
    Geforce Gtx 780Ti 2gb Graphic card (Driver up to date)
    16gb Ram (70% assigned to Csp)
    Wacom Cintiq 24hd touch (Driver up to date)



  • I'm not too sure what would cause this. I had a similar issue briefly but after updating to the latest version it went away.



  • I guess i'll try uninstalling it again and repeating it some more times and hope it helps.
    If not, then i'll just wait and hope it resolves the problem the same way it has appeared :/



  • Is it laggy when you just use a mouse ?...I'm wondering if its not playing well with the Wacom Driver ( re-install driver or play with the related preferences). ? I realise its working with other programs... but that interplay can be temperamental and application specific.



  • No it also lags when i'm using the pen.
    The only difference is, that when i use the mouse, the cursor works for a few seconds normal and then stucks as described, and then after a few seconds the cursor moves to the actual position and it pulls a perfectly straight line to the current position, eventough i drew a curvy line.
    When i do the same with the pen, first seconds it works also normal, then the cursor gets stuck and moves to the actual position after a few seconds but the line isn't interrupted, it's exactly the way i drew it, just few seconds delayed after the stuck.
    I also tried unplugging the tablet and plugging it back in, i will also later try to uninstall the Wacom driver and test if this is causing the problem, eventough it worked fine before.
    Running a complete system check right now, to make sure there's nothing wrong aswell.



  • Edit, no it didn't fix it -.-"
    Alright guys, little update, i think my problem is solved...

    What i did since this bug/lag has started:
    Uninstalled/Reinstalled Clip Studio Paint several times
    Deleted all Celsys files in the Documents folder.
    Opened Csp while holding shift and reset everything
    Made a complete system check by antivirus (About 3-4tb of files)
    Plugged out and in the Tablet
    Uninstalled the Wacom Driver and tested without it
    Reinstalled the Wacom Driver and tested again.
    Turned off and on the screen.

    Nothing of this has helped at all, actually after reinstalling the Wacom driver i had an issue where windows told me: Tablet Driver not found.
    Alright uninstalled it again, closed all Wacom/Tablet tasks, removed the tablet from the device manager, reinstalled it.
    Meanwhile i had the idea to test what happens when i drag the Clip Studio Paint window to my second Screen which is just a regular screen.

    Boom, no lag, no cursor stucks, no interruptions nothing.
    I dragged the window back to my Wacom screen, and the lag started again, i checked all connections if they were plugged in properly and they were.

    Then i turned off the screen and turned it on again... and this looks like it has fixed it...

    I do not understand how turning off and on a screen affects the performance of 1 single program, while everything else worked perfectly.
    But hey... if it works it works xD

    Thank you again for trying to help me <3



  • Problem fixed
    Did a complete pc reset, uninstalled Windows 8.1 and installed Windows 10