Poser library navigation jumping



  • I did install the Experimental library build and it did fix the issue of the cursor jumping to the top when trying to expand a selection by clicking on the arrow the first time in any given tab.

    That is in mac os X yosemite

    also my safari version is (Version 10.1)

    So far the only issue I have had is occasionally the arrow to expand a selection will open and colapse rapidly instead of staying open.


  • Poser Ambassadors

    So far the experimental build has not shown the cursor jumping for me either. I am a bit cautious since I changed my behaviour to avoid the cursor jumping.

    This is in Windows 10, Chromium (default Poser)



  • @tburzio said in Poser library navigation jumping:

    @admin I believe it's a focus thing. When you scroll the wheel in the window, it should generate a focus event as well as a move event. Since it doesn't, the first time you click (which DOES generate a focus event), the focus event handler runs. For some reason, a focus event does a redraw and puts the window back in the state it was before the focus was lost, including what was formerly selected. In the days before widgets, I'd have to write my own event handlers, and this is what it looks like. Just my opinion.

    You are trying to take my paycheck, aren't you Tburzio??
    JK :)

    That was one really good guess. You know, it took me days to get to a somewhat similar conclusion :)
    The issue appears to be related to a combination of focus-change handlers and event handlers. For some reason, when changing focus,event does not get sent to the right location (expand-node), but goes who-knows-where instead.
    Sounds simple, rite? Well....creators of the framework decided they would like to reinvent everything. So, besides hot water, wheel and the wind, they re-implemented their own events...and everything else. At that point, things stopped being simple...

    Anyways, this experimental build is a result of heavy patching on the framework side. Lets hope some other library features don't rely on framework bugs being there :)



  • @david_macrae said in Poser library navigation jumping:

    I did install the Experimental library build and it did fix the issue of the cursor jumping to the top when trying to expand a selection by clicking on the arrow the first time in any given tab.
    That is in mac os X yosemite
    also my safari version is (Version 10.1)
    So far the only issue I have had is occasionally the arrow to expand a selection will open and colapse rapidly instead of staying open.

    Thank you for testing this on OSX!



  • @wimvdb said in Poser library navigation jumping:

    So far the experimental build has not shown the cursor jumping for me either. I am a bit cautious since I changed my behaviour to avoid the cursor jumping.
    This is in Windows 10, Chromium (default Poser)

    Thank you Wim for testing this on Windows!!



  • OK, so we have basic smoke testing done on both Windows and OSX, with positive/good outcomes.

    I cannot say how much it'll take for these changes to get fully tested, but your confirmation will speed things up for sure.

    Once again, thank you!!



  • For the people discussing the experimental build: Are you referring to the built-in library or the external on used in a browser? I use the embedded Poser library, and if it's every slightly fixed I'd be really happy. D:


  • Poser Ambassadors

    @johndoe641 said in Poser library navigation jumping:

    For the people discussing the experimental build: Are you referring to the built-in library or the external on used in a browser? I use the embedded Poser library, and if it's every slightly fixed I'd be really happy. D:

    Both the internal library and the external browser one.



  • @wimvdb The Mac program "Poser Library", that oddly enough browses the Poser library, is also broken in that it can only see the built-in library and not a user defined library like all the other library tools. Weird, huh? I guess it should also be fixed one day. Oh well, one miracle at a time! :-)


  • Poser Ambassadors

    @tburzio said in Poser library navigation jumping:

    @wimvdb The Mac program "Poser Library", that oddly enough browses the Poser library, is also broken in that it can only see the built-in library and not a user defined library like all the other library tools. Weird, huh? I guess it should also be fixed one day. Oh well, one miracle at a time! :-)

    I do not quite understand this. I have many friends who use the Mac with Poser 11 and work with the library without problems you describe. One of them uses hundreds of external runtimes.

    What do you mean with "The Mac program "Poser Library"?



  • @wimvdb "Poser Library" is a separate program in the Launchpad from Poser. It's purpose is to browse the library.

    0_1491277115525_fred.jpg



  • @tburzio That is the old library which I believe @bagginsbill wrote and was 'retired' as of Poser 11, it doesn't use the DB but simply does file searches. ISTR it uses a different pref file to get the list of runtimes not the same one that the HTML / Java one uses. Try adding an eternal library whilst in the Air based library and you should be okay. I continued to use the Air based library when Poser 11 first came out as the java one was so badly broken it was, if you had large runtimes, totally unusable.



  • @amethystpendant Oh. Well then I change this to a "documentation fault" then, because it kinda works but is not mentioned anywhere in the help... :-)



  • @tburzio said in Poser library navigation jumping:

    Poser is pretty good, but the "menu hopping bug" has got to be snuffed out first, before anything else. Golly jumping Jehoshaphat, it's annoying! :-)

    I think that might actually be a Windows bug. I have Win 10 and File Explorer does that to me, too.



  • @admin Any news on patching this bug? The staff at the sanitarium want my bed back! :-)



  • New service release SR7 is being prepared. It should include fix for that bug.

    Edit: If you don't feel like waiting for new SR for this bug, you can download new library here:
    https://forum.smithmicro.com/assets/uploads/files/release-1.9.1.zip
    Extract it and use these to overwrite existing library files



  • @admin Thanks! This gives me a huge amount of hope for the future!



  • @admin This is definitely good news. Even though I've taken to viewing my PP11 Library in my browser, I'd really like to get it back into my PP11 UI.



  • The first update by the new team!
    That is good news.



  • @wimvdb said in Poser library navigation jumping:

    Copy this URL and paste it in your browser.
    http://127.0.0.1:11530/nonVirtualAssets/ContentLibrary/release-1.9.1/ContentLibrary/ContentLibrary.html

    If the link does not work, let me know and I will tell you how to get the correct one.

    Late on the scene to this one but trying the link only gets me
    "Firefox can’t establish a connection to the server at 127.0.0.1:11530.
    The site could be temporarily unavailable or too busy. Try again in a few moments."

    I have opened port 11530 via my router - could it be that I have Poser not on my "C" Drive?