Poser startup error

  • That's what I do. But it's still aggravating when it didn't start till a few weeks ago. I'm leaning toward the conclusion that a windows 10 update is the cause- it's been known to happen.

  • @mdbruffy It was happening to me on W7 on my old computer. Same problem on new machine with W10.

  • @mdbruffy I actually get two errors. First error occurs when the library first loads and the second error occurs when I click on the library folder that has mats in it.

  • The moment Poser comes up, I get a mainWacros window telling me it couldn't find the DLL modules for KinectCapture or the addon PyhtonShell. Yet, the program works just fine.

  • @mdbruffy is that DLL for Kinect a standard thing for all users windows users? I bought an official Micro Soft physical copy of W10 on a memory stick.

  • I just went back and took another look. There are single DLL files in the Poser 11 folder. But inside the Runtime/Python/ DLLs folder there is nothing labeled KinectCaptaure or PythonShell. Could be something IS missing.

  • just did some exploring in the Poser 11 folder. They are there- they're in the addons folder. Go to Smith micro > Poser 11 > Runtime > Python and you'll see folders for both and they have the files inside.

  • @mdbruffy Is your main runtime in a non-standard place?

  • Everything except the actual library is in the program folder on my main drive. My library is so big, I have it on my second drive. Until now, everything's worked just fine- no problems at all. In fact, I've been very surprised by how problem free Poser 11's been- till now.

  • Came here hoping someone found a solution. Guess not... I have PP11 on Win10. It just suddenly started giving that message one day. Not sure what caused it, but the only "fix" I found is to reboot. Of course, it does it again later.

    After a bit of debugging, I found out that they're failing when trying to call "import wx.py". For some odd reason, that doesn't throw an error. Instead, it silently fails and throws a useless error message elsewhere. Oddly enough, I can't even find the file. It's weird that it doesn't have any problems after a restart. Not sure where to go from here, but I hope that points someone in the right direction.

  • @semicharm All I can say is "welcome to the club". I did a complete uninstall and re-install and the mainwacros error window went away- for a short while. Then it came back all on it's own without anything help from me.

  • When a DLL does not load, the cause may be a missing dependency.
    Using a free program: dependency walker, you can check if something is missing.
    As easy as download, unzip, run.
    For example, one of the DLL in Poser's runtime\python\addons\KinectCapture: KCBv2.dll is missing "kinect20.dll"
    Nothing strange as I don't have kinect.

    alt text

    I hope this may helps you.

  • Will it also replace the file? I've tried to find a download link for kinect20.dll and all I can find is talk and other programs I don't know if I can trust.

  • @mdbruffy

    The purpose of this tool is (among other things) to determine if a dependency is missing.
    It cannot replace something that's missing.
    Furthermore, some DLL must be registered in win's registry database. That's the reason why that often come with a setup program.
    I suspect that the missing DLL comes with Microsoft's kinect system.

    That being said, on my poser, kinect is not enabled, so that the missing DLL is not a problem.
    Is the kinect option checked in your poser?
    Look at "Window > Addons > ..."

  • The only thing I have under addons is the Dyson importer- which I'm going to remove first chance I get.

  • @Y-Phil
    I checked the python code used to load the addons. It's "wx.py" that's failing to load for both "KinectCapture" and "PythonShell". The issue isn't with Kinect or any of it's DLLs.

  • @Y-Phil
    I dug a little deeper into wx.py and found that it's failing to load _stc.pyd. Turns out that the damn thing is a actually a DLL. So, I threw it into walker and it failed to find most of its dependencies, which are mostly core python DLLs in the Poser app folder. After manually adding that path into walker, it was able load them correctly. So, the problem is that somehow python in Poser isn't finding it's own DLLs when loading _stc.pyd?

  • Could it be a difference in the version of python27.dll? or that you have another dll with the same name, but in windows' folders hierarchy?
    It's in French but you can guess the dates and sizes:
    alt text

  • Nothing to contribute at this point, but I am listening. Makes a kind of sense so far...

  • @Y-Phil Yeah, I have the same file in PP11. I'd thought about it being a file collision issue and checked windows to be sure, but turned up nothing. However, rebooting seems to solve the problem--at least temporarily. Something is probably screwing with the paths it checks to resolve dependencies and rebooting resets the path list. Not sure what's doing it. I've tried opening many of my common apps, but no issues so far.