Poser startup error

  • Hi all,

    I recently purchased poser 11 pro. first two days it was okay after installation. From today onwards, I am getting error as following whenever I start the poser. What is the error could be how to resolve it?

    "An errror occurred importing addon KinectCapture :
    ERROR: DLL load failed: The specified module could not be found.

    An errror occurred importing addon PythonShell :
    ERROR: DLL load failed: The specified module could not be found."

    Thanks and regards

  • Poser Ambassadors

    Did you attach a runtime from a previous version of poser, such as Poser Pro 2014? If so, it is duplicating the plugin with an older version and the old one fails.

    I've had this forever, and i just ignore it. I suppose if it matters to you, you could go into the 2014 runtime and rename the Runtime/Python/addons folder so they are no longer seen. However, if you do that and then run 2014, it will not see the addons. So you only want to rip out the old one if you never run the old Poser.

  • I have only one version no earlier versions.


  • Hi there,

    Contact Smith Micro customer support, they can help you out. Email: cs@smithmicro.com

  • @anniespewak said in Poser startup error:

    Hi there,

    Contact Smith Micro customer support, they can help you out. Email: cs@smithmicro.com

    Be prepared to wait 2 days, then get a response asking you information you actually supplied in the original contact, respond, wait 2 days....

    Sorry I love Poser but my contacts with support have been abysmal, they seem to assume you are an idiot and don't even seem to know anything about Poser other than the real basics.

    If this is a known issue, there should be details on the FAQ if it isn't, well unless someone here can help you out...

    First check that you have a file called poseraddon.py in the path C:\Program Files\Smith Micro\Poser 11\Runtime\Python\addons

    You should also have 2 folders KinectCapture and PythonShell

    PythonShell has 1 file init.py (formatter removed the double underscores pre and post init (see image below)
    KinetCapture has several

    its worth checking that everything is there.

  • For anniespewak and anyone else with this problem. I started having it a few days ago- after my Poser 2014 had been installed for quiet a while. I even went to the extreme measure of re-installing the program and still had the same issue. Found this forum and started checking. Everything was where it was supposed to be. So I got to wondering and looking and found a SECOND runtime file outside the Smith Micro folder that only had Python scripts- No Shell or kinetCapture files.
    I deleted that folder and rebooted my comp. I then brought Poser up and did NOT get either error message.
    I still don't know what caused the creation of that new folder, but at least I now know what to look for.

  • @mdbruffy
    Me again. Did all the above, rebooted and the program was fine. Till the NEXT time I brought it up. Got the same error messages- and this time there was no second folder involved.

  • I get this error too. I was getting this same error when using PP2014. It did not/does not prevent me from using the program. I just close out the error window and go about my day.

  • That's what I do. But it's still aggravating when it didn't start till a few weeks ago. I'm leaning toward the conclusion that a windows 10 update is the cause- it's been known to happen.

  • @mdbruffy It was happening to me on W7 on my old computer. Same problem on new machine with W10.

  • @mdbruffy I actually get two errors. First error occurs when the library first loads and the second error occurs when I click on the library folder that has mats in it.

  • The moment Poser comes up, I get a mainWacros window telling me it couldn't find the DLL modules for KinectCapture or the addon PyhtonShell. Yet, the program works just fine.

  • @mdbruffy is that DLL for Kinect a standard thing for all users windows users? I bought an official Micro Soft physical copy of W10 on a memory stick.

  • I just went back and took another look. There are single DLL files in the Poser 11 folder. But inside the Runtime/Python/ DLLs folder there is nothing labeled KinectCaptaure or PythonShell. Could be something IS missing.

  • just did some exploring in the Poser 11 folder. They are there- they're in the addons folder. Go to Smith micro > Poser 11 > Runtime > Python and you'll see folders for both and they have the files inside.

  • @mdbruffy Is your main runtime in a non-standard place?

  • Everything except the actual library is in the program folder on my main drive. My library is so big, I have it on my second drive. Until now, everything's worked just fine- no problems at all. In fact, I've been very surprised by how problem free Poser 11's been- till now.

  • Came here hoping someone found a solution. Guess not... I have PP11 on Win10. It just suddenly started giving that message one day. Not sure what caused it, but the only "fix" I found is to reboot. Of course, it does it again later.

    After a bit of debugging, I found out that they're failing when trying to call "import wx.py". For some odd reason, that doesn't throw an error. Instead, it silently fails and throws a useless error message elsewhere. Oddly enough, I can't even find the file. It's weird that it doesn't have any problems after a restart. Not sure where to go from here, but I hope that points someone in the right direction.

  • @semicharm All I can say is "welcome to the club". I did a complete uninstall and re-install and the mainwacros error window went away- for a short while. Then it came back all on it's own without anything help from me.

  • When a DLL does not load, the cause may be a missing dependency.
    Using a free program: dependency walker, you can check if something is missing.
    As easy as download, unzip, run.
    For example, one of the DLL in Poser's runtime\python\addons\KinectCapture: KCBv2.dll is missing "kinect20.dll"
    Nothing strange as I don't have kinect.

    alt text

    I hope this may helps you.