Poser startup error



  • Will it also replace the file? I've tried to find a download link for kinect20.dll and all I can find is talk and other programs I don't know if I can trust.



  • @mdbruffy

    The purpose of this tool is (among other things) to determine if a dependency is missing.
    It cannot replace something that's missing.
    Furthermore, some DLL must be registered in win's registry database. That's the reason why that often come with a setup program.
    I suspect that the missing DLL comes with Microsoft's kinect system.

    That being said, on my poser, kinect is not enabled, so that the missing DLL is not a problem.
    Is the kinect option checked in your poser?
    Look at "Window > Addons > ..."



  • The only thing I have under addons is the Dyson importer- which I'm going to remove first chance I get.



  • @Y-Phil
    I checked the python code used to load the addons. It's "wx.py" that's failing to load for both "KinectCapture" and "PythonShell". The issue isn't with Kinect or any of it's DLLs.



  • @Y-Phil
    I dug a little deeper into wx.py and found that it's failing to load _stc.pyd. Turns out that the damn thing is a actually a DLL. So, I threw it into walker and it failed to find most of its dependencies, which are mostly core python DLLs in the Poser app folder. After manually adding that path into walker, it was able load them correctly. So, the problem is that somehow python in Poser isn't finding it's own DLLs when loading _stc.pyd?



  • Could it be a difference in the version of python27.dll? or that you have another dll with the same name, but in windows' folders hierarchy?
    It's in French but you can guess the dates and sizes:
    alt text



  • Nothing to contribute at this point, but I am listening. Makes a kind of sense so far...



  • @Y-Phil Yeah, I have the same file in PP11. I'd thought about it being a file collision issue and checked windows to be sure, but turned up nothing. However, rebooting seems to solve the problem--at least temporarily. Something is probably screwing with the paths it checks to resolve dependencies and rebooting resets the path list. Not sure what's doing it. I've tried opening many of my common apps, but no issues so far.



  • @semicharm I did a complete uninstall and re-install and the issue disappeared- for a short while. Then it returned all on it's own.