How do I get rid of flickering shadows?



  • Sorry I'm posting so many questions. And I have a feeling that I'm posting this too quickly. A reboot and rerender might fix it. But in the mean time, just in case anyone knows what to do here.

    I'm getting weird bad shadows that are flickering on and off. My lights have no keyframes. In preview mode I sort of figured, "ah it's just preview mode". But it's showing up in the final render - which is using the sketch shader.

    Here are 3 consecutive frames, rendered at 1920x1080 and then reduced in size to post here:

    0_1493115421400_1.jpg
    0_1493115465398_2.jpg
    0_1493115472226_3.jpg

    The middle frame has weird shadows across the face. You can see a line above her eyebrow.

    In other shots I actually need some shadows and they're not rendering.

    Oh, I'm on a retina iMac, i7, 32 GB ram, AMD Radeon R9 w 2GB. I have hardware shadows turned on. With no shadows you don't get the nice shadow on the side of her face and it looks too flat. Probably my video card just sucks ass. But there's no call for flickering shadows. Nothing in these 3 frames is different enough to make this happen.



  • Seems to be a common side effect of indirect lighting, so try turning that off.



  • Acutally it goes away when I turn off "hardware shadows". I figured that would render it too flat without the shadow on her face. But when I tried a test render it actually does render the shadow with it off. So I guess it's a non-issue.

    I'm learning. :/



  • It worked to turn off hardware shadows. Thanks to everyone on here that's putting up with my questions. Here's a preview of what I'm working on...

    http://badweaselgames.com/ats2/BrainChemFirstShot.mov

    All the whitespace (bluespace) on the left will have other shots composited there.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.