3D imports don't show textures in 1.6.2

  • I've tried importing my file as a zipped file with .OBJ, .mtl, and image inside it. I've tried zipping up a .fbx and image. No matter what, the textures never appear when I import it into CSP. It's infuriating, because a year ago the zipping trick worked just fine. The .mtl file's pointing to the image, and the .obj's pointing to the .mtl, so I don't understand how this has been going so wrong all day. Please help! 2_1493153936496_Screen Shot 2017-04-25 at 4.58.20 PM.png 1_1493153936495_Screen Shot 2017-04-25 at 4.58.05 PM.png 0_1493153936495_Screen Shot 2017-04-25 at 4.57.55 PM.png

  • Try changing the MTL filename to "it's_a_plane_i_think.mtl" (underscores where spaces are) and edit the OBJ to point to that. Doesn't seem to matter if the OBJ file has spaces in the name, but the MTL and images shouldn't have spaces in the names.

  • Didn't work. :( I even tried cutting out the apostrophe. I wish I could just upload the .zip folder, but it says I don't have enough privileges? (why show me the option, then!) 0_1493186885614_Screen Shot 2017-04-26 at 2.07.28 AM.png

  • Hmm. Guess you'll need to do more in-depth troubleshooting...

    Does this model open with textures in your 3D modeling program?
    If not, then maybe there's something wrong with the model itself.

    You mentioned trying FBX. Assuming you converted the OBJ --> FBX, did that FBX open in your modeling program with the textures?
    Also, you'd have to do the conversion after moving the images to the same level and editing the OBJ or the FBX will import to CSP missing textures too (but it sounds like you already know that).

    If you import a known good model you imported before without problems, does it also lose its textures?
    That will tell you if it's a potentially a problem with CSP or the model.

    Have you tried starting CSP while holding down the shift key?
    This will clear out any old preference/cache issues that may be causing problems.

    Have you tried reinstalling CSP?
    That seems to solve a lot of problems for people.

    Did you recently upgrade to macOS Sierra, and if so was that before or after installing/updating CSP 1.6.2?
    I'm not using Sierra myself, but there are some issues with macOS Sierra still being discovered, this may be one of them. Actually I'm not sure Celsys tested 1.6.2 with Sierra, since it's not listed as "verified" on the Japanese website. I'd just wait for the english release of 1.6.3 or 1.6.4 to see if that fixes it. Last resort would be to downgrade the OS, but that's a pretty drastic solution.

  • Wow, thanks for all the suggestions! :D I was working on something else today (I alternate days right now, since I have two projects), and the A/C in my house is broken, so I might not get to trying them all tomorrow. I'll let you know what the results are as soon as I can! Thanks again!

  • I finished a different model and imported it, and it worked just fine, oddly enough. I think the problem may be trying to use an image, because I just used the solid-color textures in Maya this time. Luckily, I already had this Galaga plane model working from a year ago, so barring any major catastrophe it's problem solved!

  • Actually, I'm having the same problems too. It doesn't work with objects that has custom images for texture. Those areas are just black. The textures that came from the modeling program works though.

    The file type I'm using is OBJ and I tried looking at it back in my 3D modeling program. It works fine there. It seems like it's CSP that's in trouble here.

    I tried resetting the cache, it doesn't work either. I haven't tried reinstalling my CSP yet, so we'll see about that later.

    Also just to add, my OS is Windows 10 and I'm using the same version of CSP too. Any help would be appreciated.

  • Hmm. I just tried an OBJ with textures I know imported fine previously and also slapped together a new one with in my modeling program. They both imported with the textures on my Mac and Windows installs. However I rarely actually use my Windows version of CSP so I had to update it to 1.6.2 first, so maybe reinstalling will help.