Is Ajax still around? Seeking EasyPose Underground support...

  • I have EasyPose Underground dated 2002-2007, which I bought from RuntimeDNA some years ago when it was on sale. It's worked fine in Windows 7 until quite recently, but has now started throwing exceptions. I'm assuming a recent Windows update has clobbered a library somewhere.

    I've not seen anything from Ajax for a long time. Does anyone know if he's still around?

  • @englishbob

    There are still 3 products from him in his Rendo store. Maybe a pm there will get in touch with him.
    All of his sites seem to be down thou.

  • I'll try Rendo, thanks. The version of EPU that's there is an old one and is unavailable anyway; I didn't think to look for other products of his.

  • The readme file says EPU uses .NET framework 2, which hasn't been updated during the life of the machine, as far as I can tell (it was released in 2005, and support ended in 2011). However .NET 4.6.2 has had three security updates and two non-security ones since the time that EPU was last seen working. I don't know enough about .NET to know if there's any overlap - is there a .NET expert in the house?

    I've PMed Ajax at Rendo, anyway, so we'll see. Rendo's admins are generally helpful with enquiries about a member still being active.

  • There have been so many changes to NET. NativeIndexImages was the first thing they broke, but I don't know what else has been broken since then.

  • Here is a link to a work around to get around the NativeImages issue. No idea if that would work for Easypose or not thou.

    Indexee issue

  • It's worth a try. I asked the .NET question in a Windows-oriented forum and it was suggested to try uninstalling the 4.6.2 updates, which should achieve the same ends. I'll wait until I get home however, in case I break something. :)

  • @englishbob Hi Bob, did you happen to find contact with Ajax?
    I'm having a problem with Easypose 2 with the 'swap geometry' functionallity. It used to work for me in former times, but some months ago it refused to add alternative Geometry to a CR2 file, telling the obj must be in a subfolder to the runtime:geometries folder... But this is the case!! So some months ago I abandoned because the thing was not so important, and I assumed I had just made some silly mistake myself. But now for a new product I definitely need it working, and it again refuses with the same error message. I don't know what to do top make it work...

    So I would be very grateful about any advice on this issue or where to find Ajax?
    Thanks, Charlie

  • @Bytefactory3D I tried to contact Ajax via PM at Renderosity in June, on the assumption that would reach whatever e-mail he currently has. I've heard nothing; you can read into that whatever you will. I haven't tried Renderosity admins. Since he's still listed as a vendor there, they should have up-to-date contact details for him, and they've been willing to try to get in touch with a vendor on a customer's behalf before.

    I didn't pursue my .NET problems much further, and it sounds as if you may have been hit by an upgrade too since Easypose used to work and now doesn't.

    I'm actually setting up an off-line XP machine that won't be allowed anywhere near the Internet, and that might be my ultimate solution to legacy programs. It would be more convenient to have EPU working properly on my main machine, all the same. Thanks for reminding me about this.

  • @englishbob
    Hey Bob, thank you so much for the quick reply :-)
    Yes, it seems to me, like you said, that some .NET update could have caused the problem recently. I found some threads about how to fallback with .NET updates, but this is beyond of what I can do and also what I would be ready to try doing.
    I had the same idea like you, will try to use an older Win7 laptop with Easypose. If that could work, even if inconvenient, it would be okay. Easypose still works well on my main work station (Win 8.1, I refused upgrading to Win 10) for most of the things, only thing I recently realized is something is wrong with the 'alternative Geometry' functionality, and as it is about 'file location' it really seems to be an issue between Easypose and the OS.
    Thanks again for your reply :-)

  • @Bytefactory3D You're welcome, let me know how you get on.

    I should add that I was using Windows 7 Pro at the time my problems began. I even tried installing EPU in XP mode, and only installed the appropriate .NET version - or so I thought - but without success.

    I'll try Rendo staff anyway, which I meant to do back when I started this thread.

  • @englishbob
    Goodness, I solved my own issue, but could never imagine THIS was the reason...
    Now when adding an alternative geometry, this must be contained in a subfolder to the runtime/geometries folder. I had made sure to respect this, but it didn't work...
    In the error message popup window it says '... subfolder of the Runtime/Geometries folder', and somehow the capital letters attracted my attention. In Windows systems, minor or capital letters have no meaning in folder names, so I had never put much attention on naming my content folders 'runtime' or 'Runtime'. But now, out of desperation, I tried renaming my 'runtime' to 'Runtime' and the 'geometries' folder to 'Geometries'...
    and BANG, Easypose adds the alternative geometry like a charm again...

    So this can't help us find out whether or not Ajax is still active somewhere, but it COULD help someone who occasionally drops in to this thread for the same reason like me, thats why I described the solution to my issue with Easypose here, smile...
    Soooo happy :-) :-) :-)

  • @Bytefactory3D Poser was originally written as a Mac application, and Macs, being Unix based, are case sensitive. Poser on Windows has historically been picky about case even though, as you say, Windows itself is not. For example, look at the error messages I got from Poser 4 by capitalising the name of the geometry file:

    That said, EasyPose has always been a Windows program, and I can think of no reason it should be subject to the same quirks. I'm not even sure if those still apply to Poser, in this day and age. I should try it some time.

    Glad to hear you got it sorted out, anyway. Renderosity told me Ajax hadn't signed in since the beginning of August; that's still some time after I PM'ed him, but hey ho.

    Bizarrely, I just tried a new installation of EPU2 on my XP machine (.NET versions up to 4.0) and it throws the same exceptions. I may have to look at factors other than .NET for the answer. I can't remember what project I wanted it for, any more. :)

  • I just heard from Ajax, which is a relief. Rendo's flaky ebots were to blame, wouldn't you know. I'll update here if we make any breakthroughs.

  • Ajax was kind enough to send me version which seems to have sorted the problem out - it was a known issue, and nothing to do with .NET versions, fortunately. I have it working on Windows 10 at the moment.

  • @englishbob
    hey Bob, I'm glad I could bring him here. I had reached him through the email adress which was mentioned in the EasyPose documentation. I just gave it a try and lucky enough it was still valid, so I sent him the link to this thread here. :-)

    Thank you for mentioning the latest version number, now I can be relaxed about having this version already :-)

  • An hopping I can get hold of Ajax as I would like/need to get hold of a copy of Easypose Underground, had been meaning to pick it up for ages but never did and now I that I have a reason to its gone :(

  • I've almost finished a first version of a very simple PoserPython script that adds the standard EasyPose to any figure.

    I've just been in touch with Ajax (thanks EnglishBob) and he's happy for me to release this as a freebie. He says that he doesn't do 3D any more, that his software hasn't been updated in 10 years, and that it'll be good to have an alternative ! :)