Rendering transmapped hair in Superfly: very long render time



  • Hi,

    I finally sidegraded to Poser 11 pro and so far I find my results convincing. The only problem I have: rendering transmapped hair seems to last forever (I'm sitting now for a few hours in front of a never-finishing simple portrait of only 700x700 pixels). Is there any way around this? The hair I'm really having trouble with is Xanadu by Littlefox, But I had similar problems with an SAV-hair, too. I used ez3-shaders, and these are my render settings:

    Pixel samples: 8

    branched path tracing on

    diffuse samples 7
    glossy samples 5
    transmisson samples 7
    subsurface samples 7
    volume samples 2
    ao samples 2
    Mesh light samples 4

    min bounces 1
    max bounces 8
    diffuse bounces 1
    glossy bounces 2
    transmission bounces 8
    min transparent bounces 16
    max transparent bounces 64 (lower value left me with pitchblack ugly shadows under the hair)
    volume bounces 0

    no caustics

    filter glossy 1

    lights:
    3 area lights

    I did CPU-rendering.

    Any suggestions would be much appreciated!



  • You can try these settings. I don't see a slowdown on hair with them.
    0_1497876017415_RenderSettings.jpg



  • @varnayrah Are you using the Plug-in that @amethystpendant made from @bagginsbill shader? That shader looks killer but it's also a killer on render speeds. In my tests render times double with his shader. Like I said the shader makes the hair look awesome but there is the trade-off.

    Also: SAV made her hair supper dense. It looks great and probably some of the best hairs out there but they are a killer on render speeds as well. So many layers of transmaps will do that to your render times.



  • @ghostship I found the same. I use that bagginsbill hair shader only on closeups because of the render times and it adds a great deal to hair in closeup and not so much in full body shots. Not enough to justify the long render times in full body shots for me.


  • Poser Team

    You can cheat trans mapped hair in SuperFly where it renders a lot faster and still looks ok.
    You do have to play around with it and figure out what the minimum number of trans bounces you need to get it to fill out. (It will still have black areas in it if it has a lot of layers) Once you know the number of layers you need, set the shader up to go transparent after X number of bounces. You don't get black spots that way, and you don't need all the bounces either.

    You can define the number of bounces the render engine will see in a shader, then ignore the rest like this.
    alt text

    Plug whatever shader setup you are using for the hair into the Diffuse BSDF, then set the value in the Greater Than to the number of bounces you want the engine to stop seeing the hair.

    If you get into the habit of defining bounces in the shaders, you can just set the engine to anything above that and forget about it.



  • Thank you all very much :) @ghostship, I'm just using the hair shader that comes with ezskin3, I honestly don't know if it's the plugin by amethystpendant. But I think not so.

    @shvrdavid, I'm not sure I understand - where do I even find the settings you refer to? This light path panel?


  • Poser Team

    @varnayrah You have to build a similar node structure in the material room. The picture above is a cycles version, but you do it the same way in Superfly.



  • @shvrdavid said in Rendering transmapped hair in Superfly: very long render time:

    You can cheat trans mapped hair in SuperFly where it renders a lot faster and still looks ok.
    You do have to play around with it and figure out what the minimum number of trans bounces you need to get it to fill out. (It will still have black areas in it if it has a lot of layers) Once you know the number of layers you need, set the shader up to go transparent after X number of bounces. You don't get black spots that way, and you don't need all the bounces either.

    You can define the number of bounces the render engine will see in a shader, then ignore the rest like this.
    alt text

    Plug whatever shader setup you are using for the hair into the Diffuse BSDF, then set the value in the Greater Than to the number of bounces you want the engine to stop seeing the hair.

    If you get into the habit of defining bounces in the shaders, you can just set the engine to anything above that and forget about it.

    This is a nifty tip! >thumbs up<



  • @shvrdavid I was under the impression that the render settings for transparency too care of that. There is a minimum number and a maximum. and I thought that it would do as many bounces as needed till it hi your maximum setting.


  • Poser Team

    @ghostship

    If you don't terminate it to transparent, you can get black areas in the transparency with anything that has a lot of trans layers. Forcing the last step to see what is behind the layers stops the engine from seeing nothing (black) versus seeing what is behind the layers of transparency.

    Setting it up in a similar way can also stop the hair from blocking all of the light when it should let far more thru. This also can compound based on the type of lighting used.

    An easy way to set this up to see the difference is to just set max bounces to something low like 4 and do a render without terminating it to transparent versus doing so. You will get very harsh shadows with it set to 4 without the shader, and with it it will only use 4 layers for the shadows.

    Clamping things to a max amount of bounces has it's advantages in both render speed and quality of things like shadows. For speed you basically want the illusion of it being right, without having to brute force everything.



  • @shvrdavid Yeah, the black areas are bad, so I set my max trans to 32. But you are saying, as a trick, to set max trans lower and then have this math node halt the bounces so it doesnt need to go the full 32 bounces to get rid of the black parts?


  • Poser Team

    @ghostship

    Yes, if you set the bounces in the shader to switch to transparent the ray cast will switch to what is behind it instead of terminating to black.



  • If anyone is interested here is a new hair shader. This one is pretty simple. The highlights fall in the same places as BB's shader but it still needs good texture maps that do not have highlights or shadows burned in . I'll post up a screen shot of the shader tomorrow sometime in the morning. This shader renders in around half the time as the BB shader.
    0_1498030038325_New Hair.jpg



  • Ok here is one with a blonde map.
    0_1498030910839_New Hair Blonde.jpg



  • That looks good to me! Posting the shader settings would be much appreciated... especially as I still don't grasp how to build the thing shrvdavid mentioned^^



  • @varnayrah most of the nodes come from the Cycles menu and the hsv2 and map nodes come from the Poser menu. you might have to play with values in the hsv2 node to get the right highlights.
    0_1498056495822_Hair shader 1.jpg



  • @ghostship said in Rendering transmapped hair in Superfly: very long render time:

    @varnayrah most of the nodes come from the Cycles menu and the hsv2 and map nodes come from the Poser menu. you might have to play with values in the hsv2 node to get the right highlights.
    0_1498056495822_Hair shader 1.jpg

    Nice work! :D

    I'll look forward to trying this. It seems like a good compromise between speed and physical accuracy.



  • Thank you very much! I'll try that out as soon as my current render is finished.



  • @ghostship Looks good. I shall try using this for transmapped hair in Superfly renders.



  • @shvrdavid said in Rendering transmapped hair in Superfly: very long render time:

    You can cheat trans mapped hair in SuperFly where it renders a lot faster and still looks ok.
    You do have to play around with it and figure out what the minimum number of trans bounces you need to get it to fill out. (It will still have black areas in it if it has a lot of layers) Once you know the number of layers you need, set the shader up to go transparent after X number of bounces. You don't get black spots that way, and you don't need all the bounces either.

    You can define the number of bounces the render engine will see in a shader, then ignore the rest like this.
    alt text

    Plug whatever shader setup you are using for the hair into the Diffuse BSDF, then set the value in the Greater Than to the number of bounces you want the engine to stop seeing the hair.

    If you get into the habit of defining bounces in the shaders, you can just set the engine to anything above that and forget about it.

    @shvrdavid Sorry for the late response to this.
    How does this work when you are using a transmap to modulate between your hair shader and transparent BSDF? In the screenshot you posted the transmap would normally go where you've got the math and light path nodes.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.