OpenGL Problem - Black Eyes



  • Sure

    In Material Room / Advance Tab Settings

    0_1498700526411_Poser-Black-Eyes-Material-Room-1.jpg

    0_1498700542943_Poser-Black-Eyes-Material-Room-2.jpg

    Render Settings

    0_1498700610363_Poser-Black-Eyes-Render-Settings.jpg

    worth noting, Rendering (for the most part) in color texture shading is normal. Despite the black eyes in Preview mode, when the images get rendered, the eyes becomes normal.

    However, if I turn on Comic Book Preview Options, the black eyes still appear. When I do an Anti-alias Document render for this black and white comic book look, the black eyes remain. This is also the same for Sketch renders. The black eyes remains when rendering Sketches

    0_1498701266757_Poser-Black-Eyes-Comic-Book-Preview-Options.jpg

    0_1498701345493_Poser-Black-Eyes-Antialias-Document-Render.jpg

    0_1498701490731_Poser-Black-Eyes-Antialias-Document-Render-2.jpg



  • I was able to get some "moderate" level of success by using a picture of an eyeball for a Texture Map and setting the Diffuse to "White".

    Still, not quite for what I was hoping for. Doable yes (for still images only), but if there's a better option by tweaking the Material settings to normalize the eyes, that would be so much better - that way, I can have full control of the eyes (scale, up down, left to right, right to left etc.) from the Parameters / Properties panel.

    0_1498707773710_Poser-Black-Eye-Solution.jpg



  • The problem is almost certainly connected with those math nodes connected to the transparency inputs in your first screenshot. Also, there's a connector from the Math_Functions_2 node going off-screen and we can't see where it goes. OpenGL is limited in how it handles complex node set-ups.

    Try deleting all the nodes attached to transparency, and see how that works.



  • Hi

    I deleted the 3 nodes attached to the Transparency. Results still look the same.

    0_1498730334528_Poser-OpenGL-Black-Eyes-No-Transparency-Nodes.jpg



  • I hadn't spotted this before, but your specular value is very high. Try reducing that to zero - you shouldn't need it since you already have anisotropic plugged in to Alternate_Specular.

    What's that purple link connected to Diffuse_Color? It seems to be headed for Image_Map_3, but stops short before it gets there. Disconnect that, since it won't contribute to a render, but it may spoil the preview.



  • Since it renders ok, try turning off the hardware shading in your preview settings.



  • Hi

    I lowered the Specular to zero, and disconnected the other node linked to Image Map 3. The result is still the same.

    0_1498735365569_Poser-Black-Eye-Specular.jpg



  • @redphantom I tried turning off the Hardware Shading, the result is still the same.

    I also disable Hardware Antialias, that didn't help either.

    0_1498735838230_Poser-Black-Eyes-Render-Settings.jpg



  • I don't have a graphics card in one pc, just an AMD processor with built in HD graphics, and using PoserPro11 and OpenGL on that one, loading JamesCasual doesn't present this problem with the eyes. I checked and the preview options are all as your screenshot.

    Is your Poser and content all up to date just in case that's causing it? Have a look at the PoserDownloadManager to see.
    Poser should be on 11.0.6.33735 and your content should be 11.0.6.33625.

    0_1498740106309_versions.jpg



  • Hi, I have the latest version. I was told by support that OpenGL might not work 100% with PC using Intel HD Graphics Card.

    There was another user (erwin_sc) who wrote on one of my previous post from last year, who had the same problem. His computer also uses a similar Intel HD Graphics Card.

    He was able to reasonably fix the black eye issue through the Material room. Although he didn't elaborate on what he did to "reasonably" fix it. I am hoping he returns and respond.



  • OK, just thought it was worth checking. Have you tried changing the document display style at all? Selecting one of the lined document display style options (hidden line, lit wireframe, flat lined or smooth lined) should allow you to see the figure's eyes in order to utilise the parameters dials. Not the fix you want but maybe usable?



  • @raven I need to use the Comic Book Preview Options to get that black and white cartoonish look (follow by an Antialias Document Render). This function can only be used in OpenGL (it's disabled in SreeD view for some reason) under my circumstances.

    If I can enable this function in SreeD view, then I probably don't need OpenGL then. In my current SreeD view, the eyes are normal. In OpenGL, the eyes are black.



  • turn diffuse value to 0. that is why the eyes are now white. all you want is for the eyetrans to be transparent.



  • With the diffuse color 'white', after changing the diffuse back to '0', all it did was made the eyes black again.

    0_1498788789975_Poser-OpenGL-Black-Eyes-Diffuse-Value.jpg

    Starting all over again, with the eyes black, I turn the diffuse value to '0'. There is no change in results.

    0_1498788884604_Poser-OpenGL-Black-Eyes-Diffuse-Value-2.jpg



  • @Twister1996 the black is coming from the anisotropic node plugged into the alt spec. remove that.



  • YES! Finally got the black eyes removed

    0_1498795260698_Poser-Black-Eyes-anisotropic-node-removal.jpg

    Is there a way to save this particular Material Settings so I don't have to configure it every time I start a new file? That way, every new file will start up with this material configuration automatically.

    Thanks All :)



  • @Twister1996 if you always use james as your figure you can texture him the way you want then save as a new character preset (figure library) and then every time you load him up he will have the texture setting you wanted.



  • I just realize something. All the figures have a totally different Material setup than James.

    This is Pauline:

    0_1498800880042_Pauline-Black-Eyes-Simple.jpg

    0_1498800987727_Pauline-Black-Eyes-Advance.jpg

    Is there a common configuration that I can do for all the figures, that could get rid of the black eyes for all of them. Any commonality that would work for all of them?

    such as -

    1. setting the diffuse color to white
    2. defuse value to '0'
    3. specular value to '0'
    4. disconnect / delete all the nodes

    etc.



  • Any ideas how to normalize Pauline's eyes?



  • @Twister1996 It depends on the geometry of the eyes. Vicky 3 for example has a section that only covers the iris that is intended to be transparent while the rest of the eye is the "eye whites," so you would not want that part to be transparent. Pauline has a "cornea" section that covers the entire eye (same with Vicky 4 and Micheal 4) just the same as with James so it would be similarly textured.