Issues with Poser Pro 11 viewport

  • Hi folks. I'm having issues with pan, rotate and zoom in the PP11 viewport using key commands. The screen will hang temporarily and I'm not able to adjust the camera view. Sometimes the movement will lag so when I think I've adjusted the view just so, it will snap back into another position. I don't know if manual adjustment still works since I always use key commands. I wondered if anyone else was having this issue, if there was a fix, or whether I should try deleting the prefs or reinstalling. I'm using SR6 at this point. Thanks.

  • @dcrosby I have never used keys to move the camera around so I don't know what keys to use. I looked in the manual but did not see any info on this. What keys do you press to move the camera around?

  • @ghostship Spacebar+drag lets you pan your view. Option+drag lets you orbit your view around the selected object. I used the word camera because I'm essentially looking through the lens as it moves though not selecting and dragging it manually. Apologies if I wasn't clear.

  • @dcrosby Hmmmm, I don't think I've ever used key combos for moving cameras in Poser before. I do it all the time in my modeling apps, but never thought I could do it in Poser. I'm going to have to try that out when I have Poser open later.

  • @dcrosby OK just tried this out. I'm on W10 and I'm assuming you are on a Mac (I used alt instead of option.)

    Seems to work just fine on my system.

  • @ghostship OK. I figured it was just me. I hadn't heard anyone mention the prob on the forums before.

  • @dcrosby I have something similar on Mac. Option Key + Mouse orbit changes the cursor to a photographic camera and seems to work fine, but if I try to do the pan equivalent, it puts stupidly large translations on the camera, which seem like a jump, and then anything you do with the camera seems to have no effect, because you're left looking at the background with the camera off at infinity, with none of the foreground figures or objects visible.

    If I manually reset the camera translations in the parameters palette, I can see what I expect to, but the camera remains flaky, as though its sensitivity has been messed with and it continues to jump around.

    I have a trackpad, rather than a mouse, and the zoom by pinching/spreading fingers seems to work properly for me, though, again, it's very easy to get large negative z-translations on the camera if you spread your fingers too quickly and then can't see anything but background.

  • @dcrosby said in Issues with Poser Pro 11 viewport:

    @ghostship OK. I figured it was just me. I hadn't heard anyone mention the prob on the forums before.

    Not just you. I don't use the combination you mention, but I have a similar problem when dragging the 'pointing hand' icons for camera movement, which is my normal method. Sometimes the X-Y movement turns into a Y-Z movement of its own accord, and the only way I know to fix it is to click randomly on the icons until it works again.

    It's similar to the effect you get if you hold Ctrl while dragging the hand icons, and to begin with I assumed I was holding the Ctrl key a little too long since the problem often seemed to happen when I'd used a Ctrl-[key] shortcut to change camera. However I paid closer attention to what I was doing and the trouble cropped up even when I hadn't touched Ctrl.

    I thought I'd posted about that on a forum, but can't remember which one it was now. It could have been RDNA, in which case phooey. :P

    Anyway, I couldn't find anyone else to corroborate my story, and SM support didn't have a clue. I suspect it may be to do with a particular combination of drivers, or hardware, or something that not everyone has. It dates back to the new interface that came in with Poser 8 onwards, as far as I can tell; Poser 7 and earlier never had this problem.

    I tried your method on my system (Poser 11 standard, SR7, WIndows 7) and it worked as expected. But my method is also working at the moment; if I remember, next time I see the problem, I'll try both methods to see what happens.

  • @anomalaus Check the scale of your camera. A lot of times crazy jumps for me are caused by that getting too big.

  • @englishbob Cool, misery loves company, lol. My Mac could use a serious cleaning out or maybe a reboot. I can't remember the last time I restarted it. I tend to get random issues no one else has. Oh well.

  • @dcrosby We're just more discerning than the average user. Look at it that way. :)

    I found the thread I posted, by the way. Just linking this here for reference.

  • @englishbob I rarely use the icons for movement. Only when I'm holding a beer and can't use my other hand (and no, releasing the beer is not an option). Think I'll try installing the latest update. I don't think I've heard of any issues with it... right? Thanks all who commented.

  • A general note: I've run into this issue before using other software. The keyboard commands are interpreted differently, of course, and keyboards will repeat characters when keys are held down. Sometimes, making very slight adjustments to the keyboard repeat speed settings in your OS can make this issue go away. (Previous experience was the program I was using was trying to update what it was supposed to do every time the keyboard was pressed instead of using the mouse.)