PoserPro 11 Transparencies

  • I have read, and re-read, the 10-month old thread where Bagginsbill discussed the difference between transparency and opacity --> PP11 Pro Rookie Question - Transparencies but the problem I'm having today while beta testing some textures with transparent/lacey areas that are causing a problem I've never seen before in earlier versions of Poser.

    My PP11 is updated with the latest SR, but I had a good friend try it with her PP11 since she hasn't updated to the latest yet, and she had the same problem. Basically, whether I use the "transparency" map the vendor created, or I use an inverted "opacity" map, what happens when I try to apply the material set is, the whole dress disappears, and I'm left with the character standing there naked.

    My friend then tried saving a scene in her PP2014 with a transparency setup, and then opened her saved scene in PP11, THEN it worked, so I tried it because I had already tested the textures in my P9, and sure enough the scene opened in PP11 with the transparencies intact.

    Has anyone come across anything like this? Can anyone confirm (or deny) this happens for them? I'd like to take out a support ticket if this is indeed a quirk with PP11's (or P11's if you have Standard) Material Room. I had really wanted to set up a different character, and pose as it's a dynamic piece of clothing so thought it would be nice to give the vendor a different "scene" as it were. She's already seen all the P9 renders and was very pleased. Now I have to tell her it's not going to be this easy in PP11. I suspect she's working with PP2014, or she would've come across this problem, UNLESS of course, she just opened her PP2014 scenes in PP11.

    Thanks in advance for any tips/tricks/suggestions you might have.

  • Provided the material is being applied correctly - I've seen this happen. But, it usually resolves itself. However, it does require either a restart or a new scene. I presume that clears whatever faulty cache entry causes it.

    Check to see if it's evident on both OpenGL and Sreed Preview windows. It shouldn't do that on Sreed, regardless of any bug, but it might be worth checking, just to be sure.

    Which item is it? That might help as the cr2/obj can be checked, too. Sometimes, mat zones can get a bit weirded out in the CR2. Make sure you're using the default clothing item and haven't applied any mat pose to it. In my experience, mat poses can cause this problem, too, for various reasons, especially if the creator has made changes to the original object/cr2 but hasn't made sure their mat poses are compatible. (Also check the Display settings for the object/groups/cr2 under "Display" to make sure they're set to being visible or haven't had a weird display setting applied to them.)

  • @morkonan The product is Lully's Love-It Dynamic Dress for Dawn, which is in the HiveWire 3D store. The textures I'm beta testing are going to be an add-on pack for the dress by another HiveWire 3D vendor.

    Another thing my friend tested was to copy the material setup from the PP2014 she had opened in PP11, and applied it to another instance of the dress, and it worked. I'm wondering if it's an internal issue that only occurs when you apply it directly from the Materials Library in P11/PP11.

    I'm hoping others who have used transparency/opacity for some of their projects in P11/PP11 will drop in and give some tips or assurances, other than yours above, that it can work. I'm getting offline now, but I will try again tomorrow, as I always dump my P9 and PP11 cache when I log off each night. I'm going to keep my fingers crossed, and hope it works.

  • You can set the amount of transparency in the preview, and you can set the percentage of transparency in Poser Surface node, or use a "Less White" colour in the Transparency Node for Cycles Surface.

  • Poser Ambassadors

    I have seen it as well occasionally.
    What usually fixes it, is to use the transparency dial and set it a little bit lower, then set it to the original value again. I looks like a redraw problem and by changing the dial you force a new redraw.

  • @wimvdb and @ibr_remote Thanks for those tips. I'm going to try your suggestions and see what happens. Hopefully it might work. It's just strange I've never seen anything like this happen before in earlier versions of Poser.

    I'll let you know how I fair after I've played with it some more.

  • OK, well this morning I tried tips and suggestions from here, and in a thread on the HiveWire forum, and nothing worked, even with my PP11 cache emptied before I logged off last night.

    However, that said, I finally had success, and it was as simple as opening the scene I created yesterday, deleting the dynamic dress, and then loading in a new instance of the same dynamic dress. Then I applied one of the textures with transparencies, and YES it worked when applied directly from the Material Library. ~wide grin~

    Needless to say, I'll have to re-sim the dress, but that's the least of my problems. This is definitely quirky, but now I know what to do if, and when, this happens again.

  • @Miss-B can you post a screen shot of the material that has the transmap?

  • @ghostship Did you just want to see the texture map? Or do you want to see one of the renders?

  • @Miss-B i'm mostly interested in the mat room setup you can show the transmap in the mat room too.

  • @ghostship Ahhh, OK. I'm running some renders of the textures in PP11 SF, but as soon as the current one is done, I'll do a screenshot of the setup, which is a very simple setup.

    OK, I just checked, and I'm only 1/2 way through the SF render, so it's going to be a while, but as soon as it frees up, I'll run the screenshot for you.

  • @ghostship OK, so here's a large screenshot. On the left is one of the dress textures on the figure, and on the right is the Material Room setup.

    As you can see there's only 3 images, the Diffuse Map, the Bump Map, and the Transparency Map.


    I'm not sure if the forum will show it full size, so you may have to click on it to see the details of the nodes.

    As an FYI, the transparency is either the whole sleeves, or around the bottom edge of the sleeves and, as you see here, a large portion of the bottom of the skirt, or just around the bottom edge of the skirt.

  • @Miss-B Try plugging the transmap into the edge as well. I would also make ambient value 0.

  • @ghostship Yes I was surprised when I saw she hadn't done that, as I usually see transmaps plugged into both those nodes. Sometimes I've even seen them plugged into Falloff as well.

    I uploaded renders for her to see of how they look in PP11 with FireFly, so we shall see if there's anything else I need to check out. I even ran 3 of them through SF, and they didn't look all that bad. Something I've noticed about clothing textures in SF, if the setup is simple enough, and not a true "shader", then it usually renders pretty much as it does in FF. This isn't the first time I've rendered non-SF specific textures through SF and have them render nicely.

    Meanwhile, I'll check out your 2 suggestions and see how they look.

  • @Miss-B assuming I'm not mis-remembering one of @bagginsbill 's tutorials, transparency edge and falloff are a means to simulate refractive effects (greater thickness of material at edges) when one is not doing ray tracing. For an ordinary transmap, expecially one for lace, the lace threads are more or less fully opaque and the holes are fully transparent. Transparency edge and falloff have no place in a PBR environment, as you mention using SF. I would zero both transparency_edge and falloff and not bother plugging anything into them.

    A lot of older materials had the Poser Root node defaulting the Transparency_Falloff to 0.6, which is just wrong for SF renders.

  • @anomalaus Thanks for that tidbit. I'll pass it on to the vendor, though she didn't specifically make these textures for use in SF. I was just "playing" to see how they'd turn out. ~wink~

  • @Miss-B said in PoserPro 11 Transparencies:

    @anomalaus Thanks for that tidbit. I'll pass it on to the vendor, though she didn't specifically make these textures for use in SF. I was just "playing" to see how they'd turn out. ~wink~

    The "quality" setting on Filter type shouldn't be used. It should be "none" for sharp transmaps. Make sure Gamma, on the image select drop-down, is set to 1.

  • Poser Ambassadors

    AFAIK turning off texture filtering = turning off antialiasing. Inherently less accurate results so while it may work under some conditions that won't always be the case - just something to be aware of IMO :)

  • Thanks for the comments, and I'll make a note to try them out.