Power loader

  • I think I broke my V4 elite body morphs. M4 when I load him has elite listed in his morphs even when I don't have the morphs loaded. When I load them, they work fine. V4 used to too. But right now, that's not the case. I don't have the slot and nothing loads. I'm assuming I need to use the powerloader thing again. I downloaded it manually but I have no idea what to do with it. Can anyone help?

  • Go to the runtime where you have V4 installed and in this path :Runtime:libraries:!DAZ you should find DzCreateExPFiles-V4.bat Just run that and the channels will be created. Make sure you use the V4.2.cr2 and not a pre-saved character with a different name because they won't show up there.

    Oops I just read you downloaded the powerloader so that means you're using Daz Studio right? Disregard the above. I don't use DS so I don't know how the powerloader works.

  • No, I use Poser. I downloaded it because I thought I needed it. I tried your suggestion and it didn't help. The morphs still don't load.

  • @redphantom Do you have more than one installation of Victoria 4?

  • I'm with Kalypso on this one. Reinitialize V4, and the morphs should show up.

  • The bat file didn't help. I only have victoria 4 installed once, but I have a few cr2s saved of her under different names in the same runtime. Do I need to get rid of those?

  • I don't know if this would work, but Karina's Sasha-16 in the figure setup folder has an icon to load elite morphs, It worked with Sasha and might work with a regular V4. You can also manually install the morphs from the folder in your DAZ runtime.

  • @redphantom you shouldn't need to get rid of any character you've saved to the library yourself. The only ones which may have a problem are the DAZ supplied base figure.

    Can you tell us what sizes the files you see in your character library are? Do you have Victoria 4.2 EZ? That file (about 1.2MB in size) uses readScript lines to load groups and morph slots for whatever V4 product packages are installed in the folder @kalypso mentioned, where the bulk of the V4 & M4 morph injections reside. Loading that figure will give you a character with groups, but no injected morphs. The morph injections are done (the first time) with injection pose files in :Runtime:libraries:Pose:Victoria 4:DAZ's Victoria 4:Morph Injections.

    I'm guessing, from your first post, that you know all that, but sometimes it's easy to overwrite one of the installed files. If you can check the character file in the library with a text editor and see any lines that start with "readScript" you should have the right file (and it's a lot smaller than a fully loaded V4 .cr2 file).

    The very first one in the file should be in the BODY actor and look like:

    		readScript ":Runtime:libraries:!DAZ:Victoria 4:V4BODYGrps.pz2"

    Opening that file in the text editor (assuming it's not compressed as a .pzz file) should show all the groups for installed products. (This file gets built when you run the batch file @kalypso mentioned) and should contain (amidst all the rest):

    			groupNode Elite
    				collapsed 1
    				parmNode FBMUtopianBody
    				parmNode FBMFantasiaBody
    				parmNode FBMSylphBody
    				parmNode PBMGenitalCrease2

    If it doesn't, then you won't see an empty Elite group in the parameters tab and the channel slots may not exist to allow the morphs to be injected. At this point you should probably try to reinstall the Elite morphs product "ps_pe072_DAZ"

  • I don't have a victoria 4.2 ez. Only Victoria 4.2. I tried reinstalling the elite morphs and also running the bat file again. It's not helping.

  • @redphantom can you confirm that your Victoria 4.2 is about 1.2MB in size and look to see if it has the readScript lines in it? The batch file will only process what it finds in the :Runtime:libraries:!DAZ folder. If the file you have in your character library doesn't have the readScript lines, it's not referring to anything in the !DAZ hierarchy.

    If the Victoria 4.2.cr2 file already has groups in it, I think you will need to re-install the base Victoria 4.2 package. DIM can do that for you (I've just looked inside the installer folders and the IM00004783-01_Victoria42Base.zip file contains a Victoria 4.2.cr2 of the right size to have only the readScript lines. You will certainly need to run the batch file again after that. I'm on MacOS, so I can't tell you what file paths to look in for DIM packages, but the :Runtime: structure on both platforms is identical (except I run DzCreateExPFiles.app, instead of .bat)

  • If you re-install V4 and the morph packages from DAZ using the DIM this should automatically initialise v4 for you. This is the only way I've ever got the morph packages to work for me, never managed to get the batch file to do the job.

  • I tried the DIM too and it didn't help.