Create UV Templates directly from Poser

  • But that texture fits the car perfectly, it's the original one. The template seems to be wrong, that's the problem, and there are no guides on the original textures to help with creation of new ones. That's why I'm struggling, because it seems like the textures and templates don't match up.

  • @Glen85

    If you go to, you can get UV Mapper Classic for either Windows or Mac. This is the FREE version. This program will allow you to create your own templates.

    1. Choose FIle > Load Model, and select your OBJ file.
    2. After the file loads, choose File > Save Texture Map.
    3. In the BMP Export Options, enter the size of the template you want to create. These are usually square, and rule of thumb is to make them 1024x1024, 2048x2048, or 4096x4096.
    4. Choose OK.

    The template can only be saved in BMP format, but you can easily convert to any other format with Photoshop.

    After you create the template, it would be interesting to see if it is any different than the one you show above.

  • Errmmm... >.>

    Methinks it went wrong.


  • @Glen85
    Nope nothing wrong. What that tells me is that the car you are trying to texture does not have the same UV map as your template above, and also that it uses more than one texture, which is why they are overlapping. Where did you get the car?

    Wait a sec ... create a copy of the original template. Then use photoshop to resize the template copy to the same size as your texture map that works. What result do you get when you layer them in photoshop? Do they match up?

  • I'm not sure what you're asking me... screenies from Photoshop are above, but scaling it to match the original maps is a problem because the maps are really basic, just big blocks of colour, so I've no idea where the edges are meant to be. The link to the car is in one of the above posts. Here:

    I just want to make a new map for it, one which is realistic. It really shouldn't be this hard, I don't understand most of this. With everything else I've ever made new maps for, I've just used old maps as templates and that has worked perfectly fine, but this is just a complete mess!

  • This is the result of applying the template directly to the body of the car it is supposedly for... totally wrong!


  • This guy has done the livery I want for it, but it's not available anymore and it looks like he's closed his store. Ugh, rotten luck!

  • @Glen85
    OK based on the screen shots you are showing I can't figure out what is going on with the mismatch between the textures and the template. I tried to rescale them in a couple of different ways to see if I could get them to match up, but no luck.

    I would contact the vendor, or perhaps someone at the Renderosity store, to ask if someone can generate some new templates that match up with the car. I would offer to do them but 30 dollars is more than I want to spend for something that I probably wouldn't use after that. 8-)

    But yes, if applying the template directly to the car produces those results, something is off.

  • It's odd because people have given it high ratings for ease of texturing... I don't get it! It would be good if I could delete parts of the template from that app you sent me, but I can't seem to do it. I think I'll contact the vendor about it. Thanks for your help.

  • @Deecey this is just wrong information for anyone running macOS releases after 10.6 Lion on Intel CPUs. UV Mapper Classic is a Motorola PowerPC application. Apple deprecated and then rendered obsolete Rosetta, which was required to run PowerPC applications on Intel hardware from that time (2006) on. These apps cannot be run on the latest macOS at all. No way, No how.

  • @Glen85 I've PM'd you a non-GUI version of the script with debugging to list the groups and materials to work out the best solution for separating the overlapping UV templates. Can you post the output here, please?

  • @Glen85
    Not being a regular Mac user, there was no way for me to know that the information was "wrong." Thanks for the correction.

  • @Deecey not your fault. The vendor has abandoned the macOS version of the software and left links to the zombie corpses littering the web page. About as useful as apps for an abacus. X-/

  • @anomalaus
    No problem. I only touched Macs for documentation, when features or screen shots were slightly different than the Windows version. I do have a MacBook Pro that I bought 3 years ago for work but rarely touch it because most of my software is PC-based.

    Love the look of MacOS, but to make the switch from all the software I use would be a major investment that I surely can't afford now. 8-)

  • Loading UV from OBJ file "E:\Runtime\Geometries\Lwanmtr\DPMotors\CV1.obj"
    Counted 529422 facet edges
    Counted 14802 seam edges
    Read 759466 lines from file
    Num Verts = 266794 (266794)
    Num TVerts = 229461 (229461)
    Num Norms = 0 (0)
    Num TSets = 1044228
    Num Elems = 262724
    Num Sets = 1044228
    Num Seams = 14802
    Num Sections = 0
    Num Groups = 17
    Num Materials = 59
    CV-Int-DummyLightPlastic, UDIM=1001
    CV-Int-DummyLight, UDIM=1001
    CV-Chrome, UDIM=1001
    CV-Body-RearClipStrip, UDIM=1001
    CV-Body-FrontClipStrip, UDIM=1001
    CV-Body-Side, UDIM=1001
    CV-Int, UDIM=1001
    CV-Black, UDIM=1001
    CV-Int-Trunk, UDIM=1001
    CV-ChromeBlack, UDIM=1001
    CV-Body-Glass, UDIM=1001
    CV-Body-HoodInner, UDIM=1001
    CV-Logo-Clear, UDIM=1001
    CV-Logo-Color, UDIM=1001
    CV-BlackPlastic, UDIM=1001
    CV-Body-Mirror, UDIM=1001
    CV-Body-Light-Head, UDIM=1001
    CV-Body-Light-HLite2, UDIM=1001
    CV-Body-Light-Orange, UDIM=1001
    CV-Body-Light-Cover, UDIM=1001
    CV-Body-Light-Int, UDIM=1001
    CV-Rubber, UDIM=1001
    CV-Body-Door-WinTrim, UDIM=1001
    CV-Dash-Buttons, UDIM=1001
    CV-Dash-Vents, UDIM=1001
    CV-Dash-InstNeedle, UDIM=1001
    CV-Dash-Instrument, UDIM=1001
    CV-Dash-Main, UDIM=1001
    CV-Dash-Main-2, UDIM=1001
    CV-Dash-DK, UDIM=1001
    CV-Seat, UDIM=1001
    CV-GasTank, UDIM=1001
    CV-Body-Bottom, UDIM=1001
    CV-Body-Light-Red, UDIM=1001
    CV-Dash-Env, UDIM=1001
    CV-Dash-CDDisplay, UDIM=1001
    CV-Body, UDIM=1001
    CV-Dash-InstGlass, UDIM=1001
    CV-Tire-Lores, UDIM=1001
    CV-Tire-BrakeDisc, UDIM=1001
    CV-Tire-Hubcap, UDIM=1001
    CV-Tire-Rim, UDIM=1001
    CV-Tire-Rim-Edge, UDIM=1001
    CV-Body-TrunkChrome, UDIM=1001
    CV-Body-TrunkInner, UDIM=1001
    CV-Body-Light-BULite, UDIM=1001
    CV-Body-TrunkRubber, UDIM=1001
    CV-SColumnLever, UDIM=1001
    CV-SColumnLeverHandle, UDIM=1001
    CV-SColumnDGrey, UDIM=1001
    CV-SColumn, UDIM=1001
    CV-SWheel, UDIM=1001
    CV-SWheelButton, UDIM=1001
    CV-Int-Pedals, UDIM=1001
    CV-Int-Door, UDIM=1001
    CV-Body-Door-Inner, UDIM=1001
    CV-Int-Door2, UDIM=1001
    CV-Body-MirrorBody, UDIM=1001
    CV-Body-Door-Trim, UDIM=1001
    UV Range = ((0.0, 0.99999999), (0.0, 0.99999999))
    Traceback (most recent call last):
    File "C:\Program Files\Smith Micro\Poser Pro 2014\Runtime\Python\poserScripts\ScriptsMenu\Utility\", line 769, in <module>
    CreateUDIMUVMap( UVObj, UVName, size=templateSize )
    File "C:\Program Files\Smith Micro\Poser Pro 2014\Runtime\Python\poserScripts\ScriptsMenu\Utility\", line 473, in CreateUDIMUVMap
    font = ImageFont.truetype( 'Arial.ttf' )
    TypeError: truetype() takes at least 2 arguments (1 given)

  • That's what the script is outputting, no maps or anything.

  • @Glen85 thanks, that's the debugging I need to see. Though I'm running Windows 10 on my dual boot iMac, I see now that there is a difference in the Pillow version of the PIL libraries I had to install on macOS to fix some broken functionality with saving JPEG files from PIL. The specific difference is that the font size parameter in that "font = ImageFont.truetype( 'Arial.ttf' )" call has a default value for the font size in Pillow, but not in PIL, where it has to be explicitly stated.

    I'll send you another version of the script to fix that, when I've tested it under Windows.

    The other issue is with the CV-1 model's material naming, which the debugging output gives a good handle on. Since I had not envisioned building a full UV mapping utility, I think I can give you a useful separation of UV templates by using everything before the second hyphen '-' in the material name as a key. E.g. every material starting with 'CV-Body' will be in one UDIM map and those starting with 'CV-Int' will be in another, etc.

    This won't be a perfect solution, but until I have a GUI which will let the user choose which material to place on which UDIM region, it should give you something useful, and help me confirm it works on other systems.

  • @Glen85 nothing is ever "easy" with cross-platform support, sigh.

    Adding the font size just throws up another error "The _imagingft C module is not installed". I wonder just how much of the python installation bundled with Poser was ever tested.

    Anyway, this is just to do with fonts and not relevant to your issue, which is simply to get accurate UV templates (with or without seam guides), so I can just toggle the flag which suppresses facet numbering and the fonts are not required. The script works under Windows 10 (and 7, I hope) again, as it did previously when I posted Andy's UV template. I'll throw in some UDIM separation as I mentioned above and send you another version.

  • @Glen85 sent you a revised script link. Fingers crossed it doesn't throw any errors on your system.

    I can't see whether you mentioned you have .BMP files opened by Paint by default, as Photos (which might be Windows 10 only, I can't remember) doesn't handshake properly with PIL (Python Image Libraries).

  • Thanks a lot for the updates, I haven't checked my messages yet... my internet has been giving me hell for a few days and I don't know if it's fixed yet. Doesn't seem to be my provider, as whenever it disconnects, I can access wifi on my phone just fine. Ugh, who knows? I just might disappear for a day or so at a time, that's all. ¬_¬