Major Poser 11 bug



  • I was messing about with second skin textures for V4. The setup is EZSkin3 SSS and my own shader mixed by a mask in the hip zone. Works just fine. I copied this setup in the material room and replaced the SSS with this mixed version on the torso but it does not work. I tried every diofferent combo of deleting the old shader and pasting the new one and nothing would get it to work. I also tried setting it up manually and that gave me the same wrong result. How it SHOULD look is like she is wereing a bra and the skin parts should be SSS just as it looks on the hip zone.
    0_1504467981532_Poser 11 bug.jpg



  • @ghostship

    Can you show the material room settings for the torso? Especially the mask?



  • @Deecey here it is. the shader setup should work the same way it is on the hip zone as it is in my last image.
    0_1504470104320_mat room bug.jpg



  • Not sure if I really understood your problem, but here's something which almost made me lose my hair some years ago :)

    I do use dedicated texture folders for all of my characters, and for any other modified texture maps too (often I adjust hue/brightness, add detail, etc.).
    I save the modified textures into those folders to keep the original files intact.

    However if you modify the copy of the original texture file in a different folder, and the file name is exactly the same, then Poser will insist to use (and write into the resulting .cr2 file) the original path of the (unmodified) maps that are still in it's textue cache.

    SO you may change the texture path in the material room as much as you like, Poser will always replace it with the path from the cached original texture.

    SO if you replace
    runtime:textures:vendorName:characterName:"torso_diff.jpg"
    with
    runtime:textures:yourName:yourCharacterName:"torso_diff.jpg"

    Poser will still write runtime:textures:vendorName:characterName:"torso_diff.jpg" into the saved file.

    There's only one way I know of to stop Poser from doing this:

    RENAME your modified texture maps:
    "torso_diff.jpg" becomes "torso_diff_mod.jpg" and so on.

    Sorry, a bit tired tonight, so my brain is working even slower than usual... :D :D :D

    Karina



  • @ghostship

    OK if you look at your mask image, you have the areas that are supposed to be invisible as black. You probably want to invert it so that white is the area you want to show.

    But the other thing is, the bright green diffuse color is throwing things off too. I suspect you'll have to turn that to a white diffuse color and then plug your skin texture into that as well.

    I'd start there and see what happens. There is something else funky going on as well .... do you have any other masks that could be conflicting with that? Or some other texture that might be assigned wrong? It's definitely an issue with the torso, and it also involves that Main Node that has the bright green diffuse color. What are you using for the bump map that is connected to that?



  • @Deecey this is actually two shaders separated by a mix shader. The mask is telling the mixer what shader goes where. black is the clothing and white is the skin. it works just fine on the hip section of V4 but when I copy it and paste it onto the torso (which uses the same maps as the hip) it does not work. I unplugged the color map and set it to green like that to emphasize what was going on with the shader.

    @karina I think I have already experienced the problem you describe when I uploaded some free shaders and they were calling textures that I was not using.

    Maybe this is a variation on the same problem. I'll have to check this out later when I can turn my main machine back on. (crazy bay area heat wave=too hot to use desktop)



  • @ghostship are you copying and pasting from one material to another directly within the material room?

    Have you tried saving just the hip material to a .mt5 in the library and loading that material to the torso from the library, which will guarantee to replace every single node in the torso shader. If the loaded material still exhibits the same problem, try saving the faulty torso material back to the library as a differently named .mt5 and comparing the files. If they are truly identical (apart from just the material name) I'm at a loss. If they are different, the differences will at least indicate which nodes you need to look at. Perhaps the compound node is not being copied correctly.



  • @ghostship said in Major Poser 11 bug:

    Maybe this is a variation on the same problem. I'll have to check this out later when I can turn my main machine back on. (crazy bay area heat wave=too hot to use desktop)

    Sometimes, Poser's cache refuses to update/replace. I've had the same and similar experiences with this. Even loading a new scene, hopping that will flush it, and then going back to the scene where the problem occurs will not always work. The only cure is to close Poser and restart.

    However... I have seen this problem occur, albeit in older versions, even when Poser is restarted. (A "sticky cache?") In that case, the only solution was to restart the machine.

    I used to use a cache-flusher to fix this problem and would check my processes list to see if one of Poser's processes wasn't closing down, resulting in the cache being left "live." These days, I use "CCleaner" fairly regularly to clean out my cache lists instead of having to reboot. I can't say that works, as I haven't had this issue with the latest version of Poser. But, I also haven't been doing a lot of new mat work with it.

    Note: If you're saving the figure with these new mat settings as a CR2, take a look at the mat references in the CR2 to be sure they're correct. I use an old free version of P3DO to check things like that.



  • @morkonan cooler weather today. had saved the file from yesterday. Opened up and rendered just fine. Places that should be skin are skin. You were right about it being something stuck in cache. Frustrating but now I know for next time it happens. Still a bug I would think.



  • Safest way is to close Poser and clear your texture cache manually (in the Poser Temp Folder).
    Also make it standard procedure to at least RENAME every map that you modify! (Better even to save them in a different folder too!)

    If you don't rename the files, even a new folder won't save you:

    If ANY of your texture paths still points to the old texture and you didn't change the texture file names of the new texture, Poser will again load the obsolete textures and insist that it's the only correct texture...

    And now this is pure speculation because I don' know:
    Maybe even Windows might mess up the textures because of it's caching (some remarks about "restarting Windows" made me suspect this).
    So maybe even Windows insists on reloading the wrong texture from it's own cache?
    So rename the modified files: This will eliminate all these "if"s and "dunno"s.

    .........

    As someone already mentioned before, the last resort is to edit the file manually.
    Search for "runtime:textures:" and check all occurrences of maps for the correct path and file name.
    Quite annoying.

    Karina


  • Poser Ambassadors

    @ghostship
    It looks like a very old bug which sometimes occurs. We have never been able to reproduce it to be able to find out what causes it. As you said, when you either reboot or close and open poser, the texture is fine.
    One trick I used when this happens is to copy the texture and load the duplicate.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.