Rocky 1.6.7 Update (SOLVED)

  • My update experience to 1.6.7 did NOT go smoothly. :(

    I have the (language patched) Japanese and English versions installed alongside each other. I also had them configured to share one Materials location. After the update I had brushes and materials in Japanese, some materials that went missing, and other installations that got overwritten or broken. I’m not sure how much of my problems were related to my particular scenario. It took all afternoon, but I finally got everything fixed!


    You may still have issues with this update even if you only have the English version installed. Namely that it appears 1.6.7 has a “unified” installer for all languages (there was a dialog box during installation I've never seen before that asked what language to install). It installs to a “CLIP STUDIO 1.5” folder instead of “CLIP STUDIO 1.5 EN” folder, which leaves your previous 1.5+ version intact.

    If version 1.6.7 has Japanese brushes and/or materials with Japanese names you’ll need to manually fix that.

    The Easy Way:

    1. Copy the contents of ~/Documents/CELSYS_EN into ~/Documents/CELSYS/
    2. Run Gear—>Maintenance Menu—>Organize Materials from the Clip Studio Assets App
    3. If the Cloud materials are still messed up, try running Gear —> Sync All Materials Installed from Cloud.

    Clip Studio Assets and Paint 1.6.7 should be fixed. But your 1.6.7 and older installations will now be using separate sets of Materials.

    The Harder Way:

    Note that sharing materials between installations seems to work, but I’m not sure whether it’s officially sanctioned or not.

    So, if you want them to share the same set of materials the first thing you need to do is go into ~/Documents/CELSYS/CLIPStudioCommon/ and delete or move or rename the “Documents” and “Material” folder.

    Then open the OLDER Clip Studio Assets app in the “CLIP STUDIO 1.5 EN” folder and go to Gear —> Location of Materials and point it to:
    ~/Documents/CELSYS/CLIPStudioCommon/ (note that on Mac “CELSYS” is an alias to the actual location in /Users/yourname/Library/).

    Confirm the move and wait for it to finish. Now 1.6.7 and the older install will use the same set of materials.


    In addition to renaming the “CLIP STUDIO 1.5” folder and backing up the CELSYS folder you need to undo materials sharing before the 1.6.7 installation.

    1. Open the English Assets app in the "CLIP STUDIO 1.5 EN" folder and go to the Gear —> Location of Materials and make sure it is NOT pointing to the same location as the Japanese version (I recommend pointing it back to the original location: ~/Documents/CELSYS_EN/CLIPStudioCommon/).

    2. NOW you can install version 1.6.7.  It will create a new "CLIP STUDIO 1.5" folder where it lives.  It appears to automatically point to the ~/Documents/CELSYS/CLIPStudioCommon/ location for Materials.  Make sure you let the Assets app go through the big download of materials from the Cloud.

    3. If everything worked, you should have version 1.6.7 installed, with English brushes and Materials from the cloud.  But all your local/custom Materials and brushes will probably be missing!


    Copy the contents of ~/Documents/CELSYS_EN/ —> ~/Documents/CELSYS/


    1. Go to ~/Documents/CELSYS/CLIPStudioCommon/ and delete the “Documents” folder then rename the “Material" folder to "Material1" (or something).

    2. Open the Clip Studio Assets app in the "CLIP STUDIO 1.5 EN" folder.  Under the Gear --> Location of Materials  CHANGE it to point to ~/Documents/CELSYS/CLIPStudioCommon and confirm the move.

    3. Check ~/Documents/CELSYS/CLIPStudioCommon/Material/Install2/ and see if it is empty. If it is delete the “Material” folder and rename the old “Material1” back to “Material.”

    4. Now in the Clip Studio Assets app use Gear—>Sync All Materials Installed from Cloud and then Gear—>Maintenance Menu —> Organize Materials.  You will have to run both these operations from every version of the Clip Studio Assets app or Clip Studio Paint app that is pointing to that same materials location.

    NOTE: Newer versions will not let you change the Materials Location if any older version is also using it. However, older versions will let you redirect them somewhere else. So if you need to change the Materials Location for a newer version you’d first need to change the location for every older version sharing materials with it. Once no older versions are using it anymore, THEN you can redirect the newer version.

    It also gets tricky when you are directing multiple installations to the same location because if the “Documents” and “Material” folders already exist at the location you point to it will complain it can’t move anything there. So you have rename, move, or delete those two folders in order to trick it into moving there. However, the “legacy” versions can’t be directed to a new location, they seem to pick up on whatever location is set by the 1.5+ apps. And now it appears that the all languages will be pointing to ~/Documents/CELSYS/ by default.

    In the end I have the “legacy” Japanese, “legacy” English, English 1.6.2, Japanese 1.6.4, and English 1.6.7 all pointing back into the same Materials folder. So...I guess I was begging for all that trouble, wasn’t I? ;)

  • Clarification where I said

    "In addition to renaming the 'CLIP STUDIO 1.5' folder and backing up the CELSYS folder you need to undo materials sharing before the 1.6.7 installation."

    If you have the Japanese 1.5+ apps installed you'll need to change the name of the folder. I changed mine from "CLIP STUDIO 1.5" to "CLIP STUDIO 1.5 JP" so it wouldn't get overwritten by the 1.6.7 installation.