Strange path for Andy's geometry in Mac Poser 11 default scene



  • Having just tested a UV template creation script in Windows 10 Poser Pro 11 on Andy in the default scene, I ran into a strange result when running the same script in PPro11 on MacOS. The path returned from poser.Scene().CurrentFigure().GeomFileName() has an unexpected leading slash and starts with the Application's Path followed by the rest of the runtime-relative path. E.g.:

    >>> poser.Scene().CurrentFigure().GeomFileName()
    u'/:Applications:Poser 11:runtime:libraries:Character:Additional Figures:Mannequins:AndyP11.obj'
    

    Now, since the runtime within the Poser application's folder is just an empty template, (the content is all installed in a separate shared user hierarchy), I wonder why this worked under Windows.

    Could some Mac Poser Pro 11 user try the above command in the Python Shell with the default scene (AndyP11 in the construct) and let me know what GeomFileName path you see? I'm hoping I won't have to reinstall Poser, but perhaps resorting to that will solve some other outstanding problems I'm having.



  • Does anyone know where the default, factory state .pz3 scene file or definition exists in Poser Pro 11? Is it hard-coded into the app?

    I found that by loading a different, empty scene and then adding AndyP11 from the library, I got the expected GeomFileName() output, which refers to a compressed AndyP11.obz file. Yet on restarting Poser, I still get the same, weird hybrid format path. Anything with colon path separators should never have a slash in it anywhere, as an old style macOS path had the hard drive name as the first part of the path.

    In the mean time, I have modified my script to look specifically for ':runtime' and strip any prefix before that, then use the remainder as a relative suffix for each of the known Poser Libraries when searching for the file, before I give up and ask the user to find it.