Resizing boots

  • So no hope for an actual fix, just work arounds? Thanks for the suggestions. I'll see what I can do.

  • Sydney was Poser8. I do not recognize the boots but they are porobably same generation. We talk Poser 11 now and should be talking Poser 12.
    I do not think there will be fixes on Poser 8 content unless there is massive demand.
    What would really help in this respect is a channel under the same lock as the legacy content downloads. Users could make their fixes and refits for legacy Poser content available in a controlled manner.

  • @redphantom Sydney was Poser 7, which is all I have available on this machine. Include scales isn't an option in P7, but even scaling Sydney and the boots manually appeared to work in a quick test.

    I don't have the boots you're using, as far as I know, although I note you say this happens with any boots. What version of Poser are you using? I can try this later, if the answer is 10 or 11 anyway.

    Work-arounds aren't automatically bad. :)

  • I'm using pp11. I have the same problem with the G2_heels boots that came with her.

    I didn't mean to say workarounds are bad, though most suggested here seem complicated. I tried the morph brush and it didn't help. I know I can't expect a fix from SM at this late date. I was hoping for something that I could do and then save, rather than have to do it in every scene. For example, when joints are spiking on bent conforming cloth, you could use the smooth brush each time or you could resize the inner mat sphere once and resave it.

    Something I should note. I didn't just scale Sydney down 90%. I scaled individual body parts too along the y axis.

  • @redphantom said in Resizing boots:

    I didn't mean to say workarounds are bad, though most suggested here seem complicated. I know I can't expect a fix from SM at this late date.

    Agreed. It would be nice to find 'the answer', then you won't have to work around the problem every time if you want to use this character again.

    Something I should note. I didn't just scale Sydney down 90%. I scaled individual body parts too along the y axis.

    I yScaled Sydney's shins to 80%, and did the same to the boots. Poser 7 would have thrown up problems if I'd tried to use non-uniform scaling in that way in a real posing situation, but it worked well enough for my (admittedly very quick and non-thorough) test. At least I didn't see any of the horrific compound fractures that are in your screenshots.

    I've now located the G2_Heels, and I have other G2 female boots I can try. I may not have time today but I'll give this a whirl and see what I can come up with.

  • @englishbob
    Poser 7. You are completely right.

  • @englishbob
    Trying to hunt down an answer, but I'm wondering if it is due to Sydney G2 not being a weight-mapped figure, and whether the "Smooth Scaling" option is expecting to see one or not.

  • @redphantom said in Resizing boots:

    So no hope for an actual fix, just work arounds? Thanks for the suggestions. I'll see what I can do.

    That's an interesting point. It reveals the different expectations from us as customers. I see your expectation that if you purchased a toon and then some boots for that toon in Poser 7, then they should still work fine in Poser 11 for whatever scaling you do. That's a very good point.

    I have no such expectations. I don't even control anymore which conforming cloth is related to which original character. I used to have folders name "Based on Judy", "Based on M3", etc..., now I just have all clothes in a folder, and when I choose to conform a cloth to a character I almost always export the cloth as a mesh, then fit the mesh as I want, then change back to a figure using the character morphs. For boots and shoes I just skip two steps and parent/fit the thing, as I don't really care for morphs in boots and shoes.

    So the extraordinarily useful fitting tool/change to character functions (added in... errr.. P9?... I forgot) was a complete change of paradigm for me, and I abandoned the previous ways. Now I can fit any cloth to any character, whether that was the base character for that cloth or not. So I see this not as a work-around, but just regular routine to me.

  • @Deecey
    A slight correction on my above post. I meant to say "Include Scaling" option (which is an option in the Properties palette), not Smooth Scaling option (which is a process for weight mapping).

    If the figure was weight-mapped, you'd be able to use the "Smooth Scaling" features in the Joint Editor/Weight Mapping tools to address this. But the G2 figures were created well before weight mapping was introduced to Poser, and they are Poser Traditional figures vs Poser Unimesh figures, and have no weight mapping.

    Memories are fuzzy as to which release of Poser addressed limb scaling, I can't remember if it was added in an SR to Poser 8 or 9. But still trying to hear back from someone that probably has the answer to this buried somewhere in his head 8-)

  • I've been doing some tests to try other figures since it was suggested Sydney might be too old. Many of the figures that come with Poser don't have boots. Simon, who came out with Sydney, had some socks. Those worked ok. Something I noticed with the other figures, when I scaled the shins on the unconformed clothing, the feet rose. When I did it with Sydney's boots, the foot stayed on the ground and the top stretched. My first thought was IKs were on, but they don't have IKs.

    Here's what I mean. V4's boots on left vs Sydney's on right.

    0_1506453452566_boots 3.jpg

  • @redphantom
    That's part of what is fuzzy in my brain, because I seem to recall that the "scaling fix" I'm thinking of that occurred way back in P8 or P9 had something to do with correcting how figures such as The Freak scaled up and down. And The Freak is same generation as V4, which definitely were not weight mapped figures.

    And if you've confirmed that Simon's socks seem to be working OK, and he is the same generation as Sydney -- and if you are having difficulties with MORE than one pair of boots scaling on Sydney, then the problem might actually be in Sydney.

    Do you have any of the other G2 Females by any chance, like G2 Jessi or Olivia? Their body shapes are similar, but wonder if they have the same issue with these boots.

    EDIT: Jessi G2 does the same thing.

  • I have Jessi G2, but no clothes for her. I just use Sydney's clothes. The boots did it with her too. The sample I posted, the boots were not conformed to anyone. I scaled their own shins. And Sydney's and Jessi G2's own shins don't do this.

  • @redphantom
    Oh! You didn't conform the boots at all? So then the problem is actually the boots.

    Let me dig into that and see what I can find.

  • @redphantom
    OK. Seriously. Color me totally confused.

    It's not Sydney G2. It's not the boots. Methinks something is hosed in Poser scaling.

    Image 1 ... These two images are after I took the boots into the Fitting Room. Didn't make any changes, just hit "Create Figure" and deleted the bones that weren't required. I didn't copy morphs, and didn't autogroup (the grouping is fine on the boots). Brought it back into the Pose room, and conformed to Sydney G2. Better than the version that's in the library, but still something wrong.



    Not good.

    Next image. I opened Poser File Editor. Started with Sydney G2's CR2. Replaced the OBJ call to point to the boots OBJ. Deleted the groups from hip up. Saved the CR2. Dragged and dropped onto Sydney. This is especially funky.


    OK one last step. Took the CR2 from the previous version. Deleted the individual toe bones and just kept the single "toe" group. Removed IK. Zeroed Sydney and the boots, and memorized the boot before saving this version to the library. Results pretty much the same as the previous one ....

    0_1506462314230_rerig 4.png

    So it's seeming like something in Poser has broken scales when conformed. Scaling issues also seem to be present in SR7 ... I don't have access to previous builds to determine how far this goes back.

  • Argh. I remembered that the G2 figures use Magnets for bending and thought maybe it had something to do with that.

    So I went back to the latest CR2 I was testing with, and stripped out the magnets. Conformed the boots to Sydney while her legs were scaled. They loaded in incorrectly.

    Then I used Sydney's Add Magnet pose to put them back in the boots. Unfortunately that didn't make a difference either.

    Something def hosed in Poser relating to scaling.

  • It's probably in all of them. I opened up pp 2014 and it did the same thing there. It had the include scaling feature too. And in pp2012, the scaling the boos by themselves showed the same problem. Chances are, it's been there right along, but where few use Sydney, it wasn't noticed.

  • Odd, because the P7 boots don't scale for me, but a couple of other boots seem to work fine, apart from a little pokethrough. Nothing like the serious distortion that afflicts the G2_Heels though.

    Here's an example. Mysthero's Sydney G2 Western Boots, conformed to Sydney G2 in Poser 11 (non-Pro), with 'include scales' checked. I yScaled Sydney's thighs and shins to a rather unrealistic 80% each, and the only problem is a little pokethrough which could be addressed by hiding the toes. IK was off on everything.

    0_1506464652700_Sydney 80%.png

    I'm not seeing a fundamental problem here, except with the G2_Heels, and I haven't delved into the CR2 yet.

  • Another pair: Digicalimero's lace up boots with the same conditions. The pokethrough is worse, because they're closer fitting - but still no major distortion.

    0_1506465005242_Sydney 80% LB.png

  • @englishbob

    (Whimper). The plot thickens.

    There does seem to be an issue with scaling while conforming. But those G2_Heels have another issue as well.

    The feet and toes are parented to BODY, and not to the shins.

    Unfortunately, I'm not having any luck fixing them in the Hierarchy Editor. When I try to reparent the foot to the shin ... CRASH BANG BOOM.

    May need to use PFE or something.

  • OK I've been futzing with this and first those boot are 100% wrong. You'll notice the feet are parented to the body .... somebody didn't know how to remove IK and hacked that wrong. I know who it was and ... grumble ... Somebody made a lot of messed up content. Never mind no need for a rant.

    OK so I fixed them in setup room but that didn't fix this problem. If I fix the boots and then match the pose, including a scale when NOT conformed it's perfect. Then Zero it out and conform it. Kaplewy! I tried matching the scales and leaving the "Include Scales" option off. Then I tried it with the option on and the boots truly zeroed. Same results.

    When scaled are conformed there is a definite shift in the centers of the conformed item. This is a bug and, were I still PM, I'd call it a show stopper. This has been broken for some time. Traced back as far as P10.

    So to get around this at least for the moment, DON'T conform the figure and simply match the pose from the figure in the clothes. Now that won't work on the "G2 Heels" they are far too broken. Clothes made properly will work.