not smoothed polygons in superfly?



  • Hello

    There is a checkbox to smooth polygons, but if I uncheck this box, I get no effect. the polygons of the polished diamond is still smoothed

    How can I NOT smooth the polygon of an ogject, a diamaond for example?

    best regards



  • Re: not smoothed polygons in superfly?

    short answer is no :)

    You can use subdivision (SubD), you have to convert your figure to Unimesh figure first (figure menu)
    subdivision will be avalaible in the property panel, don't go over 1 subd. And prefer to select body part that you need subd (over whole figure subd)



  • Yes.
    Set crease angle to zero. No matter of the checkbox.
    0_1506767499952_Ball.jpg



  • @joker can you tell us which model you're using? There used to be advice to try changing the crease angle in the prop's properties, but I'm not certain if that's still relevant in SF renders. I haven't done much with faceted gemstones since switching to SF renders. If you've created the object yourself, I'm pretty sure using different vertices (identical coordinates but different indices, i.e. duplicated vertices) in common edges of adjacent facets will permanently kill any possible smoothing.

    [Edited] Ah, just seen @phdubrov 's cross-post. Go with that suggestion.



  • @phdubrov said in not smoothed polygons in superfly?:

    Yes.
    Set crease angle to zero. No matter of the checkbox.

    Oh yes go with that solution. But for me this has nothing to do with the render engine, it's a property on the object.


  • Poser Ambassadors

    Different things here :

    The FireFly render engine has an option "Smooth Polygons" in its render settings.
    This smooths out the obj file to the crease angle set in general preferences or in each vertex group individually in the vertex groups properties pannel.
    Crease angle goes from 0° to 180°.

    SuperFly does not do smoothing and disregards the crease angle setting completely. (You can set whatever you want, SuperFly does NOT use crease angle.)

    Another thing is "sharp edges" that you can set in most modelling apps, and THAT is the value inside the obj file.

    Sharp edges is the fastest way to get in trouble so ALWAYS remove them for Poser models. (Normally, Poser ignores sharp edges settings, but I have seen strange results with it enabled.)

    Best regards, Tony



  • I have not done much modeling but subdivision does "look" like a bit of smoothing going on besides just making more polys out of a low poly object. Here is a coffee mug I modeled. It is very low poly but here it is rendered with 3 lvls of sub-D.
    0_1506818327721_Subdivision.jpg



  • @vilters said in not smoothed polygons in superfly?:

    SuperFly does not do smoothing and disregards the crease angle setting completely. (You can set whatever you want, SuperFly does NOT use crease angle.)

    ??? Crease angles 0 and 80. Ball from Pose Primitives.
    0_1506871040113_S0andS80.jpg

    If you are talking about GLOBAl setting in FF options, then yes, SF has no such setting.


  • Poser Ambassadors

    You are right, my mistake.
    SuperFly does use the crease angle.



  • Thank you very much

    Crease Angel 0.0 works in SuperFly



  • @joker you've gotta patent that name for a new steam ironing gadget! "Crease Angel 0.0. It's SuperFly!". Love it ;-)



  • @anomalaus said in not smoothed polygons in superfly?:

    you've gotta patent that name for a new steam ironing gadget!

    haha :-D !!