external content



  • I'm not able to load external content. I've tried them all. For now I have an external runtime folder, but the software does not see it. I tried to copy the contents into the main runtime folder, but it still does not work. I would prefer an external folder, but it does not see anything. can anyone just tell me how should I do it?



  • @stefer can you let us know what version of (I assume you mean Poser, you didn't say, though this is the Poser forum, we get queries for other stuff too, so I'll ask) Poser you're running?

    Do you see anything like this?
    0_1507034826014_Screen Shot 2017-10-03 at 11.45.05 pm.png

    And to add external runtimes, it sounds like you've done this:
    0_1507034915992_Screen Shot 2017-10-03 at 11.45.43 pm.png

    If there was some problem after the selection of a new runtime to be added to the library, you may need to tell it to reload with the two circling arrows at the bottom right of the library window:
    0_1507035129890_Screen Shot 2017-10-03 at 11.49.39 pm.png

    Many people will tell you that it's generally not a good idea to copy stuff into the Poser Application's main runtime, as that can get overwritten when the software and content are updated, but I sense your frustration has you trying many things, so let me know if any of this helps you at all.

    I run Poser on MacOS, but most of the application works identically to the Windows version. If your problem seems to be operating system related, though, you might find others are better able to help sort out Windows filesystem issues that I am.



  • you're right: I did not say the version. I'm using Poser Pro 2012. I can only use Poser Library because if I press "content" the program crashes.
    I can not add any external runtime files and I do not even want to copy them to the folder.



  • 0_1507038213459_message.jpg



  • @stefer so do you see something like this?
    0_1507042205938_Screen Shot 2017-10-04 at 1.48.18 am.png

    I think there's another trick to adding external Runtimes, which is that you need to select the folder or directory which contains the folder or directory called Runtime, not the Runtime folder itself. Poser looks for a folder called Runtime inside the folder you select to determine if it is a "Runtime" that can be added to the library. The name of the folder you select is what is added to the list of libraries, so you don't just see a list where everything is called "Runtime" as that would be a disaster finding anything and knowing whether you had selected the correct runtime.

    If it was a folder called "Runtime" that you selected, then the message your received would be what I expect to see. Try selecting the folder one level up from that Runtime and see what happens.



  • yes the window is exactly what you indicated. Your trick does not work. I also tried renaming the folder with tiny "runtime" for precaution. Too bad ... I was convinced it would work. I've tried both with runtime and runtime, in a lowercase than normal.



  • Upper/lowercase is irrelevant because Windows doesn't care for that internally.
    "E:\MYFOLDER\RUNTIME" equals "E:\MyFoLdEr\RuNtImE" equals "e:\myfolder\runtime".

    However, adding external runtimes can be a bit tricky for inexperienced users.

    Therefore keep it as simple as you can:
    Create a new folder on your external drive and name it: "Poser runtime number 1" (or something to your liking).
    Move your existing "runtime" folder (the complete "runtime" folder with all your content!) from wherever you've stored it hitherto into that new folder.

    Fire up Poser now:
    In the library window (top right) click on the "Add Library" icon as like this, posted by @anomalaus:

    0_1507042205938_Screen Shot 2017-10-04 at 1.48.18 am.png

    The ususal file selector box appears.
    Navigate to your newly created "Poser runtime number 1" folder. DO NOT select the "runtime" folder contained therein!
    Instead, just click "OK".

    Now, in the library window "Show Library: v" (see screencap above, on the left!) you should be able to pick the "Poser runtime number 1" by name, and your content should show up.

    This is standard procedure for adding libraries, and if this doesn't work, you have a much bigger problem...

    So let's keep our fingers crossed!

    K



  • 1_1507052809565_poserruntime.jpg 0_1507052809565_message.jpg
    I always did, but it does not. Do you know how it works? If I put the folder on the desktop! First it was on a server. The desktop also goes without subfolders



  • @stefer I don't have PP2014, but from experience with P9 and PP11, and from what I can see in your screenshot, you're selecting the wrong Runtime. I don't think Poser will recognize your parent PoserRuntime folder. You should try selecting the Runtime subfolder and see if your content then displays.



  • Don't click on the top folder that you labeled "PoserRuntime", click on the folder under it "Runtime", and then see what it tells you.



  • @rokketman
    The folder that is highlighted (PoserRuntime) is the folder that should be selected when adding.

    Out of curiosity, try renaming "PoserRuntime" to "PoserContent" ... in other words, don't use "Runtime" in the folder name. See if that makes a difference.



  • I answer everybody. The only problem was the location of the folder: it was on a server disk and was not accepted: moving it to a PC disk works. I can not explain the fact, but that's right. No problem calling the folder in a different way, using subfolders or anything else ... just move it.



  • @stefer I am glad you found a solution.



  • @stefer that's good to know. Thanks for letting us know, so we can add server based runtimes to the list of things to check for when having trouble.


  • Poser Ambassadors

    @stefer
    Just curious - how did you access the new content folder on your server?
    Did you add it as UNC (like \\server\content\Runtime) or did you create a network drive (assign it a drive letter)?

    The UNC method causes problems, the drive letter method will work fine.



  • I do not have a drive letter, so it is as you say



  • @wimvdb that sounds like a problem that SMS should be (made) aware of (and fix, or at least document), given that UNC is far more likely to be used cross-platform than drive letters, which don't have a corresponding equivalent on macOS, for example.


  • Poser Ambassadors

    @anomalaus said in external content:

    C is far mor

    They are aware of it, I have filed report in the bug database some time ago.

    To be clear about this - you can attach a runtime with UNC, and you can use it to load props, poses, figures, but you can not save something to the library.

    The workaround (for Windows users) to create a network drive.



  • @wimvdb said in external content:

    The workaround (for Windows users) to create a network drive.

    That's a common situation for a lot of programs that offer user-definable directory structures, but that don't specialize in networking functions. Setting up a mapped network drive is usually the only reliable solution. Also, setting up that drive on the host machine to be read/write for the user of the remote machine is often necessary, too. And, such permissions aren't always reliably translated... It can be messy. :)