Clip Studio Assets and Ask acting very broken



  • Has anyone else had problems with browsing Clip Studio Assets and Ask? Here's what I'm getting, it's unusable:

    Assets: the view translation button is disabled on all of them
    Assets: there are two unlabelled blank buttons to the left and right of view translation

    Ask: When I try to 'ask a question' it just goes to a white screen

    Notifications: Top-right bell says I have notifications but none are there when I click it.

    I've recently installed a firewall so at first I suspected that, but I've definitely enabled Clip Studio's exe and I've tried disabling the whole firewall, so it's probably not related...



  • More details: if I try to reply to a thread on ASK, reply field says 'sign in required'. This is while I am signed in, I can see my name in top right. I tried signing out and back in, no change.



  • Sorry to spam this thread but I thought updating Clip Studio might fix it, so I tried running CELSYS\CLIP STUDIO 1.5\CLIP STUDIO\updater\CLIPStudioUpdater.exe but nothing at all happens. I'm not sure if that's normal behavior or not, maybe it doesn't do anything if you're up to date. Apparently I'm running version 1.6.7



  • @cardiacsfan said in Clip Studio Assets and Ask acting very broken:

    Has anyone else had problems with browsing Clip Studio Assets and Ask?

    Of course.
    (The same as you, since day one; in each previous version that has it.)



  • Okaaay, well I haven't had been using Clip Studio long but I though when I first installed at least some of these things were working...

    Are you saying all of these are known issues? Did you read all them? I can't even ask a question on their ask service. Some english-language users are clearly getting that to work, as I can see their posts...



  • @cardiacsfan
    there's a windows-only update to ver. 1.6.8 available, have you considered downloading it?

    I'm on mac, and assets and ask work as expected for me.



  • Thanks for the idea, I've just installed the update. No change, unfortunately.

    All of the problems seem to stem from some failure to fully sign in to my account... tried signing out/in multiple times.

    0_1508972137398_sign_in_required.png



  • I realised I could also post this to Clip Studio Ask if I used the web version at ask.clip-studio.com, which works fine for me... maybe Japanese users have encountered this problem.

    https://ask.clip-studio.com/en-us/detail?id=3502



  • @cardiacsfan

    The only way that I have been able to utilize the Clip-Studio app, is to browse (and login) to their website instead... and click the download links therein; which are then handled by the Clip-Studio downloader —it's nuts; but no more so than them invalidating the entire DVD library that comes in the boxed install disc... and then requiring a re-download of all of it from their online asset store; (which it AUTOMATICALLY tries to do, if you don't stop it). I believe that they do not comprehend the notion of limited bandwidth Internet, and so have no thoughts or concern that the invalidation is even an issue. The software is broken.

    https://assets.clip-studio.com/en-us

    Once clicked (in Firefox/Chrome/etc...), the download appears in the pending list inside Clip-Studio.



  • Huh. The web versions of both of these services work perfectly fine. I wasn't actually aware that that was an option when I first posted this thread. I'll just do that if there's no solution to this issue.

    Clip Studio's developer's would probably be better off referring users to the web version, and just using Clip Studio as a download manager. That would avoid stamping out bugs in two separate sets of code, which is what they must have to do now.



  • A hint on the Ask thread gave me the answer. It looks like the new firewall I mentioned in my first post went and adjusted things in Internet Explorer's settings. Problem is that Clip Studio relies on Internet Explorer (bizarrely). This will affect you even if you've never used Internet Explorer, if something has adjusted the settings.

    @Mechanaut, try opening Internet Explorer, going to Internet Options, clicking Security, and clicking Default Levels. That did it for me.