Where's Waldo, uh Dawn?



  • I've had this happen to me once or twice before. A figure in the scene, just ups and becomes invisible. Poser says it's still there, it just can't see it. This scene originated in PP11, but this particular screen shot was taken in 2014, so whatever it is that's occurring is not version specific.

    0_1510529341558_911b08b8-f03e-4e35-816e-13817fbf247b-image.png



  • @eclark1849 I don't own PP2014 so can't test something like this out, but in PP11, I always have the Hierarchy Editor visible. Does PP2014 have it as well, or is that a "new" thing with P11/PP11?

    If PP2014 has it, open it from the Window menu, and see if the eye icon next to Dawn is visible or greyed out. If it's greyed out, then it could've happened accidentally, and clicking on it should make Dawn visible



  • @eclark1849 what happens when you render it? looks like a display problem IOW SreeD or Open GL problem.



  • @ghostship She doesn't show up in he render either. All of her textures are loaded and I have all of her properties boxes checked, so she should be there. My only thought is that something has corrupted this document. I did change the display mode from Sreed to Open GL, and she still didn't show up.



  • @eclark1849 I have no idea if this is a good idea, but it's what I would try: Select the figure and swap it for another. If that works, swap it again for Dawn. Good luck!



  • @willshetterly I don't know why just Dawn isn't showing up, but as I've said, I think the document has been corrupted. I've already save the poses, so I'm going to re-do the whole scene again.



  • I have a Richabri room that makes a particular hairpiece disappear. It doesn’t affect any other figure, but I can repeat the effect 100 percent of the time. So, outside chance, it could be the scene.


  • Poser Ambassadors

    @eclark1849 said in Where's Waldo, uh Dawn?:

    I don't know why just Dawn isn't showing up, but as I've said, I think the document has been corrupted. I've already save the poses, so I'm going to re-do the whole scene again.

    Did you get an OBJ call when you opened the document? That's the only thing I can think of that would cause the figure to disappear, is if it can't find the OBJ file.



  • @Deecey No, The document loaded fine in both PP 11 and 2014 originally. I even posted a render in the Firefly thread here. Then last week, Dawn just stopped showing up.



  • @eclark1849 said in Where's Waldo, uh Dawn?:

    @Deecey No, The document loaded fine in both PP 11 and 2014 originally. I even posted a render in the Firefly thread here. Then last week, Dawn just stopped showing up.

    She's pretty unreliable, (especially after a night of drinking,) tis the reason I have not asked her back for another photo shoot. I hope she can straighten her life up.



  • @ Earl:
    So this is a scene and was saved with Dawn already in it.

    Did you check which geometry file is referenced for her? Is it still the original geometry file?

    --> Reason to ask:
    If you change the geometry e.g. by adding or modifying vertex groups (grouping tool), or you modify material groups(grouping tool again, NOT Material Room), Poser creates a new "base mesh" .obj file which contains the modified data for this particular figure.
    Would it not do so and use the original unmodified mesh instead, all your changes would be lost the next time you load your scene.

    What you've described here (figure shows in hierarchy editor but mesh is invisible) is a clear indicator that somewhere, somehow the mesh (whatever mesh) referenced in the .pz3 scene file is corrupted.
    IF INDEED it is corrupted then Poser won't send a warning (because the .obj file is there and can be loaded).
    It's just the information inside the .obj file that is bollocks!

    I bet a virtual cask of Vodka that that's the reason behind this mystery.

    B.t.w., the door handle is pointing the wrong way... (o;



  • @karina Karina, I didn't change anything. She was there one moment, and the next time I tried to open the document, She was not visible in the scene. Everything else was still there. Well, come to think of it, there is something else missing. She was leaning on a pool cue in the scene, and I just realized that that's missing too.



  • Maybe it was the clocks going back, and Dawn appearing an hour different from when you expected! :-)



  • @j.naylor:
    Now we are in trouble:

    If Dawn REALLY appeared in a different time line, she would be NAKED because obviously her clothes are still here. Now how to set a "NSFW" spoiler alert for a render from which you don't even know WHICH time line it appeared in!

    I'm afraid that @eclarke will get banned in one of those timelines for posting "nudity"...

    "Spock - could this have any consequences in "our" time line? Could it cause Lt. Eclarke to become only partially visble, or half banned? Please run an estimation of this with the data we already have. Uhura! Message to Starfleet: ..."

    --

    @ Earl:
    The additional information about the pool queue is interesting.
    I have a suspicion why this happens, but I would have to "recreate" a scene with a corrupt figure.obj before I can say anything specific.

    Did you check the file paths for Dawn's .obj file already?
    Somewhere in Poser's "Scripts" menu there's a script called "listFiles".
    The output should look something like this:

    Geometry files in use: *1

    P:\POSER LIBRARY\Runtime\Geometries\DAZPeople\blMilWom_v4b.obj
    ... etc.

    This is an example for V4 because it's what I have loaded right now.
    For you it should point right back to the original Dawn.obj file which came with Dawn:
    "\runtime\Geometries\HiveWire 3D\Dawn\Base\Dawn.obj"
    and nothing else.

    *FOOTNOTE 1:
    Could we PLEASE get a simple [CODE] tag here?!



  • @eclark1849 I have just had a similar issue in PPro 11.0.8.34338, with a prop which I had modified to use subdivision level 1. When I loaded it from the library into a new scene, the prop was not visible, but it's own child prop was. When I hovered the cursor over where the prop should be, it's outline became visible, but nothing would initially persuade poser to make the prop visible. Changing cameras, moving the camera, moving the prop, (which Poser happily let me do), changing frames didn't help. Issuing a poser.Scene().DrawAll() command in the python shell didn't help either.

    The resolution came when I went into the prop's properties and reset the Preview subdivision down to zero. As soon as I did so, it became visible again, and remained so when I returned the subdivision to 1. I know this won't help you in Poser 2014.

    Do you see a selection outline for Dawn's head when you put the cursor there? Are you able to re-pose Dawn and have the conformed clothing follow the altered pose?

    Can you change the figure display style to wireframe or something else? Can you show us a screen shot of your render and preview settings?

    What do you see in the hierarchy editor for Dawn? Is the figure set to visible but all the body parts and props (including the missing Pool Cue) hidden?



  • @anomalaus said in Where's Waldo, uh Dawn?:

    I know this won't help you in Poser 2014.

    Why wouldn't it? Poser Pro 2014 has subdivision too.


  • Poser Ambassadors

    Did you happen to use the grouping tool at some point on any item in the scene?

    If you use the grouping tool and the 'hide other objects' command, then close the grouping tool with the 'hide other objects' command still checked, then the figure will remain invisible.

    Even if you didn't use the grouping tool, it's possible this same bug is being triggered by something else.

    One thing you might try is to select one of the figure's body parts from the drop down menu and check visibility in the Properties menu. It will show as visible in the Properties menu (and the hierarchy menu) even tho it's not. So turn the visibility off and back on for that body part and the entire figure may show up. This usually fixes the problem for me. Sometimes it has to be done on each body part to get it to show properly but usually not. And it doesn't work just trying it on the Body. It has to be an individual body part. As far as I can recall it happens in PP2014 as well.



  • @AmbientShade I don't even like the grouping tool, so the answer is no.



  • I just realised something else. I did change something else in the scene. Almost everything, except Dawn and Dusk and the clothes they were wearing, and the pool cues they were holding. I deleted everything else and then loaded the scene back in. After I changed everything she stopped showing up.
    Here's a scene shot where Dawn rendered.
    0_1510626741813_poolhall.png



  • @anomalaus Figure display set to wireframe. Still not there.
    0_1510628681153_ac3f9e69-4afc-4e6d-b37f-108ffa1dd348-image.png


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.