Poser 11 Pro and Poser 10 libraries problem



  • I just installed Poser 11 Pro a few days ago.
    At the very beginning, the library was working, I was able to set external libraries and save them.
    But now, where the library resides, I have a blank box with this text:
    "Failed to load URL http://127.0.0.1:11530/nonVirtualAssets/ContentLibrary/release-1.9.1/ContentLibrary/ContentLibrary.html with error (-354)."

    Then I opened my Poser 10 and... his library is also gone (what a luck...) almost the same blank box, asking to update Flash.
    ...but it's updated.

    I'm using Windows 7 Pro 64 bit SP 1, Chrome 63..., (not used, but IE is updated at version 11), everything is updated.
    In my firewall Poser and cefclient.exe are allowed and trusted.
    Suggestions?

    Since I'm using them mostly for work, without libraries they're almost useless.
    Thanks.


  • Poser Ambassadors

    Can you load the URL directly in your browser?

    Since it did work in the beginning, and not anymore, where there any changes in your system such as:
    Windows Update (it may have reset the firewall)
    Anti Virus program update (which AV program is running, does the library load when it is off?)

    or
    Did you install new content or attach new runtimes since the last time it worked?
    It could be that the library stalls while reading the runtime trees.

    P10 and P11 have different libraries - P10 uses the IE components and flash or AIR, P11 uses chromium components and is entirely HTML5. If both fail, it looks like there is another cause as the library itself.



  • Thanks wimvdb, the last time I was able to use the P 11 library, I was able to open it in explorer (external window).
    Now, I'm unable to open it also in my browser: connection denied...
    No proxy, no changes I can find in IE settings (since almost everything program are using them...)
    I have given permissions to 127.0.0.1 in my firewall, but nothing has changed.
    It's been a long time, the last time when I messed with ports, and it was Win XP, maybe try to enable that 11530 port (or also 11630 in Poser.ini)
    Yes, I had an cumulative update in the past days.

    For Poser 10, it always tells me to install Flash, but I use Chrome, so I installed IE version as well...

    I stay away from Win 10 for all his problems, and now even Win 7 is as broken as Win 10? XD
    If I find the time, I'll try to install it in Win 10 Pro (alternative, almost unused boot, but upgraded to FCU for testing purposes)


  • Poser Ambassadors

    I know in the past (was fixed), poser library chocked on accented characters and incorrectly interpreted html code in names, so it is potentially possible that another problem of that kind is stopping the library.

    With regards to AntiVirus software - For example Avast has a "shield" feature which blocks the library. It is not its firewall but another layer of protection against malware. So something like that could potentially also be a problem.

    With regards to windows updates, always check if Windows has not reset some of the protection. It will do it with a major update (but usually not with a cumulative update).



  • Digging in Poser.ini, there's a "LIBRARY_EXTERNAL_CLIENT 0" line...
    ...and "USE_CHROMIUM 1"
    Maybe it's possible to enable them in an alternative way, as an external window.
    Or change the "FLEX_LIB_PORT 11530" or "FLEX_LIB_ASYNC_XML_PORT 11630" to other "trusted" ports...


  • Poser Ambassadors

    You can use the library from the browser itself, but you said that did not work anymore either.

    The external setting was is for PP2012 and PP2014 to enable the AIR library which is an external application, it disables the internal library. It has no use in P11.

    USE CHROMIUM enables the chrome components for the library, setting it to 0 switches the library to use the IE components. The chrome components seemed to be more stable, so that was used as default.

    The FLEX_LIB ports - not sure about those. I think they are leftovers used for the AIR library, but it is possible the P11 library uses those as well. You may try changing them, but probably the other ports are blocked as well.



  • Ok, tried to open as external library, no luck...
    Enabled ports, no luck...
    Checked firewall, all is fine...
    Given all the permissions, even to kill me...(lol), but no luck.

    If I open the link copied, when external library is enabled, something happens, but looking in the source code...
    there are a lot of invalid calls, broken or unexpected actions and so on.

    If at least I could use my "old" Poser 10. XD


  • Poser Ambassadors

    did you try and disable the AV program?
    Cause that is the most likely cause



  • Disabling or adding an exclusion doesn't changes nothing, neither in firewall, nor in AV.

    I'm starting to run out of options...



  • Something really weird is happening and I start to doubt the problem is attributable to firewall or AV.
    After I tried many times, opening and closing Poser 11 Pro every time I made a change, once in a while the library loads,
    I can use it and everything is fine.
    When I close Poser and then open it again, the library is gone, another time!

    There may be something corrupted?



  • In the meantime, I was able to "fix" the Poser 10 library editing the Poser.ini and changing:
    LIBRARY_EMBEDDED_TYPE from 0 to 1.

    It's rough, it's basic, but at least I can use it!



  • While I was able to (almost) fix the library issue in Poser 10, Poser 11 pro has still that "little" problem.
    Downloaded and upgraded to 11.1, with the full install (to be sure), but when I launched Poser for the second time, the library has vanished another time!

    It's really wonderful to use a program where almost everything is stored in the library, and you can't even load it...

    I'm starting to lose hope.
    I've tried almost everything...

    My last (drastic) solution is to uninstall everything, verify and clean any reference left in windows registry and then try to install it again.



  • Ok, if there's someone interested to solve the problem, in my very, very limited spare time I tried to find where the problem resides...

    Poser 11 seems to use IE 9 html code (as it's listed in poser.ini).
    However, both applications (Internet Explorer 11 and Chrome 63) I use (well, only Chrome to be honest...) are expecting to use something for Edge!
    So, I can start Poser 11 library in an IE window, but only if I change emulation to IE 9, and only after debugging it with development tools in IE.



  • No responses...

    In order to find an answer, I'll post some more details, hoping someone knows how to solve the problem, since this program without library is almost useless and even if the price I paid was discounted, I'll have to uninstall it and ask for a refund.

    From the message log:
    "Warning: ContentLibrary Error:
    message: Uncaught SyntaxError: Unexpected string
    linenumber: 1
    url: http://127.0.0.1:11530/nonVirtualAssets/ContentLibrary/release-1.9.1/ContentLibrary/ContentLibrary.html
    callstack:"

    It's even ridiculous that I've found more answers to this question in a DAZ forum... XD



  • @fonpaolo though I'm on macOS, I just today had to fire up Poser Pro 2014 (10) while already editing a scene in PPro11.1, in order to check something I'd done in a previously saved scene. For the first time ever, Poser 10 came up with nothing at all in the library palette. Just completely empty. I've had both PPro11.0 and PPro10 open together previously and not seen this before.

    I was specifically trying to save a pose out of the scene which I'd forgotten to do before getting heavily involved in a new scene, and was frustrated that P10 wasn't showing me any way to save a pose that I could see in the scene.

    Then I remembered that the Python Shell has a scene.SaveLibraryPose() method, which takes a file path string and has a few other integer parameters. I was able to successfully save the pose to the P11 library with that command from within P10, then see the saved pose in P11 when I'd refreshed the library view of that folder.

    Not much help to you, I'm sorry, but there are sometimes ways around apparently insurmountable problems.



  • @anomalaus I solved (almost) my Poser 10 library problem editing Poser.ini and changing:
    LIBRARY_EMBEDDED_TYPE from 0 to 1.
    It's only a workaround, it's very basic, but at least is usable... maybe also for you.

    Poser 11 Pro is totally another problem:
    When I turn on my computer, there's a probability that after a few attempts to start Poser, the library could appear, but if I close Poser and restart it, the library is gone and there's nothing to do...
    So, after having tweaked almost if not every possible permission from AV to firewall, from IE to Chrome and so on, the problem is unsolved, since I should edit the Poser files related to library management as a html page...

    Why, what's the reason to add an external application to display a library?
    I also asked the same question related to Poser 9 and 10, even worse, since they use Flash player or Adobe Air!



  • Ok, it's more than a month now...
    No solutions.

    I think that now it's too late to ask for a refund...
    This is the last time I "upgrade" Poser, neither with a big discount, nor for free!



  • @fonpaolo Hi, whenever I start poser and go to my library using the url above I get your error showing in poser. I just dismiss it. My library only has the treeview I then click on the three dots at the bottom to open the settings tray and select Item List and then resize the panes.

    Amanda



  • @amethystpendant Hi, thanks, but I don't have any dot, only a blank rectangle with nothing but that "Error..." in it.
    I'm still using Poser 10 and his "internal" library, because even there, libraries aren't working anymore...

    Starting from Poser 9, if I recall correctly, the "new" libraries have been a big problem and with Poser 10, much worse.
    But now... c'mon!
    As I already said at that time, the only reason to upgrade would've be some big changes or additions to the program or a very big discount.
    Until last month, an upgrade wasn't even to be considered, then I surrended, but it was a big mistake.

    A lot of time spent for nothing, and I have almost no time!



  • @fonpaolo the three dots are at the bottom of the library pain (pun intended)
    0_1516455840270_32b7ee63-16d8-4151-bd38-0f9d487597a9-image.png

    This is using the externnal library via chrome http://127.0.0.1:11530/nonVirtualAssets/ContentLibrary/release-1.9.1/ContentLibrary/ContentLibrary.html

    The checkboxes for treeview etc are normally hidden until you click the elipses

    Amanda