Why is DLM asking me to install Poser 11 when DLM has just installed Poser 11 ?



  • I've just downloaded and installed Poser 11 Pro (11.0.8.34338) via DLM.
    I've now downloaded the first content installer via DLM, but instead of the button changing to "Install" it's now greyed out and says "Waiting...", and it's asking me to install Poser 11.
    But I just did that already ! I just ran Poser Pro 11 from the desktop shortcut that it created to be certain.

    Once again, what's going on ?

    (note: I installed Poser 11 Pro to a non C: drive partition - I wonder if that confused DLM ? It shouldn't have, should it ? )

    0_1513334929034_WhysItAskingMeToInstallAgain.jpg



  • I should perhaps have mentioned that after the Poser 11 installation* had completed successfully, and I'd run Poser Pro 11 to verify it was working, I then moved the "Install Poser 11.exe" file to another backup drive. Surely that shouldn't have confused DLM, should it ? (and it was done before taking the screenshot in the OP)

    *An aside: I noticed that all the installer screens referred to Poser 11, not Poser Pro 11, so I was a bit worried until I'd confirmed by running Poser 11 that it is indeed Poser 11 Pro.



  • I continued downloading further content installers, but since my C drive is running short of space I moved each installer to my backup drive once the download was complete. My intention being to either copy them back one at a time to do the install via DIM (if DLM decides to actually see my Poser Pro 11 installation), or to simply run the installers manually.

    But I now notice that DLM has decided that there was an installer error.

    0_1513339135210_error.jpg



  • @3dcheapskate ...at least I thought I'd moved the Poser Pro 11 installer to my backup drive. But I'd copied it, so it was still in the DLM download location.
    I guess the "installer error" message in the previous post was a result of the MD5 calculation. If so, then DLM is now calculating the MD5 correctly again, and I'm back to DLM having forgotten that it installed Poser Pro 11 earlier today.

    DLM seems to be rather temperamental today...



  • Just saying...

    I absolutely HATE all this DLM and "Content Management" stuff!
    They seem to pamper the user with not having to worry where their stuff gets installed.
    I think that's wrong. I come from a time when we had full control over all files and folders on our computers, and each single file got installed exactly where we wanted.
    Hell! You could even install a program on Drive D, then move it to drive E, and it still worked!

    All this new crap is just making the users lose control over their computers, and if something goes wrong everybody is clueless because DLM did make brains superfluous...

    That's why i abhor DAZ and their content management, and I also avoid any DLM or "automated install routines" like the plague.

    Just let me download the full data (and not a crappy "installer" which then loads the data from the net!), and then let ME decide where I install it on MY computer, and not in places where some drugged junkie passing itself as "Computer Nerd" decides it should go for the better of the world!

    Sorry for the rant, but problems like this are the logical consequence and I'm soo sick of dealing with that crap over and over again.

    And if a DLM becomes "temperamental" then it's designer should be sent to the deepest, and the key thrown away.

    Finis.


  • Poser Ambassadors

    in the download manager preferences you can see (and change) where it stores the installer files.
    After it has been downloaded you can go there and install all the installers yourself to the location you want.

    The download manager looks at the download folder on what needs to be installed and once installed moves it to another subfolder.



  • @karina said in Why is DLM asking me to install Poser 11 when DLM has just installed Poser 11 ?:

    Just let me download the full data (and not a crappy "installer" which then loads the data from the net!), and then let ME decide where I install it on MY computer, and not in places where some drugged junkie passing itself as "Computer Nerd" decides it should go for the better of the world!

    In addition to what Wim, said (about specifying where to place the setup files), you CAN choose where you want the Poser content files to be installed.

    When you first install Poser (the application, not the content installers), you come to a "Select Content Location" screen. It gives you two options:

    --- Shared Documents Directory (the default choice), puts it in a shared documents folder on your C drive.
    --- OTHER LOCATION: Allows you to choose a directory of your choice. For example, I choose to install all of my content on my D: drive. So Poser creates a content installation path of D:/Poser 11 Content.

    After the initial setup is done, you move on to the content installers. By default, it selects "Defult Poser content location" which will install the content package in the location you specified during Poser setup (in my case, this would be D:/Poser 11 Content).

    Alternatively, you can choose another location for each content installer as well.

    0_1513375787322_content install.png



  • @wimvdb and @Deecey: Thank you!

    Yes know that I have those options in Poser, and it's a step into the right direction.
    Yet it's still error prone as you can see from the numerous threads about library problems.
    (e.g., that you have to know that you click the "parent" folder that contains the actual runtime, and not the "runtime" folder itself! Some of the major problems arise from this.)

    However my rant wasn't directed at Poser specifically. It was rather meant as a general rant about how some stupid installers rob me my control over my computer.

    As a negative example:
    Try to migrate your "Quickstart" bookmarks from one installation of OPERA to the next one: Google results
    for that count by tens of thousands.

    And if you decide to migrate to the other side;
    Good luck with organizing your library into anything that makes sense...

    Maybe I'm just too old to understand the benefits of being pampered by my computer to do things his' way, and remain sitting in my arm chair smiling happily sipping at my tea.

    I'm not of that kind, sorry.

    Now, back to topic.

    -K-



  • :chuckle: - I love the rant ! So it's not just me then... ;o)

    And now I remember. Poser Pro 2014 was the first version I had that required DLM, so I used DLM just to download the installers (because you had to, no other way to get the installers onto your system). Once downloaded I moved them all to another drive and then ran them, including the program installer, manually. I didn't install anything from the buttons in DLM.

    So I can probably just totally ignore the DLM message saying I need to install the program again (because I obviously don't - just ran Poser Pro 11 again to make sure), and run the content installers manually.

    But DLM should NOT be telling me that I need to install it again !
    I installed it via DLM.
    I set the program installation path in the appropriate installer dialog.
    So the installer (and thus DLM) should KNOW where I installed it.
    And Poser Pro 11 is still installed there - I can run it.

    So it looks to me as if DLM has got its knickers in a twist (as we used to say as kids) ! There seems to be an error/oversight in the bit that checks whether/where the Poser program itself is installed



  • This might not solve your issue, because you never stated which DLM you were using... but I had a similar problem when I used the Poser 10 DLM to install PP11... Once I updated the DLM the problems went away.



  • @rokketman I'm using the latest, DLM 1.0.6.32930. (I had an earlier version of DLM installed from back when I got Poser pro 2014. When I ran that yesterday it required me to install the DLM update and restart it before letting me proceed. I also checked the email with my Poser Pro 11 download links and it includes SMDownloadManager_win_1.0.6.32930.exe, so it's definitely the right version.



  • I tried. At least that is right.... I received a notification that 11.1 is coming out Monday. I hope I have enough data on my WIFI hot spot to download it when it does.



  • Finished downloading all the installers via DLM, and then closed DLM and ran each of the content installers (all version 11.0.6.33625) manually. Also ran 'PoserSupport.exe' (also version 11.0.6.33625) which DLM said is necessary for the 'full feature set'.

    I'm assuming that I do NOT need to run the two updates 'Install Poser 11 Update .exe' (11.0.8.34338) and 'PoserContentUpdate.exe' (11.0.6.33625)' ?

    By the way - I was amused by the 'options' I was given by 'PoserSupport.exe' for locations to install Poser content...

    0_1513433771113_options-not.jpg



  • And a more general gripe about installers in general - why is the "Installing" window so perfectly designed to prevent you from seeing the path that you're actually installing to ?

    0_1513435059946_wheresItGoing.jpg

    The window is a fixed size (i.e. you can't drag it to be wider or deeper), and usually the full path for the file being installed is too long for the available window width, which results in the upper part of the path being replaced with \...\ on the display.

    Anyway, enough complaining - time to go and play ! :o)



  • @3dcheapskate said in Why is DLM asking me to install Poser 11 when DLM has just installed Poser 11 ?:

    By the way - I was amused by the 'options' I was given by 'PoserSupport.exe' for locations to install Poser content...

    The reason that there is only one option for the Poser Support Files is because they MUST be installed in the same location that you selected for the Poser content location when you set Poser up. The support files include the documentation, the Face Room support files, and (IIRC) some additional tutorial stuff. This particular setup file installs the support files in the proper application RUNTIME folders so that they work properly.

    The other content installers don't have to be in the main application runtime.



  • @Deecey Thank you - yes indeedy !

    My tongue in cheek comment was because the "Please specify which location..." is totally spurious when there are no options.

    If anything it should say something like "THIS Poser content MUST be installed to your DEFAULT Poser content location, which is XYZ" and the only option is to contine or cancel.



  • @Deecey
    Right now I am here, desperate, because I tried exactly this, like you described. However, it seems like the DLM adds another folder level called 'Poser 11 Content' to my chosen folder 'Poser 11 PRO Content', so there is now a hierarchy 'Poser 11 PRO Content/Poser 11 Content' which is totally undesired...
    The installation of the Poser Support Files did NOT allow a choice for a custom folder to be installed to!

    Now after trying to install all the Poser 11.1 files, one of the new characters Pauline African did load, but it seems like none of the Morphs is working. I assume this is related to some messed up installation locations with that automatic 'messing' of the DLM... Probably some Python script in a wrong location, or something like this.

    I must tell that I am a really experienced Poser user (and content creator) ever since 2003, and if even ME I am not able to manage installation of the upgrade in a way which fits my existing folder structures, then I can't help asking myself, how on Earth a poor newbie should manage this...

    I'm now messing around with the Poser.ini in an attempt to finally make Poser accept the locations where my content is stored, and the same time find its 'supporting files' which seem to be loaded in this 'Poser 11 Content' subfolder to my (long existing) 'Poser 11 PRO Content' folder...

    I totally agree with Karina and with 3dcheapskate , the DLM is not helping (and the DAZ Content Manager is even worse, to say the least...), it is making things unnecessarily complicated and messed up. Every child could unzip a simple zip file somewhere and then copy this to a desired individual runtime folder. Why must I go through a complicated procedure of 'pleeeaaase' requesting a different runtime location, which in the end is not even possible for the so-called 'supporting files'? I understand if these need to be in the main application's runtime, its fine. But its not working, and as a 15 years Poser user ever since Poser 4 I feel like a stupid numbnut because I cannot even make my Poser 11.1 upgrade work... Is this what Smith Micro intends to make their customers feel like with the DLM? They better think again?

    I hope I can somehow sort out this problem on my own without going through the entire installation sequences again. Also without deleting all the preference files, because re-registering 63 external runtime folder in Poser is no fun to do...



  • @Bytefactory3D
    Apparently the bug I found is not related to Poser support files, but is instead a bug in the Pauline 2 African figure. i now found, that the morphs work well in all Pauline 2 variants, except the African character...
    Seems like the .pmd file for this character is messed up, it only has 257 KB as compared to 2,037 KB in the Pauline Asian character and the others which are working.



  • I have Poser 11 Pro installed, and the d@!#d thing is telling me I have to install Poser 11 to continue with installing the nude figures the content. I'm on a Mac. How can I force this idiot downloader to trigger the Installer? Thanks for any help.



  • I've had nothing but issues with DLM version 1.0.6.32930 under macOS Sierra 10.13.x.

    I only recently moved back to Poser. I first re-installed Poser Pro 2014 and that went a-ok.

    Saw the cheap upgrade to Pro 11 and got that. After repeated attempts, the following always happens (no matter where I put the install files):

    I can always download everything in DLM. Both the earlier 11.0.8 versions (where I started at after my Pro 2014 upgrade) and today I applied the 11.1 updates.

    The main item (Poser 11 for Mac) installs a-ok. Button changes to "Reinstall".

    Every other package (Animals, Hair, etc.) all install OK per the secondary process that runs (Apple's installer that deals with the .pkg files). That goes to completion. You get the nice green checkmark icon with success. Closing that and returning to the DLM window always then puts in "Version 11.1.0... installation error" and the button is "Reinstall". If I quit DLM and relaunch, it will reprocess all the MD5 values for the downloads and the buttons are then "Install".

    Here's the odd, but good part... everything is actually installed. I can run the application and load up all the content. This is thus a bug in DLM not knowing that files are actually installed.

    I've gone back and forth with support and they have offerred no explaining nor any help.

    So for those with this issue, see if the files are actually being installed; hope they are as in my case. Still, very frustrating!


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.