Underexposing issue in Superfly?

  • Let's say I have a room with a window that has two light props in this room and they are using ambient lights to illuminate the room. With just those two props lighting the room I get this:

    That looks fine to me for 13 samples, but if I enable the default domes ambient channel, even just at 1, I get this:

    It's like Superfly is underexposing my entire image because the dome now has some light to it. I stopped using the EZdome because of a similar issue but I'm at a loss on how to stop this from happening because even if I turn the ambient lights in my room up to 10000000000000000000000 it doesn't change the rooms illumination and it's really confusing the hell out of me.

  • @johndoe641 someone pointed out this same problem a while back. With the dome involved SF has a LOT more calculations to make so the scene is noisy like that. does not look like you needed the dome anyway.

    If this is suposed to be a day scene with light coming in through the window you could put a mesh light behind it OR make the dome ambient turning it into a mesh light. BTW. I light most of my stuff with just a dome that way.

  • @ghostship Yeah, I'd like the light to shine in, but I wanted to have a visible patch of clouds through the window, but it seems that anytime I have indoor lights set (any light in a rendered enclosure) and ambient light outside this issue crops up. If I want to overexpose certain lights for an effect, I'd like to have that control and with this issue I'm not able to do that. I can easily overexpose lights for a blowout effect using Reality/Lux but I'd prefer to keep my recent stuff strictly in Poser.

    I just rendered the image again bumping it from 13 to 30 samples. While it isn't as dirty, the entire image is certainly darker and adjusting the room lighting didn't change the low light levels.


  • @johndoe641 Does that bathroom have a fourth wall or is it open there behind the camera?

  • @ghostship It's enclosed, the only opening is the window.

    Using a one sides square as an illumination point towards the window doesn't make the issue as severe but it's still happening to a small degree. It looks like just increasing the outside source to compensate for the dimming of the indoor lighting sorta fixes the problem. But still, the exposure level on the inside shouldn't change because something outside has ambient enabled, or at least it should be a controllable setting.

  • @johndoe641 if you can open up the wall behind the camera that will allow more light to come in and it should not be so grainy

  • @ghostship I did have it set that way originally but the reflection on the towel rack and water faucet end up showing the gap. :(

  • @johndoe641 here is what I get when I have one wall missing behind the camera. What you could do is find a suitable interior image on-line and paste that onto a square and place that facing your scene behind the camera and have the ambience turned up so it's a mesh light. Make sure then that the dome/default ground is turned off.
    0_1513723820464_sun room.jpg

  • I noticed the same effect a long time ago. Bad point is that this not only happens with a sky dome outside but also if there are lots of point lights within an interior with several (invisible or partly visible) rooms.
    The effect is always the same: Underexposure that can’t be corrected by increasing the light strength in the visible part of the interior. Further more you can cook the render for ever without the noise to disappear.

  • @nagra_00_ yep. The problem is that the samples "never" find a light source and just bounce around forever. You have to light the scene like you would light a stage for a movie. What is behind the camera doesn't look real but is not seen by the viewer and helps light the parts you do see.

  • Yes thats true. Only having a problem with huge stages. I mean really huge stages like an alien spaceship hangar with lots of lights. When it comes to small lights (small angle of sight) Cycles is more like a blind fish in finding the lights. Other path tracers can do that better. AFAIK there are no ’light magnets’ or what ever that one could place into the scene to help cycles finding the lights.

  • It is not, strictly speaking, underexposure, it's too few samples. The reason is SuperFly doesn't have portals.
    The normal number of samples for such scenes is 120-150 for PT.
    Using background as a light as opposed to mesh-based env sphere/hemisphere can add 20-30% of speed here, but it can be scene-based. (SF seems to calculate priorities different for envspheres and background, plus doesn't have to calculate reflections from the sphere/ground.)
    The optimal solution probably is a small mesh light with a photo texture, a dark HDRI as a World (background) texture, and removed back wall.

  • No, there is a problem with underexposure. I noticed it with a huge interior scene with several rooms. The scene had around 50 lights. Most of them not visible as they where placed in the other rooms. Increasing the light intensity for the lights placed in the room the camera was in did not help. The render was still to dark and looked somewhat washed out. Only solution was to switch off all the invisible lights from the other rooms.

  • Set the 'clamp' option for both direct and indirect light to 0. That will give you the true brightness, at the sideeffect of possibly more noise.

  • @nagra_00_ said in Underexposing issue in Superfly?:

    The render was still to dark and looked somewhat washed out
    = too few samples
    or too few bounces (there is a reason why Blender "full GI" preset has 256 diffuse and 256 specular. Speaking of other pathtracers, Octane has something like 8/16 as default. For simple (one-room) interiors scenes in Lux 8-16 is optimal too. Default Poser values are good only for direct light scenes with a small number of lights. )
    If it was underexposure, increasing light brightness would help.

  • @stefan said in Underexposing issue in Superfly?:

    Set the 'clamp' option for both direct and indirect light to 0. That will give you the true brightness, at the sideeffect of possibly more noise.

    Yeah i think thats it.

  • Another trick you could try is to simply turn off the shadows for the walls of the room, or at least dial them down a bit in the properties tab. Might even speed up the render a bit.

  • @eclark1849 No,no, no, no. Might as well render using Poser 4 if you're going to shut off cast shadows from stuff that HAS to cast shadows for the scene to look normal.

  • @ghostship You can dial them down Ghostship. That is why they're there you know.

  • Pretty sure Superfly doesn't let you adjust the shadow intensity. Shadows are either on or off in Superfly.

Log in to reply

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.