This has to be possible with Time Machine on a Mac...



  • I foolishly jumped into updating Poser to 11.1 without finishing a current project I've been working on. Somehow, the install reset my layout to factory defaults and cleared my library pane of all added runtimes. I know I can downgrade by using Time Machine, but it's not enough to simply restore the Poser 11 folder in Applications. I also have to restore the appropriate preferences to put things back the way they were. Anyone know where those are? Not having a lot of luck digging around on my own.



  • @vagabondallen the preferences you seek are in ~<username>/Library/Application Support/Poser Pro/11. (Maybe just Poser, if you're not running Poser Pro)

    I had not run the updater, but the full installer and found that the installer had created an 11_201712190220 folder under Poser Pro with all my previous preferences, so it was just a matter of me merging the two without having to resort to copying them out of a Time Machine backup.

    Note that 11.1 has some new sections in the Poser UI Prefs_resolution.xml file relating to the new Path3D palette, so you'll probably want to compare the files and merge the differences.



  • You find the prefs under 'user/Library/Application Support/Poser Pro/11'
    On installation the content of the '11' folder was automatically copied to '11_installdate'.

    edit: anomalaus was faster ..



  • Several of the files did not properly update originally.
    Launch Download Manager, click Reload, then download the Application installer and Content. They will all be listed as 11.1 now when downloading.
    Once all nine files are Downloaded, you will see Install Buttons appear in the Download Manager, use those to install the application and all the content. You will first install the Application, then the Content Installer Buttons will appear. You must install the Support Files to have full functionality of the application.



  • And thus is occurs to me that I may not be seeing things properly because the app is broken and will be fixed now that I have the proper downloads via the Manager... will keep you posted...



  • After relaunching DM and downloading the correct updaters/installers, I ran the whole set again. Several had to be run twice or more to install without errors. I now have everything installed and up to date. However, it still reset my Poser to factory default and now I'm stuck with more lost time trying to put every custom runtime back in and resetting my layout, which won't be exactly what it was and will annoy me for months to come.



  • @vagabondallen if you have a Time Machine backup of your ~/Library/Application Support/Poser Pro/11/LibraryPrefs.xml file, you can just copy that from the backup and replace the one installed by the Poser update installer. There were no relevant changes to the standard library locations. That will just restore the library folders you added previously. Then restart Poser, of course.



  • I just replaced the ’Library/Application Support/Poser Pro/11’ folder with one from the previous version. For me it worked without a problem. Haven’t checked the Prefs_resolution.xml but AFAIK Poser is writing new ones on program exit anyway.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.