PSD issues with Poser rendered files



  • @wimvdb

    I just checked that using ACDSee. It's reporting that the PSD is 24-bit yet there's definitely an alpha as I can open it in After Efects to check that it definitely has transparency. ACDSee sees the PNG as 32-bit however & AE's fine with it as well.



  • @ma3rk
    Just tested clearing out all of my added plug-ins, pretty much everything except the required and still getting the crash. At this point, I've really nothing left to test that I have any sort of control over.


  • Poser Ambassadors

    @ma3rk I just tried it in P2014 and PS CC and that works fine.
    What are your rendersettings of which you create the PSD files.
    You do not have HDRI optimized output I assume?



  • @wimvdb

    I've just been rendering with Firefly and moderately high settings. The HDRI option was ON, but I just now turned that off & ran a quick series of exports from the same render.

    JPG - No Alpha (as expected)
    No Transp BG, just the default Poser beige as expected.

    TIF - Opens on transp bg in layer. No mask or Alpha.

    HDR - No transp, mask, or alpha

    OpenEXR - Opens on a layer with transp, 32-bit RGB. It has an alpha channel but
    solid black.

    PNG - Opening with SuperPNG, both options work where it can create an alpha
    and on a black layer OR w/o an alpha on a layer with transp.

    PSD - Opens briefly on a transp layer then crashes.

    When I use a completely different program such as Lightwave or After Effects & render out to 32-bit file such as PSD and open that in Photoshop, it comes in against the bg color as seen in the rendered image panel and has an alpha channel. It doesn't come in on a transparent layer.

    I think this is telling me that there's something not 100% compliant with Posers Photoshop exporter. Why it should work for some folk & not others is still a mystery.


  • Poser Ambassadors

    @ma3rk
    Standard CS6 does not support HDR, only the extended edition. So EXR would not work in standard edition.

    But if you turned HDRI optimized output off, it should have worked.



  • @wimvdb
    I have CS6 Extended.