Transparent issue with scattered volume fog



  • Hello

    I don't understand why I get this shadows at the legs. There are clothes wich should be totaly transparent. But if I have floor fog with cycles scattered volume I can see the transparent parts of the cloths as shadows.

    0_1515077416310_temp.jpg

    I use 28 transparent bounces
    0_1515077580958_temp2.JPG



  • @joker it's not your render settings, it's a problem with transparency in the Poser root or physical root. Switch you shader to a Cycles shader. Post up the shader if you're having issues making one in cycles and I can help you with that.



  • @ghostship

    Thank you :-)

    I just need a pure transparent shader. I tried this. but it does not work too. it's the same like poser-surface root

    0_1515086451281_temp2.JPG



  • I would also love to have a completely transparent shader that does not throw any unwanted shadows.

    Tell us! Tell us! Tell us! :D



  • My only thought now is to turn off cast shadows for that item but who know what that will look like.



  • @joker my second thought is that you might be able to use the light paths node somehow to trick it.



  • The problem seems to be that you've got (I assume) a giant box with the volume scatter and the two guys duking it out in the center. The geometry of the invisible stuff is still intersecting with the box/scatter thing so that is why you get the image of it there.



  • @joker Plug the trnsparency shader into your volume socket and see what that does.



  • @eclark1849 Thank you. I also tried to Plug the trnsparency shader into the volume.. the same result



  • @ghostship
    Thank you for your thoughts. Yes I have a giant box for the floor fog

    I have no realy experiences with the LightPath shader. In this case I have no idea how it could work with LightPath.

    I think the fastest way for me at the moment is, I do it with after works. I just redner it with and withot the tranparent cloths and correct that in ClipStudio.

    but maybe anybody find out how we can solve this issue maybe with LightPath?



  • @joker I just did a simple test with the hi-res ball and Andy. The hi res uses the scatter node and andy uses the transparent node. I don't see any at all in the render even the parts that intersect with the ball. I'll try back lighting it to see if it changes.



  • @joker make sure you have gamma corection set to 1.0 on your transmaps for the invisible stuff.



  • Are they wearing pants or something? Is that what you're trying to make invisible? Did you turn off the cast shadows on the material in the properties pallete?



  • The problem with clothes is that you sometimes want to make other parts invisible than the "body parts", for which you can turn shadows off. Sometimes it helps to scale down a certain invisible clothing part to avoid the shadows or to bend it into the body.
    But imagine a pair of trousers with an alpha map to cut off the legs at a certain point that is just not at the beginning of the shin. Although the alpha map will make the cloth invisible for plain sight, it will still throw some shadow. It would be nice if we could get rid of this once and for all.



  • It seems there is no solution for this moment. So I must correct this with afterworks.

    I often use transparent cloths parts together with volum scattered atmosphere. Maybe anybody find out any solution for this issue.



  • @joker other things to try:

    • double or triple numbers of all kinds of bounces (not transparent)
    • disable clamping (set to 0)
    • disable caustics


  • @phdubrov

    I tripled all kind of bounces. It had no effect. also disabled caustics.
    I found no "clambing" value that I can set to 0



  • I also tried the use the atmospher shader (Volume on) instead of a giant cube with cicles shader for the atphospher fog. But execpt that the atmosphere shader is unusable slow it's the same issue.