Poser Pro 11: V4.2, M4 and A4 morphs not showing up



  • Hello everyone, I'm new to Poser (and forums overall) so please bear with me if I've posted in the wrong place or forget to add something important. :)

    I know this question has been asked before, but I've yet to find an answer, so here goes: I've bought a few figures already and all have worked fine without any problems by just installing them into my runtime. Until I went and got Victoria v4.2 Base, Michael v4 Base and Aiko v4 Base from DAZ, that is.

    The figures themselves import just fine into Poser Pro 11 and I can see them all in my library, the problem is that they do not have any morphs. I know these figures work a bit differently in that you need to use an INJ (in this case for Victoria 4.2, INJ Base V4) on the figure, but it doesn't work (I have a few other figures using the same method that work, but this won't work on these figures). So I did some research and have tried the following (and probably more):

    • Checked for multiple !DAZ folders and installations
    • Initializing/Re-initializing the figures through the batch files in said !DAZ folder
    • Uninstalling all DAZ-content and installing only one figure at a time to test
    • Installing each figure into it's own runtime
    • Installing runtimes into the default location
    • Moved the !DAZ-folder to other locations, like the geometries folder as suggested in the Hivewire forum here
    • Also followed each other step in that thread plus many other similar threads from DAZ and Renderosity

    So I turn to you, my last hope. My question is (and this would also be the tl;dr section I suppose): how do I get the morphs to work correctly in Poser Pro 11?

    I run Windows 10 64-bit and Poser Pro 11 is installed in a custom location (not C:) as well as the other content for it.

    Please just ask if you need more information!

    Best Regards



  • @egisslen it's my understanding (having just gone back and looked at my own installations of V4 & M4) that the "Base" figures contain no morph packs except for facial expressions and the Community INJ channels to support your own developed morph injections.

    The way these figures are set up (at least until you save a customised figure back to the library yourself) is that the "Base" figures, whose CR2 files in the library are typically <10MB in size, contain only the actors, their joint definitions, and a base material set. All of the other goodies are incorporated into the figure during loading by readScript lines, which look like:

    			readScript ":Runtime:libraries:!DAZ:Michael 4:M4BODYGrps.pz2"
    			}
    		readScript ":Runtime:libraries:!DAZ:Michael 4:M4BODYChnnls.pz2"
    

    this excerpt from the Body actor of the DAZ People:Michael 4.cr2 file on my system. This Base file doesn't need to change thereafter, but it does rely on the user having re-executed the !DAZ:DzCreateExPFiles-M4.command (or .bat on windows) file, which provides a few folder and figure name parameters to the DzCreateExPFiles.app (or .exe on Windows). What the DzCreateExPFiles application does is scan the intended folders and sub-directories within the !DAZ hierarchy in which the application resides and add into those M4BODYGrps.pz2 and M4BODYChnnls.pz2 files additional readScript lines for every relevant morph package (purchased from DAZ and correctly installed in the same !DAZ folder) which it finds, and the same for every other M4/V4 body part as well.

    When just the Base figure has been installed, the only things in the !DAZ hierarchy for that figure will be the facial expressions and the community INJ channels, which have names like 00-ps_pe074inj_Chnnls.pz2 and 00-ps_pe074inj_Grps.pz2, which are the only two files present in my !DAZ:Michael 4:BODY folder, since I've only installed the Base M4 package and no additional morph packs.

    When I load Michael 4 from the library, he has no Body morph channels (except the empty Community Injection channels which are hidden until you inject something into them), but does have the head Base expression morphs.

    When I look at the corresponding !DAZ:Victoria 4:BODY folder, I see:
    0_1516231161494_Screen Shot 2018-01-18 at 10.18.48 am.png
    at least 8 different morph packages that I've installed for Victoria 4 over the years.



  • Now, the business with injecting morph channels separately from loading the figure, came from the early releases of these figures where the channels were loaded, but left without the morph deltas injected, because early versions of Poser could not create new channels (simply by loading a pose from the library) once the figure was loaded itself. The workaround was to have all of the empty channels there, but hidden, giving a relatively light, responsive figure for posing, until the user decided that they wanted specific morphs and chose the library INJ pose files which would inject those morph deltas (and unhide the empty channels).

    However, in the case of the Base figure, if you don't have any of the Morphs++, Muscle, Elite, Aiko4, Stephanie4, etc. morph packs installed in the !DAZ hierarchy, their channels are never created, so there's nothing to see or unhide.

    In contrast to my previous post's M4 example, my heavily reworked V4 figure has the following readScript lines in the Body actor's definition:

    			readScript ":Runtime:libraries:!DAZ:Victoria 4:BODY:00-ps_pe069_DAZ_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ1a_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXScale1_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ1b_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXScale2_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ1c_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXScale3_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ1d_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXScale4_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ2_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ3_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ4_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ5_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ6a_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXBreast1_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ6b_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXBreast2_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ6c_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ7_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ8_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ9a_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXFeet1_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ9b_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXFeet2_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:Victoria 4:BODY:00-ps_pe069inj_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:Victoria 4:BODY:00-ps_pe072_DAZ_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe082_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:Victoria 4:BODY:00-ps_mr259_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ExtraERC_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXBody_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXGenital_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXFace_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-HairStyle_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXLimbs_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXShader_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-Clothing_Grps.pz2"
    			readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-Erogenesis_Grps.pz2"
    			}
    		//readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXScale_Chnnls.pz2"
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXBody_Chnnls.pz2"
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXGenital_Chnnls.pz2"
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXFace_Chnnls.pz2"
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-HairStyle_Chnnls.pz2"
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXLimbs_Chnnls.pz2"
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-GfXShader_Chnnls.pz2"
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-Clothing_Chnnls.pz2"
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-Erogenesis_Chnnls.pz2"
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe082_Chnnls.pz2"
    		...
    		readScript ":Runtime:libraries:!DAZ:GeoffIX:Victoria 4:BODY:00-ps_pe070_DAZ_Chnnls.pz2"
    


  • @anomalaus First off, thank you extremely much for your in-depth reply. If I understand correctly from your answer, and just to clarify for anyone else having the same question, then the models (V4.2, M4, A4 and H4) do not have any morph dials for separate body parts (except for face/head)?

    The pack I got was this one from DAZ, so it includes a few morphs, mainly for Hiro and Aiko.

    After playing around a bit more with them, I realized that when adding the "INJ Aiko V4", it actually added some full-body morphs for Aiko. I guess what confused me was that trying to add the "INJ Base V4" did not do anything at all, despite there being a lot of files seemingly unused in the !DAZ folder (like this hip folder for example, among others).
    0_1516300995673_a58a1e93-e5dd-49c4-8383-93a9d4ba2722-bild.png Also, since the character morph dials looked like this (that is, not like on my other figures), I figured something was missing under Morphs and under INJection Channels: 0_1516300786067_9519a135-2387-45c2-8358-cbff5c187880-bild.png

    But if I understand you correctly, then this is working as intended? Again, thank you for your time! :)



  • @egisslen yes, that is correct. The package with the bulk of the standard V4 morphs is ps-pe_070_DAZ and is called Morphs++, which is what you might have been expecting as part of the Base package, but is actually separate. ps-pe_072_DAZ is Elite, ps-pe_073 is Aiko 4, ps-pe_077 is The Girl 4, and ps-pe_082 is Stephanie 4. For V4, the ps-pe_069_DAZ only installs the 2 Male morphs on the body (so I guess there's nothing for it to do on M4)



  • Thank you yet again for your answer, then the mystery is solved. :)