GoZ losing connection, what to do?

  • Every once in a while (always at the worst time) things go a bit wonky when throwing a figure back to Poser from ZBrush. It's like the connection between Poser and ZBrush gets lost. When this happens Poser wants to import the figure back in as a prop rather than a morph. Nope, there wasn't any deletion of geometry while in ZBrush or anything radical. Just the usual sculpting. So two questions: 1) Does this sudden "figure to prop" thing happen to anyone else? 2) When this occurs is there a solution other than starting over in ZBrush (losing hours of precious sculpting work)?

    When the connection is lost and Poser wants to import as a prop, the geometry has changed group names. The 'parts' of the prop have the names from Zbrush's polygrouping (ie, Group2338, Group6307, etc.). I've tried to manually change the parts back to what Poser expects using Modo, but no success on import. I always get the message that Poser is expecting a different vertex order (the 'prop' and the 'figure' have the same polygon count, just the order has changed). Oddly, if I don't change the part names from 'GroupXXXX' then Poser imports without error, but of course resulting in a dial that spins with no results (I assume because the part names don't match anything Poser expects, so it ignores).

    99% of the time the GoZ interchange works beautifully. Throw figure over to ZBrush, sculpt away, re-polygroup as needed while sculpting, and send the result back to Poser. No problem. But when that 1% happens is there any way to save all that sculpting work to get it back into Poser?

    Also, I've went down the route of trying to project the details from the sculpt to a new instance of the figure in Zbrush. For some areas of a figure that works, but for detail areas like eyes, projecting just won't cut it.

  • Poser Ambassadors

    Haven't used GoZ for a while, but what about if you save your work while in Zbrush (File -Save As rather than obj export), save your scene file in Poser, then close both programs. Then restart, load both saves back up & try hitting GoZ in Zbrush to send the morph back to Poser?

    Have you tried exporting the sculpt as an obj then importing it to Poser as a Full Body Morph from the figure menu (without running it through any other software)?

    IIRC the GoZ process is just transferring the changed vertex positions back to Poser. Group info shouldn't matter at all, it's the vertex order that is critical.

    Oh yeah, if you try the projection route then try storing a morph target in Zbrush before projecting. The do the projection and use the Morph Brush to erase the projection from any messed up areas like the eyes.

  • @caisson Thanks for the reply :) Yep, I've tried all the usual suspects. I save incrementally as part of my workflow so I didn't have to go back that far. For the first 15 iterations, there was absolutely no problem. On v16, things went sideways. Saving the object out as OBJ and trying to import as FBM from the figure menu fails. That's what lead me to further explore what was going on in Modo. The morph brush (ZBrush's) and projection works for some areas, but yeah, not so much for others. When exporting the sculpt out as OBJ directly from ZBrush and importing via figure menu as FBM in Poser, it always results in a dial that has no affect on the geometry (spins, no change). That was the reason I guessed it had to do with vert order and group naming. I've never been able to successfully get a direct OBJ export from ZBrush to work back in Poser. That's really the heart of my query: If an OBJ has the vertex order mucked with for any reason, is there any VooDoo one can use to remedy or is that "vertex order challenged" asset just junk? Hehe, as The Prodigy would say, "Magic People, VooDoo People" :P

  • Poser Ambassadors

    Not that I know of, but that isn't saying a lot ;)

    Hopefully others may have a definite answer on vert order.

    Out of curiosity, have you tried using the Fitting Room in Poser to transfer shapes between meshes? It's just another possibility I can think of. Will try to mess about with GoZ tomorrow, been way too long since I last used it!

  • I've had this happen from time to time for as long as GoZ has been a thing inside Poser, though it is rare. When it has happened, at least for me, it has consistently been that my GoZ install was somehow corrupted and needed to be reinstalled. -Les

  • Poser Ambassadors

    It happens once in a while to me too. If you save and close either programs it also breaks the connection, so that's not an option.

    There is a zbrush plug-in that maintains your poser groups. I've never used it and am not sure exactly where it's hosted - zbc i think - but you might be able to use that as a back-up and load it manually into Poser as a morph target. You could also try using the PML script to load the morphs.

    Alternatively, you could GoZ back to Poser periodically and save your morph in stages, just in case something happens to break the connection or you have a power failure, etc. This is the method I always use. Just name the morphs in increments and then combine them all as one once you're done with the morph.

  • Poser Ambassadors

    I belive this is the plugin you mean.

    Been a while since I used it and I think it named the groups with numbers.

Log in to reply

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.