Poser 11 crashes when you GOZ props to Zbrush.

  • @trepleen

    I appreciate the content references, but I won't be purchasing or testing any "adult related" add-ons. Not my thing.

  • @trepleen said in Poser 11 crashes when you GOZ props to Zbrush.:

    There should be an option for us to check what we want to GOZ to Zbrush.

    Actually you already do when you select the figure or prop to GoZ. So I'm not sure if there is any other thing going on, especially when I haven't been able to reproduce a crash yet.

  • OK I was able to obtain the Modern Home set. Once again, I cannot reproduce a crash when I try to export the Terrain to and from ZBrush with GoZ.

    But there seems to be something odd about the terrain prop. Here's what I did. I exported the Terrain 1 prop with GoZ, and set it to "Posed" so that hopefully it would export in the correct position and scale.

    Once into ZBrush I had to subdivide the mesh to create a morph (the resolution of the base prop is too low to work with otherwise). After I displaced some of the polygons, I dialed the resolution back to the base level before GoZ'ing back to Poser.

    Here's the puzzling part. Theoretically, all that should have changed is that the prop would just displace the vertices that I moved. But the entire scale of the terrain changed as well.

    So next, I tried to export the terrain to ZBrush without checking the "Export as Posed" option. Same thing happened.

    There's something funky going on here with the content and I'm trying to assess what the problem is. Even though I'm not getting the crash like you do, doesn't work as expected with GoZ. The only thing I can think of is it might be because all of the geometries for each prop are embedded into the single "Modern Home 1" Prop file, instead of being referenced as external objects. But that might take some more digging.

  • Poser Ambassadors

    @Deecey - the subdivision algorithm that Zbrush uses is different to Poser (which uses OpenSubDiv). I don't know if this will cause a problem but it has the potential; I'd suggest subdividing in Poser then passing that mesh via GoZ to Zbrush. Another thought, does the geometry pass Zbrush's Mesh Integrity test?

  • @caisson

    Yeah I thought of that. Unfortunately, subdividing the props in Poser causes all of the rectangles in the prop to turn to ovals. So if I subd before sending to GoZ, those "ovals" will be baked in on return.


  • More followup on the SubD thing. The readme says this product was released in 2013. When in 2013 is the question ... Poser 10 (first version to have subdiv) was released May 2013, so it may be that this model was not even built to be subdivided at all.

    If that's the case, the terrain isn't really built to be morphed. If the purpose of morphing some hills on the terrain is what is desired, there isn't enough geometry in the terrain to make that happen.

  • Poser Ambassadors

    @Deecey - sounds like you're right - rectangles turning to ovals doesn't sound good. Could you post a screenshot of the wires before & after subD?

  • @caisson
    I apologize for the size of this image, but this is full size preview, no subdiv and subdiv of 4


  • And wireframe view


    As you can see, not enough there to morph without subdivision.

  • Finally in ZBrush, including the area in the back that I tried to morph ...


  • Poser Ambassadors

    @Deecey - thanks - the ZB screen is the most interesting - looks like several pieces of closely intersecting geo, I can't tell if it's all joined or not. If it is all a single piece of mesh then ouch. Definitely not built for subD ;)

    At the base of the Geometry palette in Zbrush there is a button labelled Check Mesh Integrity, if you haven't already tried running that it may be worth it to see if it reports any problems.

  • @caisson

    First, the mesh integrity function in ZB reported 5 edges that are shared by more than 2 polygons. So there was that.

    As far as whether or not it is one contiguous mesh, I exported it from Poser and opened it up in Modo. It's not all contiguous, there are 5 separate pieces. Here's a cap from Modo with the individual pieces colored differently


  • And sub divided in Modo to level of 2


  • Poser Ambassadors

    @Deecey - thanks for the screens. Running Mesh Cleanup in Modo would give a more comprehensive list of issues if you want to, but your posts answer it for me - in terms of Zbrush, GoZ & subdivs that is plain bad geo & I wouldn't expect it to work.

    To be clear that isn't a criticism of the product - it wasn't built for subD & it renders well in Poser so it's a good product.

  • Banned

    @Deecey said in Poser 11 crashes when you GOZ props to Zbrush.:

    OK I was able to obtain the Modern Home set. Once again, I cannot reproduce a crash when I try to export the Terrain to and from ZBrush with GoZ.

    Well that sucks.

    What version of Poser 11 and Zbrush do you have?

  • @trepleen

    I am using ZBrush 4R8 P2, Poser 11.1 release build, and Windows 10 Pro.

    I also tried with Poser 11.1 and ZBrush 4R6. No crash.
    I also tried with Poser 11.0.5 and ZBrush 4R6. No crash.
    I also tried with Poser 11.0.5 and ZBrush 4R8 P2. No crash.

    Without being able to reproduce a crash using a prop that certainly produces a crash on your system, it is difficult to determine what is going wrong.

    That being said, did you follow the assessment of the terrain prop? It is not really built to be morphed, due to the fact that there is not a lot of geometry to work with and that it is not built to be subdivided. At the time the prop was built, Poser didn't support subdivision surfaces. But that shouldn't prevent the prop from loading in ZBrush, as proven by the fact that I've been able to load it without issue.