Getting Rid of Splotches



  • As you can see in the image I just posted, there are some splotches as FireFly renders. These splotches show up in the clothing in the final part of the render (it's just easier to see what I'm talking about in this stage of the render.)

    How do I get rid of these?

    I assume it is shading because light can shine through the clothing, but depending on the clothing it can range from looking okay, to looking like a moth has eaten part of the clothes.

    0_1526146860779_splotchyness.jpg



  • @dbwalton Sorry but we need an actual render of the image to see what's going on. Most likely a material setting unless this is being caused by poke-through.



  • 0_1526151307615_sample splotchiness.jpg

    No poke-throughs. In FireFly, everything is set to the factory defaults except Raytracing is checked.



  • @dbwalton so in your preview image the dark parts are clothing and the light parts are the skin? It would seem to be a bit of pokethrough to me. try using the morph brush on the clothing. Remove any subdivision before doing this to speed up the brush strokes. The morph brush is the tool that looks like a pointing finger.
    0_1526152182235_Morph brush.jpg



  • I did that before posting my question. That was my first thought that they were poke throughs so I went and loosened the blouse in the light areas. It really didn't help much. What's really bad is when it happens on things like nylons or other very form-fitting clothes.

    I'm not sure what you mean by remove any subdivisions.

    Also, I've only noticed it on conforming clothes. I haven't tried to see if it happens on dynamic clothes.


  • Poser Ambassadors

    @dbwalton - Firefly does several passes when rendering - first the IDL if enabled (red dots), then subsurface scattering if enabled, then it will run the final render. Your screenshot looks like the scattering calculation pass. As I understand it the splotches are the result of Firefly trying to figure out the SSS contribution - the darker the splotch the more obscured the SSS result is. It could be intersection of the clothing mesh with the figure, it could be transparency in the cloth material.

    How that works out when rendering will probably be specific to the material & geometry of the clothing. @ghostship's suggestion is a good one; altering the clothing material may also be worth a try. Worst case - render twice, with & without SSS, then comp the renders in an editor.



  • @caisson I was going to suggest the same thing, as I always notice "splotches" during the subsurface scattering pass, but the final render always looks fine.



  • @caisson Turning SSS off doesn't change the results, but turning raytracing off does (which makes sense). So, I played around with the various settings in FireFly and no changes.


  • Poser Ambassadors

    @dbwalton - it seems to me that the splotches correlate to the occlusion in the SSS pass -

    0_1526157627625_Sample.jpg

    That then suggests to me that the splotches are a combination of opacity in the cloth material plus distance between the cloth geometry & the figure underneath. The render result would actually seem correct to me - areas of cloth that are further from the figure will not show the skin tone.

    So to change the result I think either morph tool to alter the cloth geo, or material room to adjust the cloth transparency amount rather than render settings. Unless turning off raytracing is acceptable - I haven't done that in a very long time myself so can't remember!



  • I used to run into this problem with rendering stockings or pantyhose because of the opacity. I had to turn off raytracing for the specific clothing item.


  • Poser Ambassadors

    @dbwalton
    2 Questions here :
    a) What is your MSR setting in the FireFly render setting? => If FireFly, set it at 0.2.
    b) What is your main light?
    Go to your main light properties panel and reduce the Shadow Min Bias :

    => From the manual
    => Shadow Min Bias: The Shadow Min Bias parameter specifies how far to shift samples towards the light source to prevent self-shadowing of objects.

    On page 519 of the same manual:
    => Shadows: For more realistic shadows, use Ray Traced shadows. For your main light, start with a Blur Radius of around 10, Shadow Samples of around 40, and falloff set to constant. Also use a Shadow Min Bias setting that is appropriate for your display units setting. For example, if your display units are in inches (as set in the Interface
    Poser 11 Reference Manual tab of the General Preferences dialog), set the Shadow Min Bias to .1 inch. Adjust these settings as appropriate for your scene.

    Best regards, Tony



  • I don't really see the problem. The render looks fine. Who care what it looks like until it's done?



  • @vilters Sorry for taking so long to get back. It's one of those areas where I'm still on the uphill side of the learning curve.

    I'm using an area light, and I tried the settings you recommended, and things got worse. But, I'm not giving up on those settings. You at least pointed me in the right direction.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.