Camera positions



  • I'm setting up a new scene. It has different dimensions from that I usually use. I floated the scene window to create the dimensions I wanted in preview mode and then set the render dimensions to match the preview ones. The camera looks like it moved (it didn't) and shows only a part of the scene
    This is what I had before I changed the render size.
    0_1529708321261_what i want.JPG

    When I set the render dimensions I get this

    0_1529708345427_what i get.JPG

    I can't move the camera back because there's a wall in the way. It doesn't look the same anyhow.

    How do I make the camera stop moving? (or looking like it's moving.) Locking the camera doesn't help. And I've tried all the options in the render dimensions window.



  • @redphantom don't float the window. Set up your render dimensions and then make sure that constrain aspect is checked. cut your render dimension in half or enough that it will fit your window. Adjust your camera where you want it and it's focal. Switch the dimesion back to the full size you want to render and render.



  • If I check the constrain aspect, the dimensions are wrong. Currently, the scene is set to render a square. I'm wanting a rectangle. If I check it after I set the dimensions, I still get the wrong view.



  • TBH I've written this off as a Poser Quirk. I have an idea that it has to do with the focal length. At least that's how I fix it. My default setup is with the square, but I mostly render a rectangle now. And the camera "moves" (or appear to move) Every time. So I alter the focal a bit until it looks roughly like before.

    But I'd love to know the WHY ... and HOW to render what you see (with the bits outside of the square, just like the preview)



  • Too often I get distortion with that, but this time that worked. Thanks



  • @redphantom it looks as though you have Display>Production Frame set in the first image (the slightly greyed side panels in the first screenshot, which are outside the render area), which looks like you have square render dimensinons and not in the second image, which looks like your preview dimensions match the proportions of your render dimensions, as I can't see any greyed side panels there at all.

    If you were to turn off Production Frame in the first instance, you would see the same thing as the second screenshot, with the render area's width matching the preview window's width, but you also wouldn't see the top and bottom strips of what will be rendered (IIRC).



  • @trekkiegrrrl Yes, it is a right old PITA. It appears trying to be helpful, by adjusting the position to preserve as much of the scene as was previously visible. It seldom seems to work though. I suspect legacy code that should probably have been dumped years ago.

    As far as rendering everything visible in the preview window, the only way that automatically happens is if you have "Match Render Window" checked. Unfortunately that limits the size of the image as well. But if you then switch back to "Render to Exact Value" and keep constrain ratio checked it should render everything visible no matter the size.

    Personally I wish the render preview guide was more clearly visible. Us older folks with failing eyesight can barely see it, especially in a busy scene with muted colours. A nice bold marquee would be so much easier.



  • @anomalaus said in Camera positions:

    @redphantom it looks as though you have Display>Production Frame set in the first image (the slightly greyed side panels in the first screenshot, which are outside the render area), which looks like you have square render dimensinons and not in the second image, which looks like your preview dimensions match the proportions of your render dimensions, as I can't see any greyed side panels there at all.

    If you were to turn off Production Frame in the first instance, you would see the same thing as the second screenshot, with the render area's width matching the preview window's width, but you also wouldn't see the top and bottom strips of what will be rendered (IIRC).

    I never thought of that Production Frame. I don't think I've consciously SET it. But if I remove it, I can render the full image, just as it looks on screen :D THANK YOU! for that tip!



  • @trekkiegrrrl

    There's another way to do this in the Render Dimensions dialog, which will also allow you to render in the same aspect of the preview window, but you can also specify a higher or lower resolution.

    After you set your preview window size, choose Render > Render Dimensions. Then, in the dialog, do the following:

    0_1529866220690_render dimensions.png

    1. Render to Exact Resolution
    2. Click the Match Document Window button. The dimensions change to those of the preview window.
    3. Check Constrain Aspect Ratio
    4. Adjust either the width or height value, and the other value will change accordingly to maintain same aspect ratio


  • Deecy, that was my first method.

    What Trekkiegrrrl suggested worked this time.



  • @Deecey said in Camera positions:

    @trekkiegrrrl

    There's another way to do this in the Render Dimensions dialog, which will also allow you to render in the same aspect of the preview window, but you can also specify a higher or lower resolution.

    After you set your preview window size, choose Render > Render Dimensions. Then, in the dialog, do the following:

    0_1529866220690_render dimensions.png

    1. Render to Exact Resolution
    2. Click the Match Document Window button. The dimensions change to those of the preview window.
    3. Check Constrain Aspect Ratio
    4. Adjust either the width or height value, and the other value will change accordingly to maintain same aspect ratio

    Thre's a little thing about that method. If your default preview window is square(ish) and you want to render a landscape, the Match Document Window will still output a square.



  • @trekkiegrrrl

    We all work differently ... here's my usual process when I render a rectangular image ...

    I UNCHECK the Constrain Aspect Ratio option in the Render Dimensions dialog. Then I set the desired render size in the Render Dimensions window.

    Later, if I decide I want a larger or smaller render, I return to the Render Dimensions dialog again. The dimensions I entered are still there, but the Constrain Aspect Ratio option is back on again. This allow me to change the size of the rendered image but keep the same view.

    My normal document window dimensions are 1085 x 1031 (the values entered when I press the "Match Document Window" button in the Render Dimensions dialog.

    But the attached image shows the production frame when I specify 1200x1600 render dimensions (portrait) in one case, and 1920 x 1080 (typical hi res video dimensions) in the other.

    0_1529876972525_rectangular images.png



  • If I am stating stuff that's obvious, I apologize ... I thought the original issue was that the camera changed position when the document window was resized. Using the method that I use won't resolve that either, that seems to be a Poser quirk. I'm just explaining how I render a different sized image without having to resize the document window.



  • @Deecey said in Camera positions:

    If I am stating stuff that's obvious, I apologize ... I thought the original issue was that the camera changed position when the document window was resized. Using the method that I use won't resolve that either, that seems to be a Poser quirk. I'm just explaining how I render a different sized image without having to resize the document window.

    The thing is .. When Production Frame is active, it LOOKS like you're seeing the whole image, and when you want to alter the aspect to what's actually on screen (with the things outside the Production Frame also rendered), the camera jumps/moves/Zooms in.

    The culprit seems to be the Production Frame. If that's turned off, What you see is what you render. You can scale the render from there, but the camera stays put. Unlike when the Production Frame is visible.

    At least that has been my problem, and it sounds like the OP has the exact same issue :)



  • @trekkiegrrrl

    Ok now I get what you were saying. Hmmm ... I wonder if a bug was ever filed on that?



  • @Deecey said in Camera positions:

    @trekkiegrrrl

    Ok now I get what you were saying. Hmmm ... I wonder if a bug was ever filed on that?

    Ah so it might BE a bug and not just "Poser Quirk"? I never thought about the Production Frame until this thread. It was just something that "was there" and I hadn't even checked to see if it could be removed XD



  • @trekkiegrrrl

    I guess I never thought about it, but since it has been brought up it does seem odd that you get different behavior depending on whether production frame is on or off.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.