Making things bulge through clothes



  • Hi there, poser people!

    Yet another challenge:

    lets say I want to create the appearance of something that's underneath clothes to bulge through the fabric. in other words: stick something (which is not part of the figure itself) underneath the cloth, and have the cloth resemble it's shape from outside, what route will you guys recommend? for an example: sticking stones inside a sock, have the figure wear the socks - and see the stones that's stuck in there bulge through the fabric.

    I'm thinking fitting room in someway, or bullet physics, but I still experiment (and fail...).

    <3



  • @gsfcreator Any stone big enough to make a significant enough bulge to see, isn't one that most people would care to put in a sock. Likewise, a stone of that size isn't like to just slip into a shoe.

    On the other hand, if you're talking about things in pockets and wallets. I'd probably use the Cloth Room for that one.



  • @eclark1849 if I was dealing with realistic scenarios, I wouldn't be creating anything during the past decade...;)

    the stone was just an example. so, making something - which is not the figure - sticking through a sock's fabric = cloth room, you say?



  • @gsfcreator said in Making things bulge through clothes:

    @eclark1849 if I was dealing with realistic scenarios, I wouldn't be creating anything during the past decade...;)

    the stone was just an example. so, making something - which is not the figure - sticking through a sock's fabric = cloth room, you say?

    I'd probably go with the Cloth Room, but in that inctsnce all I'm looking for is a slight bulge shaped like an object. And for anything smaller than a book of matches, don't bother. The area of cloth you're looking to deform has to have a good number of polygons and vertices in that specific area.



  • @eclark1849 damn. I have to learn how to model, or at least improve existing models (add polygons/vertices).



  • @eclark1849 exactly, clothing designed to match the underlying figure's mesh is unlikely to have been build with the idea of being dynamically deformed with objects that have a much tighter mesh. Just imagine what mesh density you'd need to accurately represent the shape of a pocketful of marbles, for instance.

    Though I do seem to remember some long ago promo images of a lighter in a jeans pocket and a cigarette pack under a t-shirt sleeve, but that clothing may have been specifically designed with just those images in mind.


  • Poser Ambassadors

    The morph brush can do that for you.
    First you pull the clothing out far enough, an then use the fit brush to "shrink the clothing over the item". => Then you can save as a morph target for if you ever want to remove the item from under the clothing.

    If you clothing has too few polygons, use a SubD. The morph brush works on SubD meshes.



  • @vilters yes, very true. But you might have to resort to some extra subdivision on the cloth to get enough vertices to morph in the first place.

    Ha ha, isn't cross-posting fun. At least while you can still edit your posts. :-)


  • Poser Ambassadors

    @anomalaus
    LOL, just saw the same X-posting thing. LOL.
    Tja, morph brush works on SubD meshes and you can "bake down" to a lower SubD if required.



  • @vilters omg. genius. I've been creating with poser for years (!) and have so many things inside that software that I never touched before...but it's a always good to learn new things! I'll search for a morphing-brush tool tutorial <3



  • @vilters I'm trying to use the morph brush tool, and already bump into a problem just testing:

    0_1530288017812_f47ed28f-d67b-49ed-89bc-86e94812968d-image.png

    those socks are conforming to the figure. I just wanted to test the brush's abilities, so I try to loosen the fabric, or tighten it (the fix the poke-through, even though they are not my problem at the moment) but the brush just do nothing. the conforming cloth is chosen, and the figure = goal. what am I doing wrong?



  • @gsfcreator Turn the 'Action:' dial from 0.000 to 1.000 :)



  • @adp When I set it to anything but o.ooo - the dots that shows the brush area of effects are gone and nothing happens when I click :-(

    0_1530288860366_62b3c22d-4fb7-45d1-961d-3078894a2977-image.png



  • removed subdivision, the dots came back - but still the brush do absolutely nothing:

    0_1530289159468_13222ff9-4ebd-4f67-bffb-f81291f29802-image.png

    when I increase SD to 1, any of the brushes simply destroy the polygons :O :

    0_1530289236790_db6dcd14-60d5-405d-abb1-80a5b1c91704-image.png



  • @gsfcreator
    You need to set the dial to something other than 0.0.
    It's like any other morph: If you set the morph value to 0.0, nothing happens.



  • @adp its set to 1.0000 :-( and does nothing. strange.



  • @gsfcreator Reset the morph first. Select 'Zero morph', 'Zero all levels'. Then try again.



  • the morph tool doesn't always work well with subdivision. Morph it first and then turn on the subdivision. (or at least turn off the subdivision preview. )



  • @adp tried. not working :(.

    @redphantom tried as well. nothing. and now for some reason the subdivision option is grayed-out for this item (it was working a moment ago):

    0_1530291570883_743f3ea4-663a-48e1-84c3-c47bec5f6088-image.png

    Those socks went through a re-fitting to be used on sasha-16, so I tried using the original socks. they have all of the morph-brush options unavailable:

    0_1530291636808_e1bf6e58-c0e9-411a-9e38-fc45bbeec9ca-image.png

    any ideas? I tried working the morph brush with a different cloth and it works fine :|.

    update - it's working with the original socks...now I'm trying to figure out what I've done wrong.



  • @gsfcreator just responding to the image above. It seems to be at the stage where it's waiting for the user to click on the dropdown and then either select or create a new morph. Until you've done either of those things, all of the options will be grayed out. It usually happens the first time you open the Morphing Tool in a scene, and once you've started morphing, you can close and reopen the tool and it resumes where you left off, with the previously selected or created morph.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.