Superfly not using GPU? (or not using properly)



  • Hi!

    So, even though working mainly with octane lately, I still upgraded to pp11, and wanted to give superfly a try.

    it was absurdly slow, and also made my pc lag like crazy, so I let it go...I tried to use GPU render, of course, since I have a decent GPU (1080TI).

    and now...by a mere mistake...I run a default test render and was shocked to see that it was a superfly render...and it run smooth and fast without lagging anything! I opened the settings and saw that it's set to CPU!!!!

    so...can anyone tell me what might be wrong, that cause superfly to behave so bad with a GPU that's burns renders in octane and Iray like a super-nova?

    <3



  • @gsfcreator I run two nvdia cards. On runs the screen and the other just for rendering. Yes, if you run just one card in your machine it has to calculate your render AND redraw the screen. I don't watch videos or play video games while I'm using both cards for rendering. OTOH I can set it to use only the card that is not running my monitor and I can do whatever I want while it renders.



  • @gsfcreator
    Sounds like your GPU has not enough memory for the job. Reduce image size or upgrade your card :)



  • @adp it's the extreme version of 1080TI (11GB! if that's not enough I don't know what is...).

    • I render with Octane - which uses 100% GPU - and I can work and do stuff on my pc while it's rendering, without any problem...So there must be something wrong with how superfly is using my GPU (But i have no the slightest of ideas what...).


  • @gsfcreator
    Maybe simply a driver problem?



  • @adp that's what I'm trying to figure out :)



  • Possible not-complete checklist:

    1. Render in the separate process - unchecked?
    2. Try very different bucket sizes - like 50, 200, 500...
    3. Sometimes something goes wrong in SF initialization process, and render starts to crawl and hog resources like mad... What helps me: change bucket size, restart Poser, restart Win.
    4. Try to render in background. Gives me more or less Octane experience, not in speed, but in other applications performance.
    5. BPT mode almost always creates lags with GPU unless you set different kinds of samples to 1-2 and small bucket size.
    6. Drivers version.


  • @phdubrov thanks! Going to check those :)



  • @gsfcreator

    Do you have Poser Pro 11 or do you have Poser 11,Poser 11 doesn't have option to render with GPUs,only Pro do have this option

    Other than that,here are my render settings in Poser SuperFly,you can modify them like bucket size,512 works for me when I render with multiple GPUs,with single GPU I would try 256 and then try 512,with earlier GPUs(older Titan X Maxwell,980ti and 980 etc I would try 256 and with these GPUs SSS or hair is very slow,I posted on that thread on RDNA in past,I compared 780Ti and Titan X and 780Ti has been faster when I rendered SSS and Titan X has been way faster in rendering interiors)

    alt text

    @phdubrov

    I wouldn't run render in background,performance will be slow or slower,I can use my PC during the rendering with all 3*GPUs rendering,there is lag but nothing major

    With some Nvidia drivers PC will hang or freeze when you running or render in the separate process

    Always have opened Message Log,this will help you what is causing this,most common error I seen previously has been "cuctxcreate launch failed" which is down to driver and TDR

    BPT always OFF in my case when I render in Poser

    I'm using or running 388.43 driver is way older but works for me in rendering,newer drivers caused few issues in my case in Octane for 3DS Max and in LuxRender

    I would check as well in Nvidia Control panel-> Manage 3D settings-> CUDA-GPUs->All

    Hope this helps

    Thanks,Jura



  • @jura11 thank you so much for this thorough replay, Jura! I'll check this one out. I'm on poser pro 11, of course (otherwise I won't be asking about GPU rendering :) ).


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.