hands posses goes awry/not working in a scene - poser pro 11



  • I bumped into yet another frustrating issue/bug with PP11 :(. for no particular reason, hand poses just stopped working in a specific scene.
    if i start a new scene, everything is working, but this is a scene I already constructed, and started working on, and I don't wish to start from scratch all over again.

    any idea why this bug might happen? I tried restarting poser, to no avail.

    before applying hand pose:
    0_1530636038932_4e83a6b2-b589-41f4-881c-2b7ec801312c-image.png

    applying leads to this strange bug (no, all that blue mess is not part of the scene :\ ):
    0_1530636083345_7c5762a3-5279-47fa-97d7-1706de17f9e8-image.png

    then I refresh the keyframes, and the hand is just as it was before. no pose being applied.



  • Another thing that might hint at what went wrong: the character that I'm using (based on V4-->sasha-16), was saved to my library. when I load her into the scene, I get this message:

    0_1530637060940_b9da22a1-249a-4ef0-9133-001d07c2658d-image.png

    now, she is still being loaded and working and all...but...something went wrong there, for sure.



  • @gsfcreator uncheck "use binary morph targets" in your preffs.



  • @ghostship

    unchecked:

    0_1530641067479_3486989e-5355-403a-b277-e7e020c77a84-image.png

    problem persist :-( :

    0_1530641091740_f4b1ebd4-284b-40d9-9cda-97ce07f35f05-image.png



  • Update: applying "restore" to the palm of the figure solves the issue...strange indeed!



  • This appears to be a specific problem with SASHA-16 AND V4:

    I have it all the time when I apply a hand post to the LEFT hand (and ONLY the left hand!):
    The whole scene "explodes", looking like the mess you showed.

    As a workaround:
    click the pose for the left hand while having that hand selected, then (after the scene exploded) spin any dial (bend/side-side) and your scene is reverted to normal.

    However, this appears to be a general problem with DAZ's V4.2:
    Load a standard DAZ V4.2, pose her and then apply any LEFT hand pose.
    Watch her collars (shoulders) closely!

    There seems to be something weird going on.
    I'll look into that.

    Thank you for bringing this to my attention;!
    I thought it was only a problem with my Poser version (PP2014) because it never occurs in PP2012.

    Karina



  • @karina Nothing going on with my stock V4.2 when loading left hand poses.



  • Addendum:
    I just checked with some other figures:

    • Dawn1: No problems
    • Roxie: No problems
    • Antonia WM: Joint distortians on shoulders and knees
    • SydneyG2: Joint distortions at the elbows.

    (I don't have any more legacy figures to continue testing)

    As it seems the Poser hand poses don't work well on SOME figures.
    However I wouldn't say any longer that it's a problem with the figures per se; probably rather some sort of incompatibility.

    Weird...

    -K-



  • @karina Karina! so glad to "see" you here :))) (you are THE karina, that made s16, right?). the pose was indeed applied to the left hand! the scene "explodes", but anything you do after (also simply moving 1 frame forward or backwards) fix it. the thing with the hand pose not applied was fixed by restoring the hand.

    the problem is not happening with v4.2, but I really, really (I mean REALLY) rather stick with sasha-16. she's almost the perfect figure for me, since she was made for poser, is V4 in most means, accept many of my purchased characters, bends so nice, morphs right where I need them, anatomically correct, etc...she's just terrific! I hope you'll manage to find the problem's source <3.

    The poses, by the way, are any hand poses that I have (I have some especially designed for V4, and some that I created myself with sasha-16.) and also, it happens to me only in a specific scene. when I load sasha into a clean scene, everything works fine here (poser pro 11).

    kind regards :).



  • Hello @gsfcreator,
    yes I'm "that" Karina.

    I spent the last days searching for the bug, and I think I've finally found it.
    What's particularly intriguing is that not only the hip does explode, but also any clothing conformed (thus the mass of "blue" in your screencap: that's from the jeans trouser's "hip"!

    I ran a lot of tests, all in PP2014, but couldn't make a difference.
    Today it dawned upon me that I wrote before that it doesn't happen in PP2012, so I gave it a try et voilà: no more explosions, neither on the hip nor on conformed clothing!

    I tried my latest "SR1" version in PP2012 (no problems!), then saved it back by a different name and loaded it in PP2014: again no problems!

    Only problem:
    The KV weight maps were lost (i.e. NOT imported nor saved by PP2012).
    I'm currently running a file comparison between both files to see what differences there are, and that may take a while.

    Worst case scenario is that I have to redo these weight maps (if I can't copy them). But as the saying goes "first try is experimental, second is for learnig, third is good enough".

    Until I've got that worked out and integrated into SR1, you can still live with it, and the workaround is even esier than you percieved:
    Each time you apply a LEFT hand pose and the figure explodes it suffices to

    • just click on "any" dial wheel in the parameters pallette
      or click on any "Document Display Style" icon (even if it's the same as currently in use!)
    • Selecting any light, camera, prop, or body part does the same trick. (NOTE: but NOT if you select those from the hierarchy editor! You must use drop down menu, or click on on e of the camera symbols in the preview window!)

    .
    All this is extremely weird.
    .

    My best guess for the time being is that it's a Poser bug which was "introduced" in PP2014.
    By the symptoms it looks like the "update viewport" function gets stuck in an intermediate state (the "explosion") and is only updated to final state once you execute another function (spin a dial, change display mode, change camera) which forces the viewpost to update again.

    TBH I'm quite happy to provide such a simple workaround (another one!) for the time being.
    OTOH I'm quite pissed that this exactly affects my poor SASHA which is still stuggling to gain recognition as a valid alternative to other figures.

    But I guess one can't have it all...

    Karina

    P.S.:
    I'll keep you updated, I hope I can somehow circumvent this with SR1.
    Visit SASHA's page at http://sasha-16.forumprofi.de once in a while.
    Thank you!
    -K-



  • @karina thank you so much for your time and efforts, my friend!

    the bug is not a big issue for me. what fixed it here is restoring the hand! no more explosions atm (But I might be wrong...).

    S-16 is my default now, and even when that means I need to tweak a lot of poses and slowly adjust myself to her many new options, she's worth the while! I managed to import G3/G8 to poser with all the morphs, and I still rather work with Sasha & great V4 characters + some nice redspec SSS :D. I also consider PE - but It sadden me to see so few vendors creating stuff for her, atm. it's G3/G8 all over the place. maybe it will change soon enough.

    P.s - I visit the sasha forum all the time! there I'm named Dreamweaver ;) :).



  • I visit the sasha forum all the time! there I'm named Dreamweaver ;) :).

    Oh là-là!
    And I wondered why there was a bell ringing in my head when I saw your latest render over there! (the feet closeup).
    :D

    I'll get back to you at SASHA's board and try to propose some possible solutions for your particular "socks" problem.

    I'll also try to fix this "hand poses" problem if I ever find out what causes the difference between PP2012 and PP2014.

    Thank you for your input, and stay tuned!

    Karina



  • @karina sweet! :) :D



  • @karina

    I have run into similar issues with figures exploding, and most of the time it is an issue with propagating scaling



  • @shvrdavid
    Yes, I already suspected that being the culprit too, however I wasn't able to pinpoint any differences between a vanilla V4.2 and SASHA.
    If you cold give me another hint I'd be eternally thankful.
    NOTE: The explosions only happen at the figures HIP and at the HIPs of conformed clothing, which makes this extra weird.

    Thank you for your input!

    Karina



  • I found a few differences between the left and right hands in the base.

    Under translate (x,y, and z) tracking scale is 0.001 on the left, 0.002 on the right.
    The X,Y, and Z offsets (A and B) are not symmetrical side to side.

    That's all that I see in the base, And I don't think that would be all of the issue.
    I will look at it some more and see what else I can find after I get some sleep, been a long day.

    I ran into this on the first release of another figure and need to go look at what I found in that one as well.



  • Bringing this still unresolved issue back:

    I think I finally solved it.
    Look here:
    http://sasha-16.forumprofi.de/showthread.php?tid=94&pid=606#pid606
    HTH
    Karina



  • I recently troubleshooted some hand poses I'd saved for M4 that didn't work quite right, and here's what discovered when I opened them w/ BBEdit. Hand poses save the values of ALL the morph channels on each joint (over 120 in my case) in addition to the rotation values, and you don't get the option to exclude the morph channels the way you do when saving pose files. So if your figure has any morphs dialed in that affect the hands, those values will be saved w/ hand poses OR overwritten by other people's hand poses.

    So instead of saving hand poses to the Hand library, I used Netherworks' PoseWriter (which comes w/ Poser now, it's that useful!) to save only the rotation values for the hand and all the fingers as a Pose file. Then I changed the file extension from .pz2 to .hd2 and moved the files to the Hand library. They seem to work fine that way and still prompt the user to select which hand to apply them to, although I saved a right and left version anyway, just in case.

    I wonder: could some of the problems with hand poses come from the fact that they're supposed to work on either hand but actually contain data for only the right OR left hand (depending on how they were saved)? In one case I found that a hand pose did NOT work the same on either hand (it created an inverted pose instead), so in that case I just left the right and left hand poses as .pz2s but put them in the Hand library for users' convenience, and that works fine.

    And yes, I'm using Poser Pro 11 (on a MacBook Pro running macOS High Sierra).



  • @perpetualrevision that would make sense. Sometimes I pose V4 and then add a nail morph and then later load a different pose and the nail morph goes away.



  • @ghostship Yes, though I've only noticed it reset to 0.000, rather than disappearing altogether.