hands posses goes awry/not working in a scene - poser pro 11



  • @karina thank you so much for your time and efforts, my friend!

    the bug is not a big issue for me. what fixed it here is restoring the hand! no more explosions atm (But I might be wrong...).

    S-16 is my default now, and even when that means I need to tweak a lot of poses and slowly adjust myself to her many new options, she's worth the while! I managed to import G3/G8 to poser with all the morphs, and I still rather work with Sasha & great V4 characters + some nice redspec SSS :D. I also consider PE - but It sadden me to see so few vendors creating stuff for her, atm. it's G3/G8 all over the place. maybe it will change soon enough.

    P.s - I visit the sasha forum all the time! there I'm named Dreamweaver ;) :).



  • I visit the sasha forum all the time! there I'm named Dreamweaver ;) :).

    Oh là-là!
    And I wondered why there was a bell ringing in my head when I saw your latest render over there! (the feet closeup).
    :D

    I'll get back to you at SASHA's board and try to propose some possible solutions for your particular "socks" problem.

    I'll also try to fix this "hand poses" problem if I ever find out what causes the difference between PP2012 and PP2014.

    Thank you for your input, and stay tuned!

    Karina



  • @karina sweet! :) :D



  • @karina

    I have run into similar issues with figures exploding, and most of the time it is an issue with propagating scaling



  • @shvrdavid
    Yes, I already suspected that being the culprit too, however I wasn't able to pinpoint any differences between a vanilla V4.2 and SASHA.
    If you cold give me another hint I'd be eternally thankful.
    NOTE: The explosions only happen at the figures HIP and at the HIPs of conformed clothing, which makes this extra weird.

    Thank you for your input!

    Karina



  • I found a few differences between the left and right hands in the base.

    Under translate (x,y, and z) tracking scale is 0.001 on the left, 0.002 on the right.
    The X,Y, and Z offsets (A and B) are not symmetrical side to side.

    That's all that I see in the base, And I don't think that would be all of the issue.
    I will look at it some more and see what else I can find after I get some sleep, been a long day.

    I ran into this on the first release of another figure and need to go look at what I found in that one as well.



  • Bringing this still unresolved issue back:

    I think I finally solved it.
    Look here:
    http://sasha-16.forumprofi.de/showthread.php?tid=94&pid=606#pid606
    HTH
    Karina



  • I recently troubleshooted some hand poses I'd saved for M4 that didn't work quite right, and here's what discovered when I opened them w/ BBEdit. Hand poses save the values of ALL the morph channels on each joint (over 120 in my case) in addition to the rotation values, and you don't get the option to exclude the morph channels the way you do when saving pose files. So if your figure has any morphs dialed in that affect the hands, those values will be saved w/ hand poses OR overwritten by other people's hand poses.

    So instead of saving hand poses to the Hand library, I used Netherworks' PoseWriter (which comes w/ Poser now, it's that useful!) to save only the rotation values for the hand and all the fingers as a Pose file. Then I changed the file extension from .pz2 to .hd2 and moved the files to the Hand library. They seem to work fine that way and still prompt the user to select which hand to apply them to, although I saved a right and left version anyway, just in case.

    I wonder: could some of the problems with hand poses come from the fact that they're supposed to work on either hand but actually contain data for only the right OR left hand (depending on how they were saved)? In one case I found that a hand pose did NOT work the same on either hand (it created an inverted pose instead), so in that case I just left the right and left hand poses as .pz2s but put them in the Hand library for users' convenience, and that works fine.

    And yes, I'm using Poser Pro 11 (on a MacBook Pro running macOS High Sierra).



  • @perpetualrevision that would make sense. Sometimes I pose V4 and then add a nail morph and then later load a different pose and the nail morph goes away.



  • @ghostship Yes, though I've only noticed it reset to 0.000, rather than disappearing altogether.