How do I get rid of these black splotch shadows?



  • This is a firefly render. How do I get rid of these black splotches & artifacts?

    0_1531113365652_st.jpg

    I'm not using BB's environment sphere.



  • @zazop it's a problem with your shader. You will need to post up an image of your shader setup for this so we can see what's going on. I've seen it before with FF but using SP exclusively now I don't get this problem anymore.



  • Here is the shader. It's very basic. I tried disabling the spec and bump by setting the values to zero, but I still get the same problem.

    0_1531116805830_345.jpg

    I would use superfly but it would take months to learn how to setup all the materials and the render times take too long on an i7-2600k.


  • Poser Ambassadors

    @zazop
    A cloth draped over a bed? => 2 Geometries very close to each other.

    This looks like a Shadow Min Bias issue on the light setup. => Manual page 322, 519-520(under shadows).
    Go to the properties of your main light, be sure to have the light set at Raytrace shadows, and play with the Shadow Min Bias.
    When 2 geometries are close together self-shadowing can happen.



  • @vilters

    I moved the drape far away from the bed, but still got the same problem. I'll try moving it around in various places to see if it makes it go away.


  • Poser Ambassadors

    @zazop
    Remember that draped cloth can self-shadow itself.
    Euh, the cloth is single sided I hope.
    Double sided cloth will almost always show this.



  • Try setting the "Normals_Forward" on the poser root node.



  • @vilters The cloth is single sided. For example if I flip it upside down, the other side is invisible.

    I tried normals_forward but it didn't help.

    This is a tricky problem, sigh.

    I'll try playing with Shadow Min Bias some more.



  • @zazop said in How do I get rid of these black splotch shadows?:

    This is a firefly render. How do I get rid of these black splotches & artifacts?

    0_1531113365652_st.jpg

    I'm not using BB's environment sphere.

    Stop wiping your hands on the fabric after eating greasy foods. :)



  • Unfortunately, there's a problem with the Firefly implementation in Poser 11 which has degraded the performance of the ray accelerator - the bottom line is that some kinds of curved surfaces which are illuminated mostly by IDL rather than direct light are more prone to blotches than was the case in Poser 10 / 2014. I raised a bug report about this two years ago, and I'm assuming it will never be fixed, which is a shame. :(

    The thread is here if you want to read about it, although the first page and a half are mainly the blind leading the blind. ;)
    https://forum.smithmicro.com/topic/877/idl-in-poser-11-a-step-back-from-poser-10

    To cut to the chase. A few things you can try:

    • Make sure 'smooth polygons' is deselected in your render settings
    • Subdivide the item which is showing the problem (1 level is usually enough)
    • Turn down the IDL intensity to less than 1 - I generally go for 0.5 to 0.65
    • Render in Poser 10 or preferably Poser Pro 2014 - I say this tongue in cheek, but I bought a copy of Poser 10 purely for rendering difficult scenes, and I haven't regretted it.

    Sorry to be the bearer of bad news, but hope that helps somewhat.