SuperFly issue, Dreamlands Car patio renders all black.



  • It renders just fine in Firefly but that's doesn't help me. :p

    I thought it could have been file corruption so I downloaded a fresh copy of the patio from Rendo but I still get the same result in SuperFly. If I put something else that's not from that set in the scene it lights properly.

    Here's what the material room setup looks like (that's what the default setup is, I haven't changed it):

    0_1531681384655_CarPatiomaterialsetup.jpg



  • Stupid edit time limit... I forgot to mention that the textures like fine in the preview window, also Dreamlands Block 13 has the same issues except for the grass and trees.


  • Poser Ambassadors

    You got dotted broken lines on some of the nodes. Check those ones out, They are not working with SF.



  • @Ghostman Yeah, I see that now. There's a few broken spaghetti lines to a bunch of thingies. I isolated them and took some screenshots because I have no idea wtf any of this means but it makes my hungry for some pasta.

    0_1531683909977_CarPatiomaterialsetup2.jpg
    0_1531683919280_CarPatiomaterialsetup3.jpg


  • Poser Ambassadors

    Well i suck in the material room but atleast now you know what ya need to figure out. ;) hehe



  • @Ghostman Ha, well I don't blame you. I guess I could probably replace all the textures with materials from other sets. It seems daunting but a hell of a lot easier than trying to figure out all those boxes and lines. :p

    Didn't @bagginsbill do the texture sets for this one? Maybe he can tell me what I did to cause this.


  • Poser Ambassadors

    @johndoe641 said in SuperFly issue, Dreamlands Car patio renders all black.:

    @Ghostman Ha, well I don't blame you. I guess I could probably replace all the textures with materials from other sets. It seems daunting but a hell of a lot easier than trying to figure out all those boxes and lines. :p

    Didn't @bagginsbill do the texture sets for this one? Maybe he can tell me what I did to cause this.

    The message log will give you a clue what is wrong about the connections.
    Bagginsbill's materials for this set were probably done before there was superfly.



  • @johndoe641 you did nothing - all black render is correct. Some (especially advanced) FF shaders are incompatible with SF.
    But, in this particular case IIRC - most materials (not shaders!) are simple enough, so you can try to use PhysicalSurface root and plug color and bump maps there. At least it should work for dry materials.


  • Poser Ambassadors

    @johndoe641

    0_1531693444049_Message log.png

    There are multiple ways to find where the issue came from.

    • The message log icon in the upper right hand corner will change color from grey to yellow/orange when there is a problem. => Open the message log to find where something went wrong.

    • If it was a node issue; Open the advanced material room and locate the dotted lines and update those.

    As proposed, going the PhysicalSurface route is your best option.



  • @johndoe641 It is curious that there is no bump map for this as it is supposed to be concrete? Try my shader using the original texture map and set the roughness appropriately for the concrete material. Values should be between 0 (none) and 1 (full).
    0_1531695159035_texture help.jpg



  • @johndoe641 you're running Poser 11, yes? A lot of what that shader is doing, IIRC, is compensating for the lack of automatic gamma correction in earlier Poser versions. There are pairs of Color_Pow nodes on either side of the diffuse node which gamma correct and then un-gamma correct so the diffuse node works properly. Given @bagginsbill 's usual inventiveness and attention to detail, it also does absolutely nothing if the Poser version is already doing automatic gamma correction (the five nodes on the lower right), so you can remove it. For SF renders, you can just plug that Diffuse node directly into Alternate_Diffuse. The Color_Mul node can just directly multiply the Color Map with the Color Tint (simplecolor node on the left).



  • @wimvdb said in SuperFly issue, Dreamlands Car patio renders all black.:

    @johndoe641 said in SuperFly issue, Dreamlands Car patio renders all black.:

    @Ghostman Ha, well I don't blame you. I guess I could probably replace all the textures with materials from other sets. It seems daunting but a hell of a lot easier than trying to figure out all those boxes and lines. :p

    Didn't @bagginsbill do the texture sets for this one? Maybe he can tell me what I did to cause this.

    The message log will give you a clue what is wrong about the connections.
    Bagginsbill's materials for this set were probably done before there was superfly.

    Yeah I checked the log, and it's basically what everyone already said.

    0_1531723348633_CarPatiomaterialsetup4.jpg

    I'll try ghosts shader and plug in the textures, and unless I mess it up, it should work just fine. D:


  • Poser Ambassadors

    I did make the shaders for this and many other dreamlandmodels props. In fact, the idea for this one came from me. We were doing cars and I wanted a place to showcase the cars.

    And, yes, it is full of tricks to make the set work nicely in FireFly. SuperFly didn't exist. The rules for SuperFly are more restrictive.

    While it is easy to rewire my auto-GC shaders with only one change for SF, sometimes there are other things that need fixing as well.

    Let me dig this up from my archives and I'll get back to you.


  • Poser Ambassadors

    Oh - wanted to point out something. You posted a screen shot of my shader from a commercial product. That is called copyright violation. The shader in this case is not particularly brilliant, and not exactly a concern about theft of intellectual property. Nevertheless, it would be against the law and against the terms of use of both Renderosity (where you bought it) and this web site.



  • Ok, I haven't posted a response in over a week because that last reply annoyed me enough that I stopped looking in this thread. If I did or didn't violate any ToS or "copyright violation", you should have taken it to PM and not bluntly posted it in the public part of the forum. That was uncalled for.

    So, unless a moderator wants to remove my first image, it's stuck there because I can't edit my posts after a silly 2:30 and I assume I'll need to figure out the textures issues myself since it's been 12 days.