help with render settings



  • In my pictures, I have a gal with dynamic platinum hair. Most dynamic hair I have no trouble rendering but this hair is always grainy unless I jack up the render settings. Usually, I render with my normal render settings and then do an area render of just her head with much higher settings. It's usually not a big deal because it's only a small portion of the scene. But now I want to do a close up of her and the area render will be most of the image. Does anyone have any suggestions on how to tweak my render settings so I don't have to have the render take a week?



  • Here is the hair shader

    0_1531964870101_hair 1 textue.JPG

    Here are my usual render settings

    0_1531964892115_render settings.JPG

    And here is what I usually use for her hair

    0_1531964912932_render settings2.JPG

    Does anyone have any idea of what I can do?


  • Poser Ambassadors

    Cycles and Superfly can take ages to render strand hair, and even transmapped hair if there are tons of layers.

    But you can add a trick to the shader for the hair to stop calculating the trans after a certain number of jumps, then it goes transparent instead of the dreaded black you get other ways (ie , not enough trans bounces).

    Here is the Cycles way of doing it, and this works in Superfly as well.

    alt text

    The value setting in the greater than, stops calculation of the hair (assuming thats what the shader is on) at whatever number you put in there. Obviously you will have to play around with that number so you get enough of the hair to actually render.



  • How would I apply that to the shader I posted up above? This indicates using it for a transparency but there is no transparency in shaders for strand based hair.



  • The way I read it, you'd just put the MixShader of the example in between the root and your Add_Closure_4_2, and instead of the DiffuseBSDF in the example you'd just have your original shader plugged into it. But I don't claim to be an expert, it's how I've gone about it in similar circumstances and it seems to work.

    I imagine, on a broader point, that this would be useful if you want a specific material to have fewer jumps than the scene-wide maximum (set in render settings)?



  • I'll try that and see



  • 0_1532007200027_spider miki.jpg

    @redphantom this is your wavy hair for Miki 4 and the Firefly Shader you created for it. I saw this thread and was reminded that I had it. Saved me a ton of work coming up with strand based hair for her. If you get that shader to work, I'd like to see it so I can update this hair.



  • @rokketman must be the stealth hair shader :-) Can't see any highlights on that at all.

    I'm currently suffering with protracted SF renders of FF node layouts, so I'm wondering whether this Ray depth culling technique can be applied there too. Problem is, it's using alt diffuse, alt specular and translucence inputs on the Poser root node, so every one of those would possibly need the ray depth filter applied. (Before I bite the bullet and try converting it all to cycles nodes)



  • Ok. Here is how I changed the shader based on the above advice

    0_1532017137102_hair 2 textue.JPG

    Here is a sample render before it was changed using the top render settings

    0_1532017317369_40 checking the gate.png

    Here it is with the changes

    0_1532017347174_40 checking the gate2.png

    This is the original shader with the higher render settings

    0_1532017576716_40 checking the gate 3.png



  • @redphantom can you try this and see if you like it?

    0_1532022665715_Dynamic Hair Settings.jpg


  • Poser Ambassadors

    @ghostship Looks a bit like threaded paper.



  • @Ghostman yeah, the ends don't taper. I don't use dynamic hair all that much. This was a modification of my trans-mapped hair shader that works pretty well for me.



  • @Ghostman Did a little digging. The hair looking like shredded paper was from the strands being too thick, not a result of the shader. I reset all the hair groups to 1 for root and .5 for tip and that fixed the issue. I suppose I could add some density to it if needed.
    0_1532027559167_DynHairTest2.jpg


  • Poser Ambassadors

    @ghostship yeah. That looks alot better. :)


  • Poser Ambassadors

    As I learned from another thread here ... adding a color ramp might make the hair look more natural as well. Worth a try.


  • Poser Ambassadors

    @Boni
    Color ramp works very good "IF" the scullcap is UV-Unwrapped for it.
    What also works is putting a texture on the scullcap.



  • @Boni I'm testing this right now. Adding transparency into the shader adds "a lot" of time to the render. I'll make two versions one with and one without. Also note that when the hairs are slightly transparent it's possible that the hair density will need to go up as you will start seeing the skull cap and your figure will look bald.



  • 0_1532040107233_DH Color ramp 1.jpg
    0_1532040130226_DH Color ramp 2.jpg



  • Err... transparency in production SHOULD NOT be used exactly as in my example. It was only illustration/proof, not a working shader. At least it (and translucency) should be modulated with thickness.



  • @phdubrov I don't profess to be a shader guru. I just follow tutes and advice.

    I will say that, as far as I know, human head hair is all the same thickness. If we are talking about dog fur that is short and is shed when it gets to a certain point it probably gets thinner towards the ends. Whiskers on a cat taper but not human hair. No need to modulate the translucency via the hair thickness.