Getting a really strange crash.

  • Oh, managed to get it to crash again, opened another scene and rendered it a bunch of times. I then went to open the offending scene and then got the previous error, then saw a second crash error:

    Problem Event Name: BEX64
    Application Name: Poser.exe
    Application Version:
    Application Timestamp: 5a37b161
    Fault Module Name: StackHash_839e
    Fault Module Version:
    Fault Module Timestamp: 00000000
    Exception Offset: 0000281b0000281a
    Exception Code: c0000005
    Exception Data: 0000000000000008
    OS Version: 6.1.7601.
    Locale ID: 1033
    Additional Information 1: 839e
    Additional Information 2: 839ea49dd19fdc58134c3bc4f89a39f9
    Additional Information 3: dca4
    Additional Information 4: dca4f48843a343a6de53fef3cdad0166

    *edit stupid time limit for editing. I really wish it was much longer...

    *edit2 I started a new scene and imported the crashing one, same thing happens. Something directly in the scene is causing the issue.

  • @philadam said in Getting a really strange crash.:

    Give this a try:

    Regular installation and un-installation of applications on your computer can be a cause of various problems including corruption of system files. Repairing corrupt files can be very helpful in resolving error 0xc0000005.

    The following procedure relates to Windows 10 OS, but you can perform in on any version.

    Press the combination of Win + X keys to open Power User Menu.
    Select “Command Prompt.“
    Type “sfc/scannow” in the command prompt before pressing ENTER.
    The scan will automatically start running. Give it time to complete to report its findings. Now, Check and see if this solves 0xc0000005 application error for you.

    Yeah, I checked that earlier and no violations were found. Still getting the crashes with this one scene and it's crashing half the time I try to open that file. o_O

  • Oh, got a new one after saving the file as another name and rendered it.

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: Poser.exe
    Application Version:
    Application Timestamp: 5a37b161
    Fault Module Name: wxbase291u_vc_custom.dll
    Fault Module Version:
    Fault Module Timestamp: 5a37a3ae
    Exception Code: c0000005
    Exception Offset: 00000000000529a3
    OS Version: 6.1.7601.
    Locale ID: 1033
    Additional Information 1: c8dc
    Additional Information 2: c8dc68f34813b60c87545f7594f4459e
    Additional Information 3: 086a
    Additional Information 4: 086a22284b11f9dd04d57e3f903cd051

  • A bex64 error is a data execution prevention error, more often than not.

    You can turn dep off, on a global basis or add exclusions to it.

    Figuring out what is actually causing it isnt so cut and dry. It could be Poser, your video drivers, or something else running in the background.

    Have you updated any drivers, or did this start after a windows update?

  • No updates, no problems elsewhere, no changes to anything in the last two months.

    It only happens with this scene because I've tried a bunch of them and nothing else is crashing poser. I even used the DLM to install the last update and content update to see if that was the issue, but it's not.

    I still don't know what wxbase291u_vc_custom.dll or MEngineBaseReleasex64.dll do. I just find it odd that a single scene is causing all this.

  • It does seem odd that a single scene is causing an issue.
    You may have found an issue that causes it.

  • Ok, I think I've found the issue. It's specifically with this product:

    It comes with sets of headphones and I was using the version with the adjustable ear pieces. The prop seems like it's several parts grouped together (I dunno how to explain it) because it's not listed as one single prop but several parts in the props list which I can move away from the main body in the scene. I set each prop to subdivision level 1 and that sets everything off.

    I made a new scene, loaded the headphones, rendered, closed it opened it and rendered again. Everything is ok. I set the subdivision to 1 for each part, render and I get the same crash I was getting before.

    Once I set the subdivision levels back to 0 for the headphones in my old scene it hasn't given me any issues. So this seems to be what's causing the program to have a stroke. WTF

  • Poser Ambassadors

    @johndoe641 - if subD with that prop is causing a crash it must specific to its geometry ... could you set display to Hidden Line & post a screenshot of the headphones? I don't have the product but would like to see wires out of curiosity ;)

  • @caisson


    This is without subd on. I tried setting it to 1 but Poser crashed, but they headphones are fine without subd so I don't need it on. I just need to remember not to set it on with these or it crashes the program.

  • Poser Ambassadors

    @johndoe641 Why on earth subd a smooth mesh like that?

  • @Ghostman said in Getting a really strange crash.:

    @johndoe641 Why on earth subd a smooth mesh like that?

    Why would I use chocolate mixed peanut butter to make my PBJ sandwich? They say it shouldn't be done, the goverments condemn me but I march on. The mysteries of the universe! D:

  • Poser Ambassadors

    @johndoe641 - thanks - that's one high poly mesh ;)

  • Perhaps the mesh has degenerate facets (coincident vertices) which the subdivider can't cope with. Might be worth running through a mesh checker (if anyone's familiar with a free one).

  • @anomalaus UVMapper can check for degenerates :)

  • Just look at the "bolt caps" of the hinges of the earpieces! (the ones who are dark grey because the screen can't resolve the individual polygons any more)

    Those appear to have an extremely high resolution --> probably a crazy high polycount.

    Now consider sub-d'ing those, and remember that every level of subdivision will increase polycount /times 4/
    So you've probably ended up with a polycount which Poser can't handle.

    Add to that the "rounding errors" with very very small values in vertex coordinates, and we sudddenly have a mesh that "clumps" because Poser can't resolve those tiny coordinates any longer.

    What's the polycount of the mesh without SubD?


  • @karina I'm the guy that subd's super high poly objects that give Poser a stroke, could ya please tell me how to check that? :p

  • @johndoe641 that is funny as **** the way you put that.

  • @trekkiegrrrl thanks. I ask because UVMapper is now dead for OS X, since apple withdrew support for Rosetta to run Motorola binaries, and it hasn't been updated since 2006 for macOS. I know that there are other free tools (relevant to 3D printing, for instance).

  • Poser Ambassadors

    @johndoe641 Try Meshlab. It's free. ;)