Smooth Polygons Gone Wild!



  • In the past, I have enabled Smooth Polygons in the Render Settings pretty much by default, and it worked as expected. Now with Poser Pro 11, I notice something very strange. In this render, Smooth Polygons is enabled at the render setting. Notice the two benches at the bottom left and two columns on the right. In each case, one of the matching pairs had Smooth Polygons enabled at the individual property and the other disabled. Notice the extreme rounding, especially of the bench. The other props don't have any appreciable rounding at all. What's going on here? Have I just not noticed this before? Surely not. 0_1533933146406_Smooth Polygons.png



  • @ElZagna they are rounded like that for your safety.



  • Select the prop on the main screen, then go into the Properties tab of the Parameters panel and turn off Smooth Polygons on each prop.

    This happened frequently in older versions of Poser as well.



  • An example. Stonemason's Streets of NYC in PP2014 Firefly.

    Smooth polygons on Body parts "Building" and "Fence" in the Properties menu and the render settings.
    0_1533937756864_StreetsofNYC1.jpg

    And turned off in the Properties menu, left on in Render Settings:
    0_1533937811087_StreetsofNYC2.jpg



  • So I guess I'd just never noticed this before, or else I hadn't used any props that did this. It's interesting that some props do and some don't. The picnic table, for example, in my render has smooth polygons enabled but doesn't give the rounding effect.



  • @ElZagna I noticed this with PP11 earlier this year when beta testing a prop for a CA over at HiveWire, and thought I was going out of my mind. I don't recall where/how I found the solution, but now I tell all CAs I beta test for to turn it off in the Properties tab of any props they create, as a lot of folks (not sure if all) have Smooth Polygons set in the Render Settings.

    I, personally, prefer to have it in the Render Settings, so as soon as I see something blow up, I do what Traci suggested, and turn it off in the Properties tab.



  • You will see this if they modeled the prop without control edges. Using control edges keeps the model from rounding out when subdivided.



  • https://forum.smithmicro.com/topic/746/why-does-this-mesh-split-on-one-edge-with-smooth-polys-pp2014

    This has been around forever. The reply from helpdesk is that smooth polygons is meant for organic meshes and not buildings etc. (anything with sharp edges). Sometimes the mesh will be such that it hides the problem. It depends on the order of the verts in the object file as discussed in the link above.



  • @rokketman Actually Rokket, in the cases I've seen it happen, the props were rounded. One was a metal Dog Carrier, so all the "poles" were round. In another it was walking sticks, so again round. In a third it was part of a set of wings for Baby Luna, where the pieces that met in the middle of her back were 2 horizontal, and 2 vertical, wood poles, and they also were round.

    The control edges you're talking about is, for example, the sharp edges of a cube, where when subdivided will round out, so you add the control edges very close to each side of the edge so the rounding doesn't occur.



  • @rokketman sometimes subdivision works better than smoothing. I found that out with a cowboy hat once.



  • I can remember it happening on clothing as well, particularly things like straps and it something I've tried to avoid using.



  • @Miss-B said in Smooth Polygons Gone Wild!:

    @rokketman Actually Rokket, in the cases I've seen it happen, the props were rounded. One was a metal Dog Carrier, so all the "poles" were round. In another it was walking sticks, so again round. In a third it was part of a set of wings for Baby Luna, where the pieces that met in the middle of her back were 2 horizontal, and 2 vertical, wood poles, and they also were round.

    The control edges you're talking about is, for example, the sharp edges of a cube, where when subdivided will round out, so you add the control edges very close to each side of the edge so the rounding doesn't occur.

    That is what i was talking about. Control edges will keep an edge sharp when you use sub D or smooth polygons in the render. I used to see it all the time when I first started modeling. The model looked good in Wings, and had issues in Poser because of smooth polygons being checked in the render.



  • @rokketman Ahhh, OK. I've only started seeing this recently, and only with round, pole-like objects. I don't model many things shaped that way, so I'm more used to using the control edges as well, unless I want a beveled edge.



  • The effect appears when the model has adjacent facets with a large difference in length of the edge and there is an angle between the edges meeting at the common vertex . The smoothing bends edges so there will not be sharp corners. When edges are long, you will notice the bending. The table top most likely has no vertices along the length of the table.

    You can make individual choice per actor in its settings. General rule is use it for actors with organic shapes and switch it off for 'fabricated' shapes.

    The smoothing takes extra time in render so there is an override switch to skip it if you do not need it for your (test) render.

    If your actor needs to combine both types of shapes, isolate long facet edges with a short edge in exactly the same direction.



  • For props it is an easy fix. I run in to it in figures (cars, architecture sets). I did a python script to toggle the smoothPoly flag for all parts of a figure.
    https://sharecg.com/v/82522/view/11/Poser/Figure-Smoothing-Toggle

    Bill



  • @ghostship Sometimes I come here just for the comments. I was not disappointed. :D



  • Extra Comment. Does everyone here subdivide as well? I rarely used smooth polygons. (which are rounded for my safety) I also use box, rather sinc or gaussian and leave gamma correction on. I thought I found a happy medium between speed and quality considering my middle range machine but now I'm not so sure.



  • @willyb53 said in Smooth Polygons Gone Wild!:

    For props it is an easy fix. I run in to it in figures (cars, architecture sets). I did a python script to toggle the smoothPoly flag for all parts of a figure.
    https://sharecg.com/v/82522/view/11/Poser/Figure-Smoothing-Toggle

    Bill

    Thank you sir. I'm running into some instances where I need to do this, and so far have only come across one vendor at Renderosity who actually mentions turning of Smooth Polygons in the render settings for one of his products I just picked up the other day.

    Needless to say, this will definitely come in handy.



  • @maestro Yeah, Rob. I tend to subdivide the figures almost every time I render now. some of the things I model I will subdivide once I have time in the scene and run cloth sims or whatever I am doing with it. I am modeling now with Poser Sub-d in mind now. Knowing I can do that in Poser makes it easier for me to keep the model low poly and still look right once I use it in a scene.



  • I will pick up the script just because if Miss B thinks it's important, than it is. But I'm wondering. Sub Dividing polys means increasing the poly count. Won't that increase your render time as well? I hate longer render times.
    Example