Anybody using the 3D Mouse SpaceNavigator?



  • Hi folks, moving around big scenes is tedious, so I treated myself to a 3DConnexion SpaceNavigator. Really cool as you use it in tandem with your mouse.
    It works more or less out of the box with a lot of programs. But in Poser (PoserPro 11, 64 bit) all I can get it to do is zoom in and out, even though I activate everything like pan/rotate/up/down for poser.

    Reinstalling doesn't help, 32-bit Poser version doesn't make a difference, 32-bit version of the device drivers won't install on a Win7 64 bit.
    All I can find on the internet are users who are really glad with their 3d Mouse (won't go back etc), but no tips and tricks how to use or activate or whatever.

    So either this is a works-out-of-the-box thing, that apparently doesn't work for me, OR I'm missing something simple or not doing something I should be doing.

    Any thoughts, experiences or feedback?



  • I have been usigng this thing for a few years now and for me the navigaton works perfectly in all Poser versions and
    The only thing that is missing in Pro11 (and Pro2014) is that the possibility to switch between object manipulation and camera manipulation appears to be gone, but maybe I need to set the function button.
    However this switch made me just confused so I am better off without.



  • @F_Verbaas OK, thanks. But this is an out of the box experience, or do you have key combi's to activate or switches to set in Poser or in the SN control panel?



  • @BobM
    No, not really. It was just plug and play.
    what does it do with say Blender or D..Studio?
    In the mena while found again why I lost the toggle etc.
    I had made a special setting for Poser but not told SpaceNavigator that I had a new Poser executable. LOL!



  • @F_Verbaas Well, good for you for your lost toggle. Good suggestion. Daz has the same error/limitation. Default is Rotation only with push/pulling the top of the knob, which zooms in/out just like Poser. The moment I add other knob functions it stops working at all, just like Poser.
    In Blender I can make myself sea-sick zooming thru 3D-space any way I want, as I had expected. If you click restore defaults in the 3dconnexion manager it has all functions selected, unlike Daz and Poser.



  • I've had a Space Pilot for years and it works well. Do you have the latest software installed? It has settings for each applications...

    http://www.3dconnexion.com/service/drivers.html



  • @wandw Yes thank you Wandw, but I have the latest drivers.



  • This post is deleted!


  • @xen
    I forgot how the toggle worked. Guess it was one of those hidden keyboard shortcuts Poser has.



  • Did you get this working? I've been using the Space mouse in Poser since it was in beta. I never had it do what you describe.

    It should "just work" once the driver is installed. Also install the driver that matched your OS bits 32 or 64 bit. The bits of Poser shouldn't mater.

    In the 3DConnexion control panel on the advanced page make sure the Pan/Zoom and Rotation boxes are checked. Also make sure all the control axis are checked active. Make sure you open the 3DConnexion panel when Poser is active. It's settings are application specific and it detects the active app automatically.

    Now in side Poser there are some setting in the Preferences > Interface tab. You can reverse the behavior of certain functions. I keep my cameras reversed. but this is a personal preference. I never use the posing controls.



  • I am having exactly the same problem. The SpaceNavigator works in other applications just fine (3DS Max and Maya and others), but I only get the zoom in/out in Poser Pro 11. Note that this is a brand new installation of Poser Pro 11. I've not previously used Poser. I am using the most current 3dconnexion drivers as well. I can see the configuration dialog box and have enabled everything, including Pan/Zoom and Rotation. I am using the 64 bit version of both Poser Pro and the drivers.



  • @nerd3d Hi, Thanks for your feedback, but nope not working yet.
    I've put the question to 3DConnexion describing that I had enabled everything, just like you suggested and their feedback was to enable everything. So obviously this is not something they see often. Major bumzer, but one day it will work I'm sure.



  • @cbowen Well at least we can form a support group now. ;-)



  • Just to be sure: in the advanced setup did check all channels are enabled (the checkboxes).

    Also: for speed you push the sliders to the far right?
    That is something I noted I had to do recently, guess it was after a driver update or Windows update. The response appeared more sluggish than before, and certainly more sluggish than I like it to be.

    0_1470601030551_Knipsel.JPG



  • Did you check it with other Poser cameras? The rotation won't work on the orthogonal cameras, of course, but perhaps there is an issue with the parameter settings for that particular camera...



  • I just tried uninstalling the drivers and installing an earlier version 10.3.0 that I got from the archived drivers section. That version worked perfectly in Poser Pro. Then I downloaded 10.4.3 and installed it (updating). It also worked perfectly in Poser Pro. Finally, I updated to the current driver 10.4.4 just to see if it would still work and it does still work.

    This is likely an indication that something is broken in the 10.4.4 installer, likely some file or setting that is not being set. A previous version did set or install that and an upgrade then works for 10.4.4 because the file/setting is still there from the previous version. I don't know if going back to just 10.4.3 would work or if you would have to go back to 10.3.0 like I did to get it work, but this does fix the problem.



  • @cbowen Brilliant! Hadn't thought of that. I downgraded to 10-3-0 like you did, and everything started working. Upped to 10.4.3 and still working. If I go to 10.4.4 my config stops working though.
    But 10.4.3 does the trick for me, so all of a sudden I'm OUT of an expensive paperweight but WITH a 3D mouse. Kewl.
    Thanks everyone for all tips n tricks.

    Oh, BTW, the last advice 3Cconnexion Techsupport gave was to contact Smithmicro.
    I'll restrain myself from going into a rant, but clueless and useless would be part of that rant.
    I did let them know what a/the working solution was, so hopefully they'll get it fixed in v10-4-5 and LEARN something while doing that.

    Thanks all & of course kudo's to @cbowen who just made my day!



  • Sorry, I couldn't help myself but 3DConnexion DOES do a survey monkey review of your experiences with their tech support, so just for a chuckle I'll share my parting thoughts to them.

    "As you see I'm not impressed with your support. I'm not griping about the fact you didn't find a solution (being downgrading to a previous version of your driver software).
    I'm griping about the fact that the first advice was just boilerplate for something I had already done. So my question apparently was not read.
    And then the second one the advice to contact the manufacturer of the software package it wasn't working in. As Poser is listed on your site as being supported, this should be one of the last steps when everything else had failed.
    At no time did I get the feeling that somebody was really reading my question or seriously contemplating doing some actual work. Or getting curious by the fact that something that's working for 100's or 1000's of other Poser users wouldn't be working with my config.

    An experience COULD and SHOULD have been (real life experiences): 'that's strange, we tried it out here, and here it works, what could be the next steps for you to try' etc
    And frankly I think going back to a previous driver version should have been suggested. I've seen a lot of long time Poser users who all indicated that it was an out-of-the box experience, so obviously it's been working for a long time and thus should have worked for any new installation.
    Now I found it on a forum from somebody who was experiencing the same challenge.

    I'm taking the trouble sharing this with you so you'll be able to better help others in the future and maybe pep up your support."



  • So for both of you there was something funky with the 10.4.4 driver? I'll see if we can get a ticket going at 3DConnexion.



  • @nerd3d Yep, both had new installs of Poser11 (although I have previous versions of poser on my system). This was my first time Space Navigator, so I didn't have any previous versions of the drivers on my system. I get the impression that this is the same case for cbowen, although it's not really stated. His/her SN kept on working including 10.4.4, while mine stopped working after 10.4.3.
    Strange, but there you go.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.