Poser refusing to start up after Time Machine restore



  • Okay, this is a strange one. I recently restored my iMac using a Time Machine backup. As expected everything is back to the way it was on that date... except for Poser that is. Well it all seems fine, with everything accounted for... but it refuses to start. Not even crashing in the normal sense with a pop-up asking if I want to report the error, nothing.

    So I've had to fire up the Console to even get any idea of what is happening and this is what it says when I try to start Poser Pro 11. I really hope someone can help...

    ===========
    7/08/2016 12:59:02.409 PM Poser[1658]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.6 instead of 10.11.6. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
    Call location:
    7/08/2016 12:59:02.411 PM Poser[1658]: 0 CarbonCore 0x00007fff8a5956df ___Gestalt_SystemVersion_block_invoke + 113
    7/08/2016 12:59:02.411 PM Poser[1658]: 1 libdispatch.dylib 0x00007fff8864d40b _dispatch_client_callout + 8
    7/08/2016 12:59:02.411 PM Poser[1658]: 2 libdispatch.dylib 0x00007fff8864d303 dispatch_once_f + 67
    7/08/2016 12:59:02.411 PM Poser[1658]: 3 CarbonCore 0x00007fff8a521fbc _Gestalt_SystemVersion + 987
    7/08/2016 12:59:02.411 PM Poser[1658]: 4 CarbonCore 0x00007fff8a5217d0 Gestalt + 139
    7/08/2016 12:59:02.411 PM Poser[1658]: 5 Poser 0x0000000103cc753d main + 61
    7/08/2016 12:59:02.411 PM Poser[1658]: 6 libdyld.dylib 0x00007fff988df5ad start + 1



  • When I upgraded my os and restored my machine from a time machine backup I had to reinstall and reactivate the license. you might want to try reinstalling the app isself.

    Also in the console log on the left hand side check the system diagnostic logs look for the latest poser entry and click on that to see what it says0_1470616594906_Screen Shot 2016-08-07 at 8.35.36 PM.png



  • Thank you for the reply David. Unfortunately even when I tried re-installing Poser the new Poser.app did exactly the same thing. Moreover, I can't seem to find anything Poser under the System Diagnostic Reports... probably because the app refuses to even launch...

    This is depressing, being completely locked out of Poser. :(


  • Poser Team

    I ran into a similar issue in Windows when doing a system restore. In the end I had to remove the license files and then i would launch.
    I have no idea where those would be in a mac thou.

    Googling the error you posted doesnt bring up much other than a Java conflict.

    Have you started a ticket on the issue? If not I recommend that you do so they can get you up and running.



  • @shvrdavid Bang on the money, I contacted support and they gave me the location to delete it and now it works like a charm. Really happy to have it back.



  • What was the location?



  • I had tried to deleted the folder at ~/Library/Application Support/Poser/ with no luck while trying to figure out how to fix the problem, but it turns out there is also a Poser folder in the Application Support folder in /Users/Shared/



  • ah I forgot about that /users/shared/library/application support/poser

    I moved all my libraries onto an external drive and forgot that was there. Thanks.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.