Material Problem



  • @wimvdb Yah, I don't know what it is. I completely resetted my PC (which is fairly new) to have a fresh new Windows 10 clean install. I thought maybe it was the graphics adapter driver but that is up to date. Someone else here mentioned earlier that the Yellow bricks showing (when it should be red) in the Material room is a bug in Poser.


  • Poser Ambassadors

    Right click on the box.
    Select object style
    What does it say?

    Does it change when you click Ctrl+9 (texture shaded)

    You have Display (Top menu)
    Then :

    • Document style
    • Lower => You have Figure Style and Object style

    And then you have the "right click on the box itself"

    There must be an inconsistent setting as all is working as it should here.



  • Prior to placing the brick texture on the box, I went to the menu and made sure that my document style and object style is set to Textured Shaded.

    I then inserted the box from the props library. Then, I went to the paint icon to drag in the brick layer 1 texture onto the box. The box then does a quick highlight with a red outline, but the brick does not appear.

    I right click on the box and it still says Textured Shaded.

    0_1471180159479_material-problem-6.jpg


  • Poser Ambassadors

    I can duplicate:

    Goto Top menu => Display
    Select Document style, st to Texture shaded.

    That setting overwrites the object style that you get when you right click on the box.


  • Poser Ambassadors

    Toggle

    Ctrl+8 (Main keyboard)
    Ctrl+9 (Main keyboard)

    Or Cmd +8 and Cmd+9 when on a MAC



  • Yes - that's what I did, I set my document style to Textured Shading

    The object style is set to follow to figure style (which is shaded out cause there's no figure on the screen). I tried both, with that setting, and by setting object style to Textured Shading. Results are the same regardless.

    After placing the brick image on to the box, the box outline turns to red, but the red brick doesn't show.

    I togged between Control 8 and Control 9, but the box remains the same.



  • I also tried applying the other Basic Material texture to the box and it does show some color in Preview Mode (but not the actual image).

    See Below images:

    Glass:

    0_1471183242683_material-problem-7.jpg

    Metal:

    0_1471183263609_material-problem-8.jpg

    Stone:

    0_1471183284539_material-problem-9.jpg

    Woods:

    0_1471183581289_material-problem-10.jpg

    With these other material texture added, do they look right? All I see is the color of the selected material but not the actual texture of the material itself.

    And if all those other Basic Material choices (glass, metals, stones, woods, etc.) are showing something in the Preview mode, then it's odd why none of the Brick and Tile image are appearing at all - not even the color.


  • Poser Ambassadors

    This is how they look in preview here.
    0_1471184129095_Display settings.jpg


  • Poser Ambassadors

    But a little warning here:

    As these are all very- very- very OLD material setups.....
    Most render like: "What the HELL !!!" in the newer FireFly and SuperFLy.
    LOL.

    These could all do with an update.



  • Here's another wild guess but do you perhaps have the toon shading on?



  • If you're talking about Document or Object Style, it is set to Textured Shading (not Cartoon). My Firefly Render setting also have Toon Outline turned off.



  • Twister1996, did you manage to solve this issue?
    I think I'm experiencing exactly the same (see my thread floating around)

    Thank you!



  • @erwin_sc Unfortunately no, this problem viewing material in Preview mode has never been solved. I'm glad to hear that I'm not the only one. This tells me that it might not be my PC or graphics display adapter.

    I had a similar problem with eye maps not appearing in Preview mode but when I toggle from Open GL to SreeD view, the eyes appears.

    0_1472837700037_OpenGL-Preview.jpg

    0_1472837711704_SreeD-Preview.jpg



  • Thank you,
    that's interesting, I had the same problem with eyes (except mine were totally black - at start) and the issue vanished when changing to SreeD, like it does for you.
    But I had strange artifacts on faces with SreeD, plus OpenGL gave better performances, so I tried messing around with eye materials,
    and found that altering some detail (I can't remember which one for sure but I could look into that if you are interested) eyes became at first white (like in your picture) and then after additional tweaking I got them reasonably colored/textured (maybe I set something transparent, or changed specular colors and position of lighting).

    Though reading your detailed report again, I'm under the impression there's a little difference in the fact that I can't see the "brick" texture (nor other materials I tried) in the "ball" primitive either!



  • @erwin_sc When I toggle to SreeD mode, I can see the eyes but it ends up disabling comic book mode (the Cartoon Settings are all grayed out for some reason). Therefore, I have to toggle to OpenGL to access Cartoon Setting previews.

    I take it that you have the same problem I posted above? If you have time, try to duplicate the 5 boxes above using the same texture maps from the paint library. If it looks the same, then it might not be the graphic display adapter.



  • @Twister1996
    here's my preview | render of those cubes with the same materials you used:

    0_1472850637683_CUBES.png

    I think they look the same as yours?

    For eyes issue, not sure if I worded it correctly, but to make sure:

    • in SreeD preview, I can see the eyes
    • in OpenGL preview, I couldn't see the eyes at first, but after some tweaking of eye materials, they finally showed up

    Your writing on graphic cards made me think I never updated drivers of mine :D (and therefore OpenGL version, I guess) that's something worth to try... going to do that now, will report back if any good news.

    Btw, I'm using a definitely inadequate machine, consisting of:

    Intel NUC i5
    Intel HD Graphics 5000 video card

    maybe by chance you are using a similar video card?

    EDIT: graphic card drivers updated - no change :(



  • @erwin_sc I have an Intel HD 4400, seem similar to yours. Nothing fancy but it should get the job done.

    Yep, your previews look similar to mine. Then it probably isn't a faulty graphic display adapter. Sometimes, it's good to try to rule things out.



  • @Twister1996
    Would be interesting having feedback from other Intel HD Graphics users.
    Who knows... may not be a chance we both have this issue on a similar graphic card?

    But I guess it's a quite widespread graphic card family, so maybe the issue should be more widespread as well..?

    Btw, since I was distressed by not being able seeing materials in preview, I made some testing during last days (before having that dreadful "crash" issue I'm talking about in the other thread.. :(( ) and found that "image_map" textures did show in preview, so I ended up using those when I couldn't do without the preview.
    Surely not a solution and quite limiting, but maybe could be useful to know in desperate situations.. :D
    (assuming the same applies to you)